Page 2 of 2

Re: Google Base Improved v1.5b for OpenCart 1.5.x

Posted: Sat Jul 12, 2014 8:40 pm
by brydges
Hi,

I know this is an old thread but i still use this as opencart one seems to not work with my google base account, it always returns no brand.

However my feed has stopped working, i have altered my cart to add tax at the checkout so the product price is excluding VAT.

My problem is that this is calculating the overall total including VAT so google takes that price, then there bot checks my website and sees the price without VAT so they disapprove of the item.

From my understanding this is whats causing the problem :

Code: Select all

 // Add price
                $special = $p['special'];
                $price = $this->tax->calculate(($special ? $special : $p['price']), $p['tax_class_id']);
                $item->appendChild($this->_c('g:price', $price));
I have tried many things before posting on here, but i just cant seem to remove the tax without getting errors

Any help on this matter would be much appreciated

Thanks

Re: Google Base Improved v1.5b for OpenCart 1.5.x

Posted: Sun Jul 13, 2014 11:25 pm
by rhole
Did you sort this?

Re: Google Base Improved v1.5b for OpenCart 1.5.x

Posted: Mon Jul 14, 2014 5:15 pm
by brydges
Yes i managed to sort, i was been a bit silly really - easy fix, do you need?

Re: Google Base Improved v1.5b for OpenCart 1.5.x

Posted: Sun Aug 02, 2015 7:34 pm
by boredmind
I gave the same problem and I noticed that the problem is in the name column of oc_product_description table. Probably it's the same problem with invalid characters,do you know which characters are invalid? In order to search for these and replace because my table have more than 10000 rows.....