Post by msltd11 » Thu Oct 06, 2011 7:49 pm

Hi,

I am new to open cart when trying to submit site map to google using the google site map link provided within opencart i get the below error on google webmaster tools

Sitemap is HTML
Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.

weblink to google site map is domain.co.uk/index.php?route=feed/google_sitemap

currently using 1.5.1.3 with no mods.

Newbie

Posts

Joined
Thu Oct 06, 2011 7:46 pm

Post by uksitebuilder » Thu Oct 06, 2011 10:30 pm

The sitemap is returning errors at a guess which Google is interpreting as HTML

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by sanne » Mon Oct 17, 2011 3:41 am

I have the same problem with 1 site in 1.5.1.3
My other site does not have this problem.

Is there more info on how to solve this?

Sanne

Mikado martial arts -martial arts books and DVD's
Tai chi toko - Everything for tai chi and Qigong
The pocket-stick shop - kubotans and tactical flashlights


User avatar
New member

Posts

Joined
Wed Sep 15, 2010 4:44 am
Location - Almelo

Post by uksitebuilder » Tue Oct 18, 2011 7:26 pm

a link might help ?

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by sanne » Tue Oct 18, 2011 9:28 pm

Hello,

I think I already solved it. The productnames had some invalid characters voor the sitemap.

The link is
http://www.mikadomartialarts.nl/index.p ... le_sitemap

Sanne

Mikado martial arts -martial arts books and DVD's
Tai chi toko - Everything for tai chi and Qigong
The pocket-stick shop - kubotans and tactical flashlights


User avatar
New member

Posts

Joined
Wed Sep 15, 2010 4:44 am
Location - Almelo

Post by uksitebuilder » Wed Oct 19, 2011 12:44 am

seems to be fine now

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by siloam » Mon Oct 29, 2012 4:17 am

Hello,

I have a strange google sitemap bug too.

http://artificialflowersworld.com/index ... le_sitemap

I don't know what's wrong, but google doesn't want to accept this :/

Any ideas?

Biopaliwo
My last work: Artificial flowers in Ireland


New member

Posts

Joined
Sun Sep 25, 2011 3:44 am


Post by siloam » Mon Oct 29, 2012 6:57 am

Strange. I checked my sitemap via http://www.xml-sitemaps.com/validate-xml-sitemap.html and it seems that there is no errors. So why I can see an error message in my webmaster tools account?

Biopaliwo
My last work: Artificial flowers in Ireland


New member

Posts

Joined
Sun Sep 25, 2011 3:44 am


Post by siloam » Mon Oct 29, 2012 7:27 am

Solved! Google Webmaster Tools treat google_sitemap page as na normal page. Not as sitemap. .xml extension is required now.

Biopaliwo
My last work: Artificial flowers in Ireland


New member

Posts

Joined
Sun Sep 25, 2011 3:44 am


Post by netstrada » Wed Dec 23, 2015 2:32 am

so how to change it for .xml ?

Newbie

Posts

Joined
Fri Jan 04, 2013 2:40 pm

Post by uksitebuilder » Wed Dec 23, 2015 4:27 pm

Previous poster was incorrect.

However, if you really want to submit it as sitemap.xml then most likely you already have that set-up in your .htaccess and as long as you have that file enabled (e.g. renamed from .htaccess.txt to .htaccess)

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by dochsa » Wed Feb 03, 2016 5:38 pm

Hi All

I really need some help, with Google site map, we have spent hours on a developer and discussing with our hosters and Google and still have not found a solution. So any help or insight is much appreciated.

Out sitemap is:
https://shop.dochsa.com/index.php?route ... le_sitemap

We had shared hosting and the site map worked fine and Google was crawling the site. Because of speed issues we moved to VPS. Since then we have the following errors on Google Web Master Tools:
# Type Issue Description Issues count Example Line Detected
1

Errors
Invalid URL
This is not a valid URL. Please correct it and resubmit.
8
Parent tag: image
Tag: loc
1
Feb 2, 2016
Parent tag: image
Tag: loc
1
Feb 2, 2016
Parent tag: image
Tag: loc
1
Feb 2, 2016

We have checked and the sitemap is rendering OK, the htaccess file is set correctly, robot.text is there. We are just not able to nail why these errors are occurring and where they are to fix them.

Because of these error Google has stopped crawling our site. Anyone face this issue and how did you fix it.

Site URL if you need is: https://shop.dochsa.com

Donovan

Newbie

Posts

Joined
Sat Dec 19, 2015 1:45 am


Post by p1repair » Sun Jun 26, 2016 9:09 pm

dochsa Did you ever find a solution? I am having the same problem and can find nothing on it.

webmaster tools reports 171 errors, all "This is not a valid URL. Please correct it and resubmit." Images have no base URL.... just "image/cache/catalog/uniden-wxi3077-2-500x500.jpg"

missing http://URL

Newbie

Posts

Joined
Sat Jun 04, 2016 6:56 pm

Post by R_D » Tue Jun 28, 2016 11:24 pm

p1repair wrote:dochsa Did you ever find a solution? I am having the same problem and can find nothing on it.

webmaster tools reports 171 errors, all "This is not a valid URL. Please correct it and resubmit." Images have no base URL.... just "image/cache/catalog/uniden-wxi3077-2-500x500.jpg"

missing http://URL

I've got exactly the same error, still looking for a solution....

R_D
Active Member

Posts

Joined
Sun Jan 09, 2011 3:13 am

Post by lemiral » Wed Jun 29, 2016 2:24 pm

in google webmasters,
<loc>http://example.com/sample.html</loc>
<image:image>
<image:loc>http://example.com/image.jpg</image:loc>

but in open cart site map,
<loc>http://www.example.com/sample.html</loc>

is this the problem?

New member

Posts

Joined
Mon Jun 06, 2016 4:11 pm

Post by lemiral » Sat Jul 02, 2016 4:54 am

very strange.
click /index.php?route=feed/google_sitemap,
search image:loc/,
images of these products are missing.
if there is a 3 errors, 3 images are missing.
upload them,
upload sitemap
very strange :)

New member

Posts

Joined
Mon Jun 06, 2016 4:11 pm
Who is online

Users browsing this forum: No registered users and 3 guests