Post by donMiki » Fri Nov 08, 2013 8:36 pm

Hello can anyone help me!

I have after the Installation a Blank Page!!

how can i uninstall !!

Bitte um Hilfe !!

Newbie

Posts

Joined
Fri Nov 08, 2013 8:35 pm

Post by toshina » Sat Nov 09, 2013 6:53 am

Just delete the xml document from your vqmod folder.

Newbie

Posts

Joined
Tue Mar 05, 2013 2:47 pm
Location - Edmonton, Alberta

Post by parth » Thu Nov 14, 2013 8:33 am

Sir i m new to opencart
I have download the extension
Please guide me how to use it??

Newbie

Posts

Joined
Thu Nov 14, 2013 8:26 am

Post by uhealth1188 » Fri Feb 14, 2014 8:39 am

I have just installed the extension, but got following errors:

Fatal error: Call to undefined function pdf() in /home/xxxxx/public_html/demo/components/com_aceshop/opencart/vqmod/vqcache/vq2-admin_controller_sale_order.php on line 2571


Does any get solution for this issue.

Thanks

Newbie

Posts

Joined
Fri Feb 14, 2014 8:30 am

Post by cgsmith » Sat Mar 01, 2014 8:37 am

uhealth1188 wrote:I have just installed the extension, but got following errors:
Fatal error: Call to undefined function pdf() in /home/xxxxx/public_html/demo/components/com_aceshop/opencart/vqmod/vqcache/vq2-admin_controller_sale_order.php on line 2571
What version of OC and version of vqmod? Can you verify that ../demo/components/com_aceshop/opencart/system/helper/pdf.php exists?

Donate! | Github of my extensions | Invoice to PDF | FREE Secure OpenCart Passwords


User avatar
New member

Posts

Joined
Thu Mar 08, 2012 6:35 am
Location - Milwaukee, WI

Post by scr33ky » Mon Mar 03, 2014 6:00 pm

hello great extension i must say !
the module works fine on OC 1.5.6.1 with the DEFAULT invoice template ...

with a few adjustmets to the font directory using the updated fonts from the beta 3 version of DOMPDF
now when you get errors of access try to CHMODE the files that give errors... worked for me !

The other issue i am having is my custom invoice template
i tryed to send the code from vqmod to my custom invoice template

<file name="admin/view/template/sale/MY_CUSTOM_order_invoice.tpl">
this was left out because my template dosent have this bit of code in it <operation>
<search position="replace"><![CDATA[<div style="page-break-after: always;">]]></search>
<add><![CDATA[]]></add>
</operation>

<operation>
<search position="replace"><![CDATA[foreach ($orders as $order) { ?>]]></search>
<add><![CDATA[$iteration=1;
foreach ($orders as $order) {
if ($iteration < count($orders)){?>
<div style="page-break-after: always;">
<?php }else{?>
<div>
<?php }?>
<?php $iteration++;?>]]></add>
</operation>

Also i tryed to shwitch in vqmod the templated used by the controller .... but no luck


<file name="admin/controller/sale/order.php">

<operation>
<search position="replace" offset="2"><![CDATA[$this->template = 'sale/MY_CUSTOM_order_invoice.tpl';]]></search>
<add><![CDATA[$this->template = 'MY_CUSTOM_order_invoice.tpl';
if ($pdf){
$this->response->setOutput(pdf($this->render(),$this->data['orders']));
}else{
$this->response->setOutput($this->render());
}]]></add>
</operation>


BUt i get this error
Fatal error: Call to undefined method DOMText::getAttribute() in /home/zpprvjrw/domains/MY_WEBSITE.com/public_html/system/library/dompdf/include/cellmap.cls.php on line 399

what am i missing out ?
can anybody help me ???

New member

Posts

Joined
Mon Nov 29, 2010 4:25 am

Post by scr33ky » Mon Mar 03, 2014 7:39 pm

QUICK FIX although .... this doesnt export the order id as the file name and Nor does it display the graphics the same as the generated invoice as the extension does for the default invoice template ...this bit of code that is quite handy for this
and its javascript for easy integration

so here we go
go to admin/view/template/sale/order_invoice.tpl or custom_order_invoice.tpl

after the </head > tag add

<script>
function doit(){
if (!window.print){
alert("You need NS4.x to use this print button!")
return
}
window.print()
}
</script>

now for the button ... i have set this like a hidden trigger so it wont show up in the printout and i set it up to trigger on the store logo when i hit it is automaticly starts the pdf download procedure

in order_invoice.tpl or custom_order_invoice.tpl
now find youre store logo image tag shood look something like this
<img src="/image/data/logo_store.png" alt="logo_store" border="0"></td>

and add before it <a href="javascript:doit()">

now when you click the logo inside the generated invoice you can save it as pdf

REMEMBER this is NOT a alternative to the module invoice to pdf .. but its a quick fix for PRINTING OUT of custom invoice using SOFTWARE like bullzipPDF (for windows machines ) print to pdf method ....as i said the output is sloppy
but for now it's a qiuck fix untill we can figure out how to export custom templates

New member

Posts

Joined
Mon Nov 29, 2010 4:25 am

Post by scr33ky » Tue Mar 04, 2014 2:27 am

this is my custom TPL file for the order invoice

this is file located at admin/viev/template/sale

.... can anyone take a look and please tell me what is the problem ?? why it's not working ang giving this error

Fatal error: Call to undefined method DOMText::getAttribute() in /public_html/system/library/dompdf/include/cellmap.cls.php on line 399

New member

Posts

Joined
Mon Nov 29, 2010 4:25 am

Post by cgsmith » Thu Mar 06, 2014 2:43 am

@scr33ky What happens if you upgrade to the latest DOMPDF? You mention beta 3 but that is from 2012.

https://github.com/dompdf/dompdf/releases/tag/v0.6.0

Donate! | Github of my extensions | Invoice to PDF | FREE Secure OpenCart Passwords


User avatar
New member

Posts

Joined
Thu Mar 08, 2012 6:35 am
Location - Milwaukee, WI

Post by scr33ky » Thu Mar 06, 2014 3:21 am

thanks i will give it a try i was tired and did not read between the lines... also .. i read that html 5 parsing must be turned on in the config files .. i will give it a try and see

New member

Posts

Joined
Mon Nov 29, 2010 4:25 am

Post by scr33ky » Thu Mar 06, 2014 3:54 am

yep looks like it does the job now ... but for some reason it dosent pickup the funtions from the custom template ... i get errors like undifiend index ... but the custom template when i wiev it it works just fine .... should i hard code the data from the vqmod ?

New member

Posts

Joined
Mon Nov 29, 2010 4:25 am

Post by cgsmith » Thu Mar 06, 2014 4:07 am

Yes. The functions in the template will only be usable in the template.

Donate! | Github of my extensions | Invoice to PDF | FREE Secure OpenCart Passwords


User avatar
New member

Posts

Joined
Thu Mar 08, 2012 6:35 am
Location - Milwaukee, WI

Post by outsider147 » Tue Apr 08, 2014 5:09 pm

Hi all,

I am getting this notice: Undefined variable: button_details in /var/www/vhosts/xxxx/httpdocs/opencart/catalog/view/theme/theme290/template/product/product.tpl on line 450

If I look at tis line it says

Code: Select all

<!--<a href="<?php echo $product['href']; ?>" class="button details"><span><?php echo $button_details; ?></span></a>-->
I am using 1.5.6.1.
What is wrong.

Greetz,

Lars

Newbie

Posts

Joined
Tue Apr 01, 2014 3:43 pm

Post by the dude » Thu Apr 10, 2014 11:54 pm

Hello

Using Opencart V 1.5.4 and this extension - works like a charm except for one tiny problem.

Instead of letters Č Š Ž it's just ?

How can i fix this?

New member

Posts

Joined
Tue Apr 01, 2014 6:08 pm

Post by IP_CAM » Fri Apr 11, 2014 3:52 am

[quot Tee="outsider147"]
Undefined variable: button_details in /var/www/vhosts/xxxx/httpdocs/opencart/catalog/view/theme/theme290/template/product/product.tpl on line 450.

Code: Select all

<!--<a href="<?php echo $product['href']; ?>" class="button details"><span><?php echo $button_details; ?></span></a>-->
I have not been able to find anything called $button_details;, neither have I be able to locate anthing like: button details (without underscore), this is a CSS CLASS refference, meaning that you probably use some CUSTOM CSS-file or at least such entries. And you require a $variable, calling something to show up wich is not there...

May be your theme290 Template, using a customized product.tpl - so you possibly have just a .XML subsection linked to your default >>catalog/view/theme/<< OC Template Section. If so, you need to copy/paste the Subsection in the .XML File, wich links to your template Subsection, rewrite the Subs to >>/catalog/view/theme/theme290<< to your THEME290 Template Sub, and you may be lucky...

It's just an idea, If you understand what I'm trying to say...
Ernie

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'300+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Sun Apr 20, 2014 11:27 am

I had some spare time and just got the latest Version installed onto my OpenShop v1.7 Custom Theme (OC v1.5.6.1-3).

First start produced Source Code on the Screen, then I switched to the Invoice itself and got my PDF as planned. Switching back to admin-display-all user-invoices Order Page, everything worked there too.

It's a nice thing to have! Thank you...


Ernie

ipc.li/shop/

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'300+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by outsider147 » Tue Apr 22, 2014 4:59 pm

Hay Ernie,

thanks a lot.
I am going to give it a try.

I got what you meant, so I will work from there.

Thanks.

Lars

Newbie

Posts

Joined
Tue Apr 01, 2014 3:43 pm

Post by _/=-)+(-=\_ » Thu May 22, 2014 11:28 am

Hey guys!

I realize that I'm not the first to ask, but is there really nobody who could help with the mail function or a link to PDF invoice function?

If yes - thank you veru much!
If no - point me at least in the right direction please and of course, thank you!

Newbie

Posts

Joined
Fri Oct 29, 2010 7:58 am

Post by IP_CAM » Fri May 23, 2014 3:54 am

here they are some useful files, for a few days, it takes so much time to find the corresponding links on OC
http://www.opencart.com/index.php?route ... %20Invoice

http://www.opencart.com/index.php?route ... ame=bgill0

http://www.ipc.li/os/pdf1.zip
http://www.ipc.li/os/pdf1.rar

Ernie

PS: that's alI can do for you, take time, read the Forum about them and work exactly...

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'300+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by projectcris » Wed Aug 27, 2014 10:03 pm

I use Invoice to PDF for some time now and it works fine. I now try to add a barcode to the pdf invoice and cannot figure this out.

I used generation an image (code from http://www.opencart.com/index.php?route ... n_id=16069) and using jquery (code from http://barcode-coder.com/en/barcode-jqu ... n-201.html). They do look good in html view, but don't show in the pdf view. Other images do show in the pdf view, so that is not the problem.

Does anybody has experience with this or suggestions?

Regards,
Cris

Newbie

Posts

Joined
Wed Aug 27, 2014 9:55 pm
Who is online

Users browsing this forum: No registered users and 2 guests