Post by bobone1 » Tue Jan 17, 2012 6:24 pm

Goodmorning everyone and thanks in advance who will respond to me to give me a help.

I have this problem with the cost of shipping:
"Warning: No Shipping options are available. Please contact us for assistance."
Obviously in the system is installed and enabled "Weight-Based Shipping", and is now set in this mode:
GENERAL
Tax: IVA 21%
Status: Enable
Sort Order: 1

ITALIA
Rates: 3:5.00,10:7.70,20:10.50,40:13.20,50:15.40,75:22.00,100:24.20,150:36.30,200:48.40,250:60.50,300:72.60,350:84.70,400:96.80,10000:10000.00
Satus: Enable

What can I do to solve my problem?

Newbie

Posts

Joined
Tue Jan 17, 2012 6:06 pm

Post by vicky_vale_71 » Tue Jan 24, 2012 7:50 pm

I also had this problem and it turned out it was because the weight class I has used in the shipping extensions (eg kilos/grams/etc) did not match the weight class set in my store setting (systems>settings>your store>local tab)

wasted a lot of time getting to the bottom of that, hope this save someone else :-)

Newbie

Posts

Joined
Fri Jan 06, 2012 1:49 am

Post by internetuser101 » Wed Sep 05, 2012 6:08 pm

Thanks vicky_vale_71! Your tip is truly useful. It's hard to determine that the difference in weight class can sometimes be the culprit!


Posts

Joined
Wed Sep 05, 2012 6:05 pm

Post by skyflyer » Wed May 08, 2013 4:13 am

Likewise- many thanks; that cured my problem too

New member

Posts

Joined
Sat Oct 20, 2012 9:48 pm

Post by Tahnee » Wed Jun 05, 2013 4:59 pm

Wow! Thanks a lot Vicky_Vale_71 you saved my day (and my store)! That was my problem too!

Newbie

Posts

Joined
Sun Jun 02, 2013 1:48 am

Post by yowchuan » Thu Oct 31, 2013 2:21 am

Thanks, the weight classes is THE_CULPRIT!

New member

Posts

Joined
Wed Feb 06, 2013 2:39 am

Post by slewman » Tue Apr 15, 2014 5:23 pm

Hey guys. I get the same error message, but only when enough items are added to cart to trigger the free ship threshhold.

for example in the single page checkout:

you can add 3 x http://www.thaimarket.com.au/bags/bambo ... ndbag-blue (no problem)

when you add a 4th item it trigers the "no shipping options" error.

but: when you add a 5th item, the error removes itself.

I've checked and double checked the weight class settings and my local settings and product settings. All are in KG's

Any help would be appreciated. I've hit a bit of a brick wall on this one.

****---------EDIT---------*****
I have 2 weight based shipping zones, Australia & international. Just to make it weirder, it's only happening on for Australian Zone. International Zones are working fine

Cheers

Newbie

Posts

Joined
Thu Aug 29, 2013 12:12 am

Post by slewman » Wed Apr 16, 2014 10:32 am

Ok, so it was actually a VQ mode doing the damage.

The "disable other shipping methods" mod. This stops other shipping methods displaying when the customer qualifies for free shipping.

Although this is ideal, had to remove it to get things functioning properly.

Took me ages to work out this was the prob, so thought i'd post it here in case someone else needs it.

Newbie

Posts

Joined
Thu Aug 29, 2013 12:12 am

Post by jormens » Fri Aug 22, 2014 2:51 am

vicky_vale_71 wrote:I also had this problem and it turned out it was because the weight class I has used in the shipping extensions (eg kilos/grams/etc) did not match the weight class set in my store setting (systems>settings>your store>local tab)

wasted a lot of time getting to the bottom of that, hope this save someone else :-)
This help me, thanks very much

Newbie

Posts

Joined
Fri Aug 01, 2014 7:02 am

Post by Frost_Giant » Fri Jan 16, 2015 7:18 am

slewman wrote:Ok, so it was actually a VQ mode doing the damage.

The "disable other shipping methods" mod. This stops other shipping methods displaying when the customer qualifies for free shipping.

Although this is ideal, had to remove it to get things functioning properly.

Took me ages to work out this was the prob, so thought i'd post it here in case someone else needs it.
Thanks. It helped solve my problem, too.

Newbie

Posts

Joined
Thu Dec 19, 2013 3:47 am

Post by half_human » Wed Oct 28, 2015 9:36 pm

Hello,

I have the same problem and I`m not sure that I`m doing everything with weight classes alright. My default weight class is Kilogram, in the settings it`s again Kilogram. At extensions->shipping->Weight Based Shipping I don`t have the option to select weight class, only tax class and I leave it None. I`m using opencart 2.0.3.1. Does anyone have an idea why is that happening and what I`m doing wrong?

Newbie

Posts

Joined
Wed Aug 05, 2015 7:14 pm

Post by VortexTed » Sun Nov 08, 2015 5:13 am

I kept running into the same error message after I added a geozone. After many hours of frustration, Jonathan over at Clear Thinking extensions solved my problem. Mine was caused by shipping rates not meeting their requirements and I had looked in my multi-flat rate module and the new geozone I had created had to be selected in the this module. Now the error message is gone. Hope that helps someone.

Newbie

Posts

Joined
Sun Sep 21, 2014 11:53 am

Post by pupito » Sat Feb 13, 2016 6:24 am

I am having the same issue, I was able to get Fedex as a shipping option working before, but now I get the dreaded "Warning: No Shipping options are available. Please contact us for assistance" message.

My weight classes are the same in the shipping options and store settings, any ideas as to what else I could check?

I checked Geo Zones as well, the only thing I did do is that since I am in the US I removed the UK Geo Zones, not sure if this could have something to do with it.

Any help is greatly appreciated, this thing is driving me nuts, especially since I already had it working before.

Newbie

Posts

Joined
Sat Feb 13, 2016 6:08 am

Post by JKM2004 » Tue Mar 20, 2018 12:18 am

Hey - I had this same issue with OC 2.3.0.2.
Identified problem: If customer added more than 2 products to a cart, no shipping options were available.
Cause of problem: In Extensions > Shipping > Weight Based Shipping. My Settings were = 1:5,2:10 . Any shopping basket above 2kg in weight would not provide a shipping option. My products were setup as 1kg in weight each. Hence 2 products in a basket worked fine, but 3 or more products would show no shipping options.
Solution: Set another Weight:Cost bracket like = 500:10 (i.e. 500kg will cost £10). This allowed any shopping basket weight from 2kg to 500kg to render a shipping option of my highest shipping cost.
I thought OC would work out that any cart of 2kg and above would be my highest shipping cost, but I guess OC is working on the max weight bracket and not looking beyond it.

Newbie

Posts

Joined
Thu Nov 09, 2017 3:59 am

Post by imsadi21@gmail.com » Mon Jul 16, 2018 12:42 pm

I am facing this error "Warning: No Shipping options are available" while using weight based shipping. I am using version 3.0.0. I have setup Geo Zones correctly.
I am banging my head for the last 48 hours but could not find any solution.
I have another site which is using opencart 2.0 and it works fine with weight based shipping. But version 3.0 has this issue with weight based shipping.

Please help!
Thanks


Posts

Joined
Mon Jul 16, 2018 12:33 pm
Who is online

Users browsing this forum: No registered users and 5 guests