Page 1 of 4

New Fedex WSDL shipping module Support

Posted: Mon May 16, 2011 1:24 pm
by Qphoria
The new FedEx WSDL (2011) version is available now on the Extension store
The old FedEx API has been killed off by FedEx

Re: New Fedex WSDL shipping module Support

Posted: Tue May 17, 2011 2:31 pm
by slimcubby
Q, I installed it by adding each file to each category according to where you specified them to be placed. I am now getting an error now that I have the Module enabled. Below is the text I get.

"Fatal error: Class 'SoapClient' not found in /hermes/web05b/b960/moo.pcubbison/slickpoolsupplies/catalog/model/shipping/fedex_wsdl_api.php on line 69"

Re: New Fedex WSDL shipping module Support

Posted: Wed May 18, 2011 9:27 am
by Qphoria
OK. I added the nusoap library to the package for those with servers that don't have soapclient compiled with php.
Redownload the latest version. Be sure to upload ALL files from new version.


Also, If you are getting this error:

Code: Select all

ERROR::803::Meter number is missing or invalid.
That is something on FedEx's server switching propagation.

There is a proposed workaround here.
http://www.prestashop.com/forums/viewth ... 84/#443209[/s]
No longer needed in latest version

Re: New Fedex WSDL shipping module Support

Posted: Fri May 20, 2011 5:06 am
by mortz
Q- Thanks a ton for this.

This is kind of interesting. I first uploaded your fix and it didn't display still. I decided to uninstall and reinstall from the admin back end to see if that made a difference or at the least.. reset the options.

Turns out this is working fine if I leave it on "List Rates," however, if I want it to pull our discounted rates, the page goes blank again.

Re: New Fedex WSDL shipping module Support

Posted: Fri May 20, 2011 12:23 pm
by Qphoria
mortz wrote: Turns out this is working fine if I leave it on "List Rates," however, if I want it to pull our discounted rates, the page goes blank again.
This is possible. My fedex test account doesn't have discounted rates so I had to go blind on the steps to get the discounted rates. If you could PM me the debug file so I can see how the discounted rates are returned the I can fix it.

Q

Re: New Fedex WSDL shipping module Support

Posted: Fri May 20, 2011 12:45 pm
by slimcubby
I uploaded the remaining files that I forgot to upload and now it works. However, when it shows the transit times it shows a delivery date of 01/01/1970?? Thanks for your help. :)

Re: New Fedex WSDL shipping module Support

Posted: Fri May 20, 2011 9:31 pm
by Qphoria
slimcubby wrote:I uploaded the remaining files that I forgot to upload and now it works. However, when it shows the transit times it shows a delivery date of 01/01/1970?? Thanks for your help. :)
Hmm.. That is odd. Can you send me the fedex_wsdl_debug.txt file that gets created in the root folder

Re: New Fedex WSDL shipping module Support

Posted: Sat May 21, 2011 1:43 am
by Expeditionops
Home delivery isn't showing up, it was giving me a line 253 error in fedex_wsdl_api.php package_count display_weight

Only worked when I had show shipping rates as "yes"

Jeremy

Re: New Fedex WSDL shipping module Support

Posted: Sat May 21, 2011 2:03 am
by Qphoria
Expeditionops wrote:
Only worked when I had show shipping rates as "yes"

Jeremy
You mean "List rates"? There's is a possible bug for discounted rates. I need someone who has discounted rates to PM me their fedex debug log file

Re: New Fedex WSDL shipping module Support

Posted: Sat May 21, 2011 2:10 am
by Expeditionops
Qphoria wrote:
Expeditionops wrote:
Only worked when I had show shipping rates as "yes"

Jeremy
You mean "List rates"? There's is a possible bug for discounted rates. I need someone who has discounted rates to PM me their fedex debug log file

Yes List rates. I have a discount, but I'm not using the debug mode. But I just turned it on.

Jeremy at expeditionops dot com. I'd be more than happy to send you what you need, but I'm not the most tech savvy guy, so may be a bit of work.

Jeremy

Re: New Fedex WSDL shipping module Support

Posted: Mon May 23, 2011 12:13 am
by Qphoria
Ok I see the issue with list rates vs discount rates... FedEx returns BOTH rates when using non-list rates so it returns an array instead of a single object. I'll have a fix soon. For now leave Show List Rates = Yes

Re: New Fedex WSDL shipping module Support

Posted: Mon May 23, 2011 10:48 pm
by Foggy
Hello, I have same discount prices problem. Please fix it soon ...

Re: New Fedex WSDL shipping module Support

Posted: Tue May 24, 2011 7:39 am
by Sidecutter
Hey Q, I'm having the exact same problem, I'm not getting quotes for Home Delivery rates. Kind of sucks since Home Delivery is the only Ground service I really need. :( I do have it set to show the List Rates instead of my discounted rates, but no dice...

Second issue, it looks like you can't add a percentage to the quoted rates anymore, it has to be a specific dollar amount? I tried entering "10%" in that field, and it just ignored the % emblem and made it add $10 to the quoted prices.


Also, I thought this might be useful to some people, maybe even to you Q. ;D

The instructions state that you can force the gateway if you keep getting Error 803: Meter number missing or invalid after going into production. I called up support, and found out what server it should be "talking" to for rates in production. Then, using the instructions for forcing the gateway to find the right line, I edited catalog/model/shipping/RateService_v9.wsdl.

I changed line 4753 from this, which worked fine in Test mode/with testing keys and meter numbers:

Code: Select all

      <s1:address location="https://wsbeta.fedex.com:443/web-services/rate"/>
To this:

Code: Select all

      <s1:address location="https://gateway.fedex.com:443/web-services"/>
Problem solved! Now that it is checking the right server, no more error 803. ;D

Re: New Fedex WSDL shipping module Support

Posted: Tue May 24, 2011 9:18 am
by Qphoria
Thanks for the clarification on the gateway. I'll change it in the main file
I am adding % support back

I will add the "Residential" flag for Home Delivery.

Re: New Fedex WSDL shipping module Support

Posted: Tue May 24, 2011 10:14 am
by Sidecutter
You're welcome, glad I could help. I'm trying to give back what I can here and there since so many people have given freely to me... ;D

It may be that this line needs to be as-is for Test purposes, and needs to be changed when you move to production. Someone would need to do a test with the change I made and a test key set to find out if that works or not.

Oh, also, in the documentation for the extension, under "How to install it", step three is wrong.

4) From the admin menu, go to 'Extensions->Order Total'.

Should be:

4) From the admin menu, go to 'Extensions->Shipping'.

Re: New Fedex WSDL shipping module Support

Posted: Tue May 24, 2011 10:21 am
by Qphoria
Sidecutter wrote: Oh, also, in the documentation for the extension, under "How to install it", step three is wrong.

4) From the admin menu, go to 'Extensions->Order Total'.

Should be:

4) From the admin menu, go to 'Extensions->Shipping'.
WHAT! You mean you actually read the instructions?! :crazy: :joker:

Re: New Fedex WSDL shipping module Support

Posted: Tue May 24, 2011 11:05 pm
by Sidecutter
Of coarse. I are read gooder. :crazy:

Re: New Fedex WSDL shipping module Support

Posted: Wed May 25, 2011 9:54 am
by Qphoria
Ok new version up with all known issues fixed. Redownload from wherever you purchased to get the latest.

v149.4 - 2011-May-24 - Qphoria@gmail.com
- Fixed bug with Discounted rates
- Changed API to add structure to returned data
- Added Residential flag
- Fixed endpoint for 803:meter error for live accounts
- Added separate wsdl file for test
- Added % support for extra cost

Re: New Fedex WSDL shipping module Support

Posted: Thu May 26, 2011 4:21 am
by Foggy
Here is a comparation between fedex.com and opencart:
http://www.tvorba-internetovych-stranek ... roblem.jpg
Image

Re: New Fedex WSDL shipping module Support

Posted: Thu May 26, 2011 5:17 am
by visualjourney
Im experience some frustrating issues here. I have changed the address to https://gateway.fedex.com:443/web-services and when I do the screen goes white on step2 page and will only continue after disabling the module or changing the address back to the original one. Any ideas?