Post by diggydog » Wed Jun 16, 2010 7:38 pm

Have upgraded from 1.47 to 1.48 then 1.48b and all has gone seemingly fine except for a few module issues. I have an error wich is as follows:

Warning: Invalid argument supplied for foreach() in /home/promote/public_html/catalog/controller/module/deliverymodule.php on line 13

The code which this relates to is as follows:

Code: Select all

$languages = $this->model_localisation_language->getLanguages();
		
		foreach ($languages as $language) {
			if (isset($this->request->post['deliverymodule_code' . $language['language_id']])) {
				$this->data['deliverymodule_code' . $language['language_id']] = $this->request->post['deliverymodule_code' . $language['language_id']];
			} else {
				$this->data['deliverymodule_code' . $language['language_id']] = $this->config->get('deliverymodule_code' . $language['language_id']);
			}
I cannot see anything obvious which causes the error (i am no expert or coder), the same module worked fine in 1.47, does anyoone have any ideas?

Thanks
Last edited by i2Paq on Wed Jun 16, 2010 7:44 pm, edited 1 time in total.
Reason: Topic moved

Diggydog
http://www.promoteyourproducts.co.uk


Newbie

Posts

Joined
Thu Apr 29, 2010 6:24 pm
Location - UK

Post by i2Paq » Wed Jun 16, 2010 7:44 pm


Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by diggydog » Wed Jun 16, 2010 9:54 pm

Perfect, just the job.

Thanks O0

Diggydog
http://www.promoteyourproducts.co.uk


Newbie

Posts

Joined
Thu Apr 29, 2010 6:24 pm
Location - UK
Who is online

Users browsing this forum: No registered users and 2 guests