Page 1 of 1 AIM cURL Issue [Solved]

Posted: Wed Jul 18, 2012 2:43 am
by OpenSaysMe
Our server software (PHP & MYSQL) was updated last night and now the AIM module is no longer working. It was showing the "Please Wait" wheel endlessly until I updated the payment module using the "Patched_Curl_Payments_v1496.1" file provided in another thread. Once I did that the error is now being shown/logged as:

AUTHNET AIM CURL ERROR: 35::Unknown SSL protocol error in connection to
The store is running:

As I feared, the version update to 1.5x did not solve this. It has the same error shown above.

PHP: 5.2.17
MYSQL: 5.1.63
libcurl/7.24.0 OpenSSL/1.0.1c zlib/1.2.3 libidn/1.22 libssh2/1.4.1

I suspect you are going to tell me to upgrade to the latest version of OC. I'm more than happy to try that, but since I am going to have to charge my customer for the time to redo some custom changes to their store, I really need to know that it will in fact solve the problem.

Can Q or anyone else tell me if they are running a newer version of OC using AIM and if it works with those versions of PHP/MYSQL?

I also just spoke to and they have advised me that the transaction is not even hitting their side of gateway at all.

Anyone else have any thoughts or suggestions???

Thank you in advance!!!

Re: AIM cURL Issue

Posted: Thu Jul 19, 2012 2:42 am
by oscprofessionals
curl_setopt($curl, CURLOPT_SSL_VERIFYPEER, 0);

set this to
curl_setopt($this->ch, CURLOPT_SSL_VERIFYPEER, true);

and check.

Re: AIM cURL Issue

Posted: Thu Jul 19, 2012 9:03 am
by OpenSaysMe
Unfortunately that did not work.

I'm leaning towards just upgrading the version and keeping my fingers crossed unless someone else has another suggestion?? - Upgrade succeeded, but failed to resolve issue!

I sincerely appreciate the above suggestion oscprofessionals!

Re: AIM cURL Issue

Posted: Tue Jul 24, 2012 8:19 am
by OpenSaysMe
Alright, we have resolved the issue. Apparently when our server was updated something went wrong with the way that the SSL protocol is identifying it's version. It is reverting back to an earlier version which does not work.

The fix was to go into the catalog/controller/payment/authorizenet_aim.php file and add the line below to force it to use the newer version. From what I've been told, some older setups might need to set it to 2 instead of 3.

curl_setopt($curl, CURLOPT_SSL_VERIFYPEER, 0);

curl_setopt($curl, CURLOPT_SSLVERSION, 3); // Force SSLv3 to fix Unknown SSL