Page 1 of 1

Checkout problem - won't pass to payment method!

Posted: Sat Oct 22, 2011 12:16 am
by rocket
Hi
New to this and have my site almost set up but I have a problem.

When in maintenance mode to test the payment system, I can't seem to go past the delivery method to select a payment type. Is this a known problem I'm missing or what could it be? Do i need a live site to get to the next step?
I'm using 1.5.1.3

Thanks

Checkout problem - won't pass to payment method!

Posted: Wed Oct 26, 2011 6:30 am
by rocket
Worked out my first problem, it was because I changed the image viewer from fancy box and had removed the js without realising it was needed for the pop up box!

Now I have another issue though, in that I put the site live ready to launch and it won't go to the checkout! You select the item, add to cart, login and go to checkout, but it keeps refreshing the screen back to the postage cost estimator, login from the https page for checkout to the http page for the shopping cart??
Anyone maybe shed some light on this having the same issues?

Re: Checkout problem - won't pass to payment method!

Posted: Tue Dec 06, 2011 12:10 am
by powerpuf
Hi,
I have the same problem, but it is only with Google Chrome.

Re: Checkout problem - won't pass to payment method!

Posted: Tue Jan 17, 2012 11:20 pm
by kdmp
I have not noticed this issue in any other browsers, except in Internet Explorer 8 and below. All other browsers do not have this issue. I have tested to see if it was my theme, by using the default theme. It worked fine. So thinking all would be simple - I replaced template/checkout/payment.tpl in my theme with the default one. Cleared my cache and seen no change. I then tried removing payment.tpl from my theme, which forced opencart to use the payment.tpl from the default theme - that worked perfectly. I could now use Internet Explorer 7/8 to checkout successfully.

I am unsure why simply moving the default payment.tpl to my themes checkout directory was not liked by opencart. I wouldn't mind some one's insight on this ;)

Same with Me

Posted: Tue Apr 10, 2012 10:39 pm
by jasonsilver
I have the same problem.

I upgraded from a really old version yesterday, using a script that's posted elsewhere in these forums, and everything has gone pretty smoothly. I'm now on the latest version of OpenCart.

However, a few problems remain, the most serious of which is that a user cannot get to Step 5, to make a payment.

https://occasiongiftware.com/index.php? ... t/checkout

I've uninstalled/reinstalled all the various payment modules, and enabled/disabled them trying to trigger some kind of effect, error, or anything. The error log is blank, and I can't get to that point at all.

What should I try?

Re: Checkout problem - won't pass to payment method!

Posted: Wed Apr 11, 2012 1:32 am
by jasonsilver
For anyone else who has this problem, reuploading isn't always the solution-- I needed to CHMOD my javascript folders to allow them to be accessed.

Duh, but it took a while to figure out that was what was wrong. jQuery wasn't loading on a page refresh, but I didn't think to look at the browser's console.