Post by goosenic » Tue Feb 15, 2011 10:56 am

We've tried the Opencart offline credit card processing extension - "Offline Processing Credit Card"

But it sends CC numbers etc in a open email, a very bad security risk to the customer.

Has anyone got this extension running succcessfully? - http://theqdomain.com/ocstore/offline_credit_card

Newbie

Posts

Joined
Mon Jan 10, 2011 6:43 am

Post by Qphoria » Tue Feb 15, 2011 11:04 am

Quite important to read the readme.
There are 2 modes
Pci mode which stores only part of the card num and exp date but mails the other half and cvv. This way only part of the info is in one place and you need both pieces for it to work.

Or all db mode which stores everything in the db with encrypted cc num

There is no better way to do it and it works fine

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by webworks » Wed Feb 23, 2011 2:59 am

Hi Qphoria,
I've recently bought this and set to Full compliant(#2). The order email to admin is fine but i don't see the 8 digits credit card numbers being stored in the db...they are not visible in the admin order. How to retrieve the 8 digits in the admin to process the payment?

Thank you.

OpenCart V.1.5.6.4


New member

Posts

Joined
Fri Jan 21, 2011 8:57 pm

Post by Qphoria » Wed Feb 23, 2011 3:07 am

You can only view them through the admin order edit page. They are encrypted in the database. Be sure you've made the one line change stated in the readme to see the cc details on the order view

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by webworks » Wed Feb 23, 2011 3:23 am

My bad. I did'nt upload the file after added the line. It's working fine and love to see the "delete" cc info option.

Thank you.

OpenCart V.1.5.6.4


New member

Posts

Joined
Fri Jan 21, 2011 8:57 pm

Post by mazhar » Thu Apr 28, 2011 6:19 pm

hi guys hope you will be fine

i am using offline credit cart problem is that it is offering only two type of card like "visa", and "master card" i have to add "amex" in the list also. i have added the amex text in

catalog\view\theme\default\template\payment\offline_cc.tpl but it not validating it correctly and giving error i am unable to proceed to next page by giving correct card number and expiry.

any help will be greatly appriciated.

Thanks

Newbie

Posts

Joined
Thu Apr 28, 2011 6:11 pm

Post by mberlant » Tue May 03, 2011 8:08 am

AmEx is an included credit card type in this extension.

Go to Admin > Extensions > Payments and edit Offline Credit Cards. The fourth section of that management screen is where you tick off the boxes of the credit card types you wish to accept. Choose those that you can accept and save your changes. That's all.

Good luck.

Please use proper English at all times, so that all members may understand you.


User avatar
Active Member

Posts

Joined
Sun Mar 13, 2011 8:33 pm

Post by mazhar » Fri May 13, 2011 4:25 am

mberlant wrote:AmEx is an included credit card type in this extension.

Go to Admin > Extensions > Payments and edit Offline Credit Cards. The fourth section of that management screen is where you tick off the boxes of the credit card types you wish to accept. Choose those that you can accept and save your changes. That's all.

Good luck.
thanks for you reply i have checked the back end and unable to find the option can you please provide me this extension with this option please

waiting for you kind reply

Regards,
Mazhar

Newbie

Posts

Joined
Thu Apr 28, 2011 6:11 pm

Post by azli » Tue Jun 14, 2011 4:25 pm

same problem with me. Any one can help us?..

New member

Posts

Joined
Sun Apr 24, 2011 12:19 pm

Post by mberlant » Tue Jun 14, 2011 9:58 pm

First my apologies for not posting this comment sooner. I assumed that mazhar would do it, and then I forgot about this topic.

mazhar contacted me by PM and gave me some confidential information so I could help him find the problem. What I found was that my posting of May 3 was correct, but that mazhar was using a free extension that does not include many (any?) of the options and features that Qphoria's paid extension provides.

I have no idea if mazhar purchased Q's extension after our PM exchange, or not.

@azli -- Are you using Qphoria's paid extension with the features you require, or are you using the free extension that is missing these features?

Please use proper English at all times, so that all members may understand you.


User avatar
Active Member

Posts

Joined
Sun Mar 13, 2011 8:33 pm

Post by azli » Wed Jun 15, 2011 11:30 am

yup...
just now i never buy any extension and only used the free one.. ;D

New member

Posts

Joined
Sun Apr 24, 2011 12:19 pm

Post by Qphoria » Wed Jun 15, 2011 11:35 am

azli wrote:yup...
just now i never buy any extension and only used the free one.. ;D
You get what you pay for ;)

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by azli » Wed Jun 15, 2011 11:38 am

by the way, where i can get the extension, can u provide me the link
tq.

New member

Posts

Joined
Sun Apr 24, 2011 12:19 pm

User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by ollie007 » Sat Jun 18, 2011 2:10 pm

when will this be updated to 1.5? isnt this the most important extension for security?

New member

Posts

Joined
Fri Jun 10, 2011 1:56 am

Post by Degsey » Sun Jun 19, 2011 9:26 am

When is the V1.5 version going to be updated for release, even on Qphoria website it seems that this payment module is taking a back seat to all the other payment modules he is upgrading.

Live Long and Prosper!

Degsey :-]

Visit us at :

http://www.Supreme-Ink.com


User avatar
New member

Posts

Joined
Sun Jun 12, 2011 2:29 am
Location - North Carolina

Post by Degsey » Wed Jul 13, 2011 4:25 am

Its been nearly a month and I understand that Qphoria is back from vacation and I have heard nothing about this module being upgraded to 1.5.xx

I have even emailed him on his website last week and he has not replied to me but he can still post here?

Come on Qphoria give us this module updated soon.

Live Long and Prosper!

Degsey :-]

Visit us at :

http://www.Supreme-Ink.com


User avatar
New member

Posts

Joined
Sun Jun 12, 2011 2:29 am
Location - North Carolina

Post by cantykiwi » Wed Jul 13, 2011 8:22 am

Q, Have been trying to get this module to work using oc v1.4.9.5 which presumably works as your site says it's compatible with 1.4.x (although not sure when you last updated your site as your module is v148.2) but am not receiving the email containing the credit card details, all other emails from the shop are coming through fine. Is the credit card details supposed to be included in the admin order email or a separate email? Am using PCI mode 2 without encryption at this stage while testing.

Also on customer checkout side says you can enter card number with or without dashes but if you use dashes the number does not show up correctly in the admin order edit screen as the dashes are not being stripped out. Maybe needs to limit input to 16 characters or maybe separate number into 4 boxes of 4 digits on customer side?

Anyway thanks for all the work you do on opencart and the modules you have made.

Attachments

offlineccard.jpg

offlineccard.jpg (17.6 KiB) Viewed 7267 times


New member

Posts

Joined
Mon Sep 13, 2010 12:37 pm

Post by Qphoria » Wed Jul 13, 2011 11:26 am

If you are not receiving the emails it may be due to having no sendfrom address with the php mail call I'm using. I am about 99% done with the port to 1.5.x support so I will update the mail function to use the built-in mail class and that should hopefully resolve it.

Ok, Offline CC has been updated to support 1.5.x

IMPORTANT:
If upgrading from a previous version to 150.1, you need to do the following:
1. Upload the new files over the old files
2. Click UNINSTALL in the extension list
3. Click INSTALL in the extension list
4. Edit the extension and reconfigure it

The reason for this is because I changed the way the allowed types are saved and it needs to clear out the old fields with the new fields

Q

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by cantykiwi » Thu Jul 14, 2011 8:19 am

Q, Thanks for the v1.4x/v1.5 update of the module.

Have tested on oc1495 and oc1505 ok. Found my email problem is only on my local test server when using smtp to send so will set myself up a local mail server again as well to test with. Still curious though as to why the admin emails send ok through smtp but not the ones from your module ??? Am using UniServer as my dev server on Windows 7 if that is any help.

The credit card number is still not showing up correctly in either version of the shop as per my picture in comment above when using the full pci compliance mode of splitting credit card numbers, only when customer uses dashes between numbers. Now that I can receive emails, also found the email with card details to admin is showing credit card number incorrectly as seen below when user enters dashes with number:-

Order ID: #2
The Partial Credit Card details for this order are:
Card Type: Visa
Card Num: 4111xxxxxxxx11-1111
Expiration: 12/12
Card CVV: 123
Start Date:
Issue Num:

Also your readme file for this module needs to be updated as the line of code that needs to be added is in a different file in oc1505 in the admin/view/template/sale/order_info.tpl file.

Many thanks Q.

New member

Posts

Joined
Mon Sep 13, 2010 12:37 pm
Who is online

Users browsing this forum: No registered users and 5 guests