Post by maderstrains » Sat Jul 17, 2010 1:33 am

I am getting an error message when trying to use PayPal Website Payments Pro for checkout through my website

The error is saying:

"the page at: http://www.maderstrains.com says:

The security header is not valid"

Can someone help me fix this problem and tell me what I need to do? I have PayPal website Payments Pro in test mode right now because im trying to see if it will work, which it isnt.... I have entered the API Username, the API Password, and API Signature from my PayPal account. Do you ever need to request new API information? The last time I requested it was back in May of 2009, im not sure if that has anything to do with it or not?

Im using OpenCart Version 1.4.7 if this information is needed.
Last edited by i2Paq on Sun Jul 18, 2010 6:46 pm, edited 1 time in total.
Reason: Topic moved

Josh Mader
Maders Trains
http://maderstrains.com/


Active Member

Posts

Joined
Sat Jun 06, 2009 1:31 am
Location - Rancho Santa Margarita, Cali

Post by maderstrains » Sun Jul 18, 2010 12:27 pm

Bump, anyone help please?

Josh Mader
Maders Trains
http://maderstrains.com/


Active Member

Posts

Joined
Sat Jun 06, 2009 1:31 am
Location - Rancho Santa Margarita, Cali

Post by maderstrains » Wed Jul 28, 2010 6:13 am

Bump Bump still need to get this fixed if anyone can help me with it

Josh Mader
Maders Trains
http://maderstrains.com/


Active Member

Posts

Joined
Sat Jun 06, 2009 1:31 am
Location - Rancho Santa Margarita, Cali

Post by Daniel » Wed Jul 28, 2010 9:34 am

normally a wrong details. wrong api key or something.

check your error logs?

has paypal ever worked?

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by maderstrains » Wed Jul 28, 2010 9:52 am

The API's are correct, I copy and pasted them from PayPal

The regular PayPal works, and it transfers the customer to the PayPal website to log into their account and send the payment. Its the Payments pro that isnt working...

I did have PayPal Website Payments Pro a while back, and I do remember it worked. I had my website crash when my host did some changes and I lost everything because I did not have a backup. I had to start over from the beginning and build my site back to what it was. I switched hosts and am now doing backups every few days or after major changes are made to the site.

Im just not sure why it is not working now. Do you ever have to request new API information or should it stay the same? Like I said, its saying "Security Header Is Not Valid". im not sure what that means?

Josh Mader
Maders Trains
http://maderstrains.com/


Active Member

Posts

Joined
Sat Jun 06, 2009 1:31 am
Location - Rancho Santa Margarita, Cali

Post by maderstrains » Wed Jul 28, 2010 9:57 am

I had Payments Pro in test mode because I was trying to test it to see if it worked. Getting curious, I took it out of test mode and made it live. I made a new item that costs $0.01 in my store and added it to my cart (have a test account for my website) and tried to checkout with Payments Pro again.

This time instead of saying "Security Header Is Not Valid" it says "This transaction cannot be processed due to an invalid merchant configuration."

Any idea as to what to do?

Thank you in advance

Josh Mader
Maders Trains
http://maderstrains.com/


Active Member

Posts

Joined
Sat Jun 06, 2009 1:31 am
Location - Rancho Santa Margarita, Cali

Post by momtrepreneur » Tue Oct 19, 2010 3:39 pm

I'm wondering if this issue had any resolution to it? I've looked all over the board and have seen this same issue but can't find a resolution to it. I'm experiencing the same problem. I have Paypal Website Payment Pro and pay for Virtual Terminal (which works fine on my other site), I've put in the correct API username, password and signature, the store is live and not in test mode and I still get Security Header Not Valid error when trying to process a credit card.

Did anyone find a resolution? I thought upgrading to version 1.4.9.1 would fix the matter but it didn't. ??? Paypal and the API system is working on my other site (not running Opencart) but for some reason with my Opencart site it is not. If anyone can shed light on this, I'd be sooo grateful.

Thanks in advance,
Wende
http://www.creativesolutionscompany.com

Opencart 1.4.9.1
Global Options Mod


New member

Posts

Joined
Wed Apr 21, 2010 2:27 am

Post by konpavlos » Wed Oct 20, 2010 3:24 pm

hallo
i have the same problem
so i was wondering if you found the solution
thnx
kon pavlos
www.konpavlos.net

Newbie

Posts

Joined
Wed Oct 20, 2010 3:18 pm

Post by momtrepreneur » Thu Oct 21, 2010 8:16 am

Unfortunately not. I usually try to post the remedy for others too, but as you can see nobody has offered anything yet. I'll have to submit a support request because I'm going to have to take my site down unless I can get a remedy as it's turning buyers off. I'll post if I do find an answer.

Opencart 1.4.9.1
Global Options Mod


New member

Posts

Joined
Wed Apr 21, 2010 2:27 am

Post by momtrepreneur » Wed Oct 27, 2010 6:35 am

Here's what I did to fix the issue!

Ok, good news! I went into my Paypal account and deleted the old credentials and requested new ones, then copy and pasted the new info into Opencart as I had before. I had to change my other site to work with the signature as well (not using Opencart) but that's appears to be ok so far. Then I purchased a test product (but not in test mode) from my main site (using Opencart) and SUCCESS!! I got emails and expected, Paypal IPN worked as expected, etc. I can't tell you how relieved I am!

So here's the only things that were changed to remedy the error:

1. Request NEW credentials from Paypal! My other Paypal credentials were working fine on my other site but were over 2 years old. Opencart MAY NEED NEW, RECENT CREDENTIALS.

2. If you have another site using PayPal Web Pro but using the certificate rather than the signature - CHANGE IT. Both/all sites MUST use the same system i.e. SIGNATURE METHOD.

Of course I'm not an expert or Opencart pro, this is just what has worked for me so I'm passing on info in case it may help someone else.

Now if I could just get some help on whatever is causing the new 1.4.9.1 version to run exxxtrrremely slow...

~M
www.creativesolutionscompany.com

Opencart 1.4.9.1
Global Options Mod


New member

Posts

Joined
Wed Apr 21, 2010 2:27 am

Post by andriyz » Sat Nov 27, 2010 2:02 am

This worked for me too

Newbie

Posts

Joined
Fri Oct 15, 2010 6:45 am

Post by bobbyh » Mon Aug 15, 2011 4:53 pm

Many thanks - helped sort out our issues as well.

B

New member

Posts

Joined
Fri Jul 01, 2011 2:48 am

Post by iamskyemedia » Wed Dec 28, 2011 11:40 pm

I have changed my API credentials and done everything mentioned but am still getting the Security header not valid. I have no idea what I'm doing wrong. Can someone please assist?

Newbie

Posts

Joined
Fri Sep 30, 2011 12:10 am

Post by iamskyemedia » Thu Dec 29, 2011 3:41 am

*bump*

I have gotten no where with this.

Do you need a Website Payments Pro account in order for this to work???

Newbie

Posts

Joined
Fri Sep 30, 2011 12:10 am

Post by disabled_ralph » Tue Apr 24, 2012 6:42 pm

Maybe your website doesn't have SSL certificate installed. I think PP Pro requires it


Posts

Joined
Wed Apr 11, 2012 8:39 pm

Post by cryptcommerce » Sat May 12, 2012 5:09 am

I'm almost certain it's purley that the test mode doesn't work within OpenCart as I've been testing over 6 of my websites and that seems to be the only thing which makes the error appear .... SO DONT USE TEST MODE.

Kind Regards

Shaun Swales
Http://www.twitter.com/shaunswales
http://www.crypt-commerce.com/

Newbie

Posts

Joined
Thu Aug 25, 2011 7:11 pm

Post by sdynak » Tue Jan 08, 2013 8:03 pm

I know this is an old post but I had the same issue .. I also copied and pasted and found there was a space at the end of the username and password.. once backspaced and saved all went fine.. just figured it may help someone else at some time.

New member

Posts

Joined
Wed Jan 02, 2013 8:52 am
Location - Bayville, New Jersey

Post by wwtemple » Wed May 08, 2013 2:02 pm

Me too have the same issue, trying to solve almost 2 months, still no chance. Always "The security header is not valid".
I have change few times API User Name, API Password and Signature. With every type of CC - the same error.

If anyone have idea, please help.

Newbie

Posts

Joined
Fri Apr 26, 2013 9:20 am

Post by Rezman » Fri Sep 13, 2013 12:02 am

As someone stated, your site requires an SSL as stated from Paypal's FAQ.

Newbie

Posts

Joined
Tue Feb 26, 2013 3:28 am

Post by ETM Co » Thu Sep 26, 2013 5:16 am

Ok I think this problem don't had a fix because I cant find any info to resolve the problem. :bash:

1- I installed a new SSL Certificate - Working and running
2- I upgrade my Paypal account to Business Account
3- I create an API Credential and copy it to the Opencart Paypal Pro
4- I try the sand box test and the error is Invalid header security.
5- I try testing with Live account, real credit card and the error is This transaction cannot be processed due to an invalid merchant configuration.

I have spend 4 days :crazy: trying to fix the problem without any luck.

If someone had the solution or the reason of this problem, any idea how to solve this problem please let me know. ???

Thank
Alexandra.

Slavery has never been abolished from America's only changed to 8Hrs or more. way of thinking.
www.etmcollection.com


Newbie

Posts

Joined
Thu Sep 26, 2013 4:46 am
Who is online

Users browsing this forum: No registered users and 7 guests