Post by promofire » Thu Aug 27, 2015 3:14 am

We got this email from Authorize and I was wondering if any changes would be needed to the Authorize mod for OpenCart 1.5.4.1. Much appreciation to someone who knows the answer.

Security Certificate Upgrades to api.authorize.net

As part of our continuous upgrades to enhance system performance and security, on September 21, 2015, we are upgrading api.authorize.net to new security certificates, which are signed using Security Hash Algorithm 2 (SHA-2) and 2048-bit signatures.

These upgrades were already completed on secure.authorize.net in May. If your website or payment solution connects to api.authorize.net and any updates are necessary to use the new certificates, please refer to this blog post in our Developer Community, which has all of the certificate information you and your developer will need for this update. Our sandbox environment has already been updated so that you can validate that your solution will continue to work using SHA-2 signed certificates, prior to September 21st.

After the update is complete on September 21st, any website or payment solution that connects via api.authorize.net that cannot validate SHA-2 signed certificates will fail to connect to Authorize.Net's servers.

Transaction ID Changes

In October of this year, due to system updates, it will be possible to receive Authorize.Net IDs (Transaction ID, Batch ID, etc.) that are not in sequential order.

Currently, if you receive a Transaction ID of "1000," you could expect that the next Transaction ID would not be less than 1000. However, after the updates, it will be possible to receive a Transaction ID less than the one you previously received.

If your system has any functionality that expects Authorize.Net-generated IDs to be sequential, please update it immediately so that you will not see any disruptions to your solution.

Additionally, please make sure that your solution does not restrict any Authorize.Net ID field to 10 characters. If you are required to define a character limit when storing any of our IDs, the limit should be no less than 20 characters.

TLS Remediation for PCI DSS Compliance

As you may already be aware, new PCI DSS requirements state that all payment systems must disable TLS 1.0 by June 30, 2016. To ensure that we are compliant ahead of that date, we will be disabling TLS 1.0 first in the sandbox environment and then in our production environments. Both dates are still to be determined, but please make sure your solutions are prepared for this change as soon as possible.

For more information, including updates to the dates we anticipate disabling TLS in each environment, please refer to our previous blog post. We will also send another email about TLS once we have a final date in place.

Active Member

Posts

Joined
Thu Jan 27, 2011 2:00 am

Post by Eggweezer » Fri Sep 04, 2015 9:55 am

Hi Promofire. I was just wondering if you got anywhere with this upgrade?
I have the same dilemma, and have no idea where to go with this?
Thanks. Eggweezer.

Active Member

Posts

Joined
Tue Jun 05, 2012 1:33 am

Post by promofire » Fri Sep 04, 2015 10:07 pm

Nope. Never heard a thing.

Active Member

Posts

Joined
Thu Jan 27, 2011 2:00 am

Post by Eggweezer » Sat Sep 05, 2015 2:04 am

Thanks. If I have any luck, I will let you know. I just don't know if I have to 1) Edit a setting in Opencart 2) Edit a file(s) on the server or 3) Contact Authorize.net?

Active Member

Posts

Joined
Tue Jun 05, 2012 1:33 am

Post by promofire » Sat Sep 05, 2015 2:14 am

If I get an answer I'll let you know, though it will be beside the point for us soon. We're moving both of our stores elsewhere this month.

Active Member

Posts

Joined
Thu Jan 27, 2011 2:00 am

Post by Eggweezer » Mon Sep 07, 2015 2:07 am

I spoke to my hosting company "1and1", and they said we just need to "Re-issue the SSL certificate" through the 1and1 control panel. He walked me through it but had an error, so he opened a ticked with their support team, and will get back to me. Now.... If that is the only thing that I have to do, I am not sure. If anyone else is familiar with what I have to do, I would sincerely appreciate any input. Thank you.

Active Member

Posts

Joined
Tue Jun 05, 2012 1:33 am

Post by virtualgeorge » Tue Apr 19, 2016 6:56 am

I wonder if we have to update anything because of these changes? I have been getting emails about up coming updates for a long time but my sites using auth.net are still working.

http://app.payment.authorize.net/e/es.a ... 8ae4d54%3E.

Active Member

Posts

Joined
Wed Jun 18, 2008 5:57 am
Who is online

Users browsing this forum: No registered users and 8 guests