Post by billfryer » Fri Feb 05, 2010 5:34 pm

I use Paypal Payments Pro and have finally got it working (sort of).

1. I didn't realise you cannot have spaces in the postcode - really this needs to be coded into the module.
2. It also seems to insert + symbols in the spaces of the name eg. "W R Fryer" becomes "W+R+Fryer" by the time it reaches Paypal.
3. In addition the module does not seem to drag across the email address (so Paypal cannot send its own invoice confirmation)

Any ideas? I'm a NON-TECHIE, so plain English appreciated.

http://www.billfryer.com - the direct marketing agency
http://www.billfryercopywriter.co.uk - the copywriter


Newbie

Posts

Joined
Fri Feb 05, 2010 5:19 pm
Location - Warminster, UK

Post by slawrence10 » Thu Feb 11, 2010 6:32 am

bump

note that this problems is with Paypal Payments Pro (UK) in OpenCart version 1.3.4

Kind Regards,
Scott

View my latest OpenCart work: JD Harris and Student Textbooks Online

Scott Lawrence - web and graphic design


User avatar
Active Member

Posts

Joined
Sun Jul 19, 2009 8:10 pm
Location - London, UK

Post by slawrence10 » Thu Feb 11, 2010 6:41 am

Transactions are sent to Paypal however if you go on the transaction details in PayPal, the customer's emails is shown as:
invalid_email_supplied@PayPal.com

OpenCart controller passes EMAIL to paypal as:

Code: Select all

'EMAIL'     => $order_info['email'],
does the email maybe need formatting?

any ideas?

Kind Regards,
Scott

View my latest OpenCart work: JD Harris and Student Textbooks Online

Scott Lawrence - web and graphic design


User avatar
Active Member

Posts

Joined
Sun Jul 19, 2009 8:10 pm
Location - London, UK

Post by billfryer » Fri Feb 12, 2010 8:23 pm

Have now sorted out this problem.

Basically you are better off avoiding the Paypal Payments Pro (UK) module and using the regular Paypal Payments Pro module instead. Just go into your Paypal account and request API details through your Profile. Worked perfectly first time without any headaches.

http://www.billfryer.com - the direct marketing agency
http://www.billfryercopywriter.co.uk - the copywriter


Newbie

Posts

Joined
Fri Feb 05, 2010 5:19 pm
Location - Warminster, UK

Post by ulyssesnz » Sat Feb 13, 2010 11:58 am

Hi there - whoever can help me,

I am a newbie to OpenCart and very impressed with how easy it was to install OpenCart 1.4

I have done some testing with the "Cash on Delivery" payment type and all looks good there.

I am now trying to work out how to setup the standard "PayPal" payment type. I have set it up on Test mode and while it displays the words Test Site at the bototm of the payments page of PayPal, it also displays the cart administrator email address at the top of the screen. How do you setup the appropriate company name? I ahve an account with PayPal but can't seem to find out where to setup those details in the OpenCart administration.

Can anyone help with this please.

Thanks & kind regards

Mauricio

Newbie

Posts

Joined
Sat Feb 13, 2010 11:50 am

Post by RockingSkier » Fri Feb 19, 2010 10:26 pm

Has anyone got any further with this?

I have tired both the UK and the generic Paypal modules.

The UK module rejects all payments that I try. (This is once i have removed the space in the postcode).

The Generic PayPal Direct module takes the payment however it doesnt pass the address to PayPal so seller protection is not avaliable.

PayPal Direct also appears to use the generic prices from the database and not the calculated prices?
ie in the database I have set the price to 1.00 and then set the currency to multiply that up to £1.20. PayPal then charges £1.00 and not £1.20.

I am using 1.3.2

Thanks,

RockingSkier

Newbie

Posts

Joined
Mon Jan 04, 2010 8:26 pm

Post by kathlk » Sat Feb 20, 2010 12:20 am

Has anyone got basic paypal working in 1.4?

I have tired basic Paypal modules.

It direct me to the paypal site and get the payment correctly. Also I have recived paypal emails both side.
But I cannot see any orders created in opencart.

Regards
Kapila

New member

Posts

Joined
Sun Jun 08, 2008 3:07 pm
Location - London UK

Post by kathlk » Sat Feb 20, 2010 12:42 am

Finally I found the reason myself as not setting "Transaction Method" to "Sales". Once set this now I can see the order.

But with paypal I(customer) do not receive Open cart email message which has direct URL to access my order online. Instead I only can see paypal transaction email which do not have product information ect.

Anyone know, is this the way this designed or do I need further configuration to get both emails when checkout?

Regards
Kapila

New member

Posts

Joined
Sun Jun 08, 2008 3:07 pm
Location - London UK

Post by world-of-satellite » Sun Jul 25, 2010 1:55 pm

I'm having the same issue with Paypal Payments Pro(UK). The regular Paypal Payments Pro is designed for use in the USA as its got the Discover card listed which is NOT used in the UK, so regular Paypal Payments Pro module really isn't for the UK unless it changed.

Anyone able to fix the UK module?

Active Member

Posts

Joined
Sun Jun 27, 2010 1:40 pm

Post by world-of-satellite » Tue Jul 27, 2010 1:58 pm

Hopeful bumb :)

Active Member

Posts

Joined
Sun Jun 27, 2010 1:40 pm

Post by Qphoria » Tue Jul 27, 2010 7:22 pm

I'll look at it for 1.4.9

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by world-of-satellite » Tue Jul 27, 2010 8:06 pm

Qphoria wrote:I'll look at it for 1.4.9
Thank you Qphoria, would be great if it can fixed :)

Active Member

Posts

Joined
Sun Jun 27, 2010 1:40 pm

Post by kia_hm » Tue Oct 05, 2010 1:43 pm

Hey Qphoria,
Still no solution for payment Pro?
Thanks,

New member

Posts

Joined
Wed Sep 22, 2010 3:14 pm

Post by kathlk » Tue Nov 23, 2010 6:19 am

I think most of email problems are related to hosting site (PHP). Once I moved site to different hosting provider, everything seems working ok in PayPal!

New member

Posts

Joined
Sun Jun 08, 2008 3:07 pm
Location - London UK
Who is online

Users browsing this forum: No registered users and 7 guests