Post by smwoodcrafts » Fri Dec 07, 2018 8:09 am

Hi,
I am running 1.5.6.5_rc and everything appears to be set up fine with square. (no easy task for me) My first order came through using square to pay and, I got the order and the payment was processed, but he got an error. The error is attached. I looked at the order in OC and everything looked fine. when I went to Square, I noticed that the products and shipping were correctly displayed, but then came some weird looking edits. They are also capture and attached. They appear to be the tax for each product separately and on the shipping. Is there something I overlooked? Everything came out alright but I don't want my customers to get these errors.

Attachments

square.JPG

square.JPG (23.73 KiB) Viewed 287 times

error.jpg

error.jpg (38.44 KiB) Viewed 287 times


User avatar
New member

Posts

Joined
Fri Sep 28, 2018 4:00 am

Post by ADD Creative » Fri Dec 07, 2018 6:49 pm

You need to contact the payment extension developer as there is no Square payment module included in Opencart 1.5.6.x.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by johnp » Sat Dec 08, 2018 12:39 am


Opencart 1.5.6.5/Default Theme/VQMOD 2.6.3 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades plus Ecommerce, Marketing and More
https://asandwhenbusinessservices.co.uk
https://asandwhenbusinessservices.co.uk ... e-services


User avatar
Active Member
Online

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by smwoodcrafts » Sun Dec 09, 2018 8:53 am

johnp wrote:
Sat Dec 08, 2018 12:39 am
Have you installed this extension?

https://www.opencart.com/index.php?rout ... rch=square
Yes and I did go through the set up. Everything looks correct with the extension and the cron job looks like it's working fine. I've had 2 orders that used that extension and both have come up with the error, but both were processed. The orders with PayPal don't have this problem.

User avatar
New member

Posts

Joined
Fri Sep 28, 2018 4:00 am

Post by johnp » Sun Dec 09, 2018 7:24 pm

Ok. Aything of note in the error log?

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.3 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades plus Ecommerce, Marketing and More
https://asandwhenbusinessservices.co.uk
https://asandwhenbusinessservices.co.uk ... e-services


User avatar
Active Member
Online

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by johnp » Sun Dec 09, 2018 8:22 pm

I installed the extension on my 1.5.6.5 based site and it froze the admin area and threw up controller errors. I would suggest getting in touch with the developer. They're a good company with good support.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.3 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades plus Ecommerce, Marketing and More
https://asandwhenbusinessservices.co.uk
https://asandwhenbusinessservices.co.uk ... e-services


User avatar
Active Member
Online

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by smwoodcrafts » Wed Dec 12, 2018 10:33 pm

I contacted iSenseLabs and was told that, since I use 1.5.6.5_rc, they can't help because it's not an official release. Or they can help if I pay them. I can't afford that. I am adding the error log. If anyone can help, I would appreciate it.

User avatar
New member

Posts

Joined
Fri Sep 28, 2018 4:00 am

Post by ADD Creative » Wed Dec 12, 2018 11:48 pm

You log file does show some possible issues with the payment module. But without access to the module it will be hard for anyone to help.

If iSenseLabs won't help because of the version. You could roll back to 1.5.6.4, as the changes were only minimal. Remember to take backups first. https://github.com/ADDCreative/opencart ... angelog.md

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by johnp » Thu Dec 13, 2018 12:18 am

Yep. A rollback would be recommended to help identify the issue. If the problem still exists on 1.5.6.4 then it's back to the developer.

Opencart 1.5.6.5/Default Theme/VQMOD 2.6.3 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades plus Ecommerce, Marketing and More
https://asandwhenbusinessservices.co.uk
https://asandwhenbusinessservices.co.uk ... e-services


User avatar
Active Member
Online

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK
Who is online

Users browsing this forum: No registered users and 9 guests