Post by Flimbees » Tue Jun 21, 2011 4:26 am

Hi everyone,

I have enabled the google base product feed in my admin control panel for my open cart site, but I have a couple of questions:

It provides me with this url: https://flimbees.co.uk/index.php?route=feed/google_base - can I submit the url only to google merchant centre or does it need to be in a particular file format?

From what I can see, it does need to be in either an xml or .txt format? But I don't know how to convert this url into one of these files successfully?

Any help would be much appreciated asap as I'm hoping to use google checkout also.

Thanks,
Sam

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am

Post by iidx036 » Tue Jun 21, 2011 5:41 pm

Hi Sam,

When you go to the Merchant Center the data feed file name can be anything you want e.g. products.txt - then create an upload schedule.

Its on the next popup that you need to enter the https://flimbees.co.uk/index.php?route=feed/google_base URL.

HTH,

Jay

Newbie

Posts

Joined
Tue Jun 14, 2011 5:50 pm

Post by Flimbees » Tue Jun 21, 2011 10:48 pm

Ok so I enter any product name like products.txt then when I go to the next screen where it says 'upload schedule' I click that, choose my upload frequency and provide the url of my feed and that's it?

What about if I want to do it manually? How do I create a proper feed?

Thanks,
Sam

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am

Post by iidx036 » Tue Jun 21, 2011 11:12 pm

Yep that's all you need to do.

I don't know what you mean a "proper feed"?? I have one thousand products in my product feed which google goes and retrieves with no problems every time my schedule tells it to using the Opencart URL method.

Jay

Newbie

Posts

Joined
Tue Jun 14, 2011 5:50 pm

Post by Flimbees » Wed Jun 22, 2011 2:24 am

What I mean by a proper feed is if I click on the option 'manual upload' a pop appears and tells me to upload a .txt or xml file. So I was wondering how to create this?

I've tried entering the url and it still says 'no items inserted'. I'm obviously doing something wrong?

Thanks,
Sam

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am

Post by Flimbees » Wed Jun 22, 2011 3:23 am

Ok after a lot of looking around I found a feed generator. I uploaded a test feed and got this response:

Feed name,Feed ID,Upload time "products.xml","3903561","21-Jun-2011 12:19 PDT" Item number,Line number,Message,Values,Snippet ,13,"XML formatting error","Column No.=75",

Can anyone shed a bit more light on this please??

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am

Post by iidx036 » Wed Jun 22, 2011 4:51 pm

Hi Sam,

I don't understand why you need to do a manual upload?

As regards to the "no items inserted" message - it could be one of these problems as per google's merchant center:

----------------------------------------------------------------------------------------------------------------------
For your reference, here are some of the most common reasons why your items may have been disapproved:

-Prices in your feed don't match the prices that appear on your item pages.
-The links included in your feed are broken.
-The links in your feed direct users to the homepage of your site instead of specific item pages.
-The currency and language in your feed don't match those of the target country.
-You've included promotional text (e.g., free shipping!) in the titles or descriptions of your items.
-You're submitting data from your marketplace shop.
----------------------------------------------------------------------------------------------------------

Newbie

Posts

Joined
Tue Jun 14, 2011 5:50 pm

Post by Flimbees » Thu Jun 23, 2011 4:24 am

I was attempting a manual upload because the schedules one wasn't working.

I've read over all the things that could possibly go wrong and everything seems to match my website ok, so I don't know why it wouldn't work?

I'm really struggling with this.

Thanks,
Sam

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am

Post by iidx036 » Thu Jun 23, 2011 5:07 pm

Can you give me a URL to look at so I can look at the google feed?

Jay

Newbie

Posts

Joined
Tue Jun 14, 2011 5:50 pm

Post by Flimbees » Thu Jun 23, 2011 8:41 pm

What URL do you mean? A product URL?

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am

Post by iidx036 » Thu Jun 23, 2011 8:54 pm

Can you give me the address of your site?

Newbie

Posts

Joined
Tue Jun 14, 2011 5:50 pm

Post by Xsecrets » Thu Jun 23, 2011 9:14 pm

the feed URL is in the first post.
If I open the feed url in IE I get

Whitespace is not allowed at this location.
Line: 897 Character: 462

Looks Like it doesn't like the & in a title.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by iidx036 » Thu Jun 23, 2011 9:38 pm

Doh! Forgot that was in the first post!

Xsecrets has it there ... :-)

Newbie

Posts

Joined
Tue Jun 14, 2011 5:50 pm

Post by Flimbees » Sun Jun 26, 2011 5:39 am

Xsecrets wrote:the feed URL is in the first post.
If I open the feed url in IE I get

Whitespace is not allowed at this location.
Line: 897 Character: 462

Looks Like it doesn't like the & in a title.
That is perfect! Thank you so much.

I removed all the '&' in titles and brand names and it worked! I'm so happy. Thanks for your help ;D

Newbie

Posts

Joined
Tue Apr 12, 2011 6:52 am
Who is online

Users browsing this forum: No registered users and 1 guest