Post by simplex » Tue Jan 26, 2010 10:16 pm

Voor een website van een klant van ons heb ik het Mollie ideal pakket geinstalleerd. Dit heeft anderhalve maand goed gedraaid, maar sinds kort worden we bij het voltooien van een transactie getracteerd op:

Code: Select all

Error: Duplicate entry '' for key 1
Error No: 1062
INSERT INTO `mollie_transactions` (`order_id` ,`transaction_id`) VALUES ('143', '');
Is er iemand die een idee heeft, waar je dit moet zoeken? Ik heb zelf al de volgende acties ondernomen:

- database vernieuwd, gespeeld met INT / BIGINT
- bestanden van mollie_ideal opnieuw geupload

Ik heb werkelijk geen idee, wat hier het probleem is...misschien iemand van jullie?

Newbie

Posts

Joined
Thu Oct 22, 2009 3:00 pm
Location - The Netherlands

Post by i2Paq » Tue Jan 26, 2010 10:28 pm

Het lijkt er op dat er een duplicate entry aanwezig is.

Ik neem aan dat die Mollie module betaald is, misschien even contact opnemen met Mollie.

Als je de tabelen update haal dan even je site off-line zodat ze niet in gebruik zijn (locked).
Overigens zou ik zeker even kijken naar de "missing orders", misschien dat daar je probleem huist.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by simplex » Wed Jan 27, 2010 12:38 am

Het maakt niet uit, of er iets of niets in de database staat. Het script maakt bij het ontbreken van de databasevelden zelf de benodigde velden aan. Als ik de desbetreffende tabel leegmaak blijft het probleem bestaan.

De Mollie module is de mollie module, zoals te downloaden uit de extensions. (Dus niet betaald)

Newbie

Posts

Joined
Thu Oct 22, 2009 3:00 pm
Location - The Netherlands

Post by i2Paq » Wed Jan 27, 2010 12:41 am

simplex wrote:Het maakt niet uit, of er iets of niets in de database staat. Het script maakt bij het ontbreken van de databasevelden zelf de benodigde velden aan. Als ik de desbetreffende tabel leegmaak blijft het probleem bestaan.

De Mollie module is de mollie module, zoals te downloaden uit de extensions. (Dus niet betaald)
Tja, dan zal daar een "echte" coder naar moeten kijken.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by yvalni » Wed Jan 27, 2010 5:54 am

Ik heb ook nog geen oplossing alleen dat je niet de enige bent...
http://forum.opencart.com/viewtopic.php?f=22&t=8125

Heb je wel deze versie gebruikt?
Opencart 1.4.0 en hoger: v1.3 downloaden

http://www.janssencox.nl/opencart

En wel ff doneren ;)

Alex

New member

Posts

Joined
Wed Jan 20, 2010 3:04 am
Location - Rijswijk Zuid Holland

Post by simplex » Wed Jan 27, 2010 9:06 pm

Eh...nee, want de versie van OC die op de desbetreffende server draait is 1.3.3, dus een iets oudere versie. Maar het gekke is, dat het van de een op de andere dag niet meer werkt. Het is net, of de webhost er iets mee te maken heeft. Als je op de foutmelding zoekt, zie je meldingen van corrupte tabellen etc. dus ik heb de boel ook al proberen te herstellen. Maar, dat heeft geen gevolg.

Ik wordt een beetje simpel van dit soort dingen. De shop moet eigenlijk geupadate worden, maar gezien de ellende die we gehad hebben met de customer_uploads, zie ik daar een beetje tegenaan. De customeruploads is namelijk nogal eenkennig, wat Jquery betreft.... Dus als ik de boel update, haal ik mezelf weer een heleboel werk op de hals. Het mooiste was dus als de boel gewoon in oude staat kan worden hersteld....

Maar, ik ben bang, dat ik straks weer een hele dag aan het klooien ben....

Newbie

Posts

Joined
Thu Oct 22, 2009 3:00 pm
Location - The Netherlands

Post by yvalni » Wed Jan 27, 2010 10:59 pm

Kan je niet naar versie 1.3.4 dan, misschien wanneer je de Mollie en je module upgrade naar 1.3.4. krijg je het wat makkelijker weer werkend, maak een backup van je gehele site + database en probeer het in ieder geval, voor 1.4.0 zou ik nog even wachten totdat alles is bijgewerkt..

( http://forum.opencart.com/viewtopic.php?f=23&t=8700 )

Het kan ook best zo zijn dat de api van Mollie is veranderd...

Alex

New member

Posts

Joined
Wed Jan 20, 2010 3:04 am
Location - Rijswijk Zuid Holland

Post by ocram » Thu Feb 04, 2010 6:51 am

Hallo,

De foutmelding die je omschrijft ontstaat doordat het aanvragen van de transactie bij Mollie misgaat. Met andere woorden: Mollie geeft geen geldige transactiecode terug. Vervolgens probeert de module het Opencart order-id aan een niet bestaande transactiecode te koppelen in de database en dat gaat mis.
Heb je niet toevallig instellingen in het Mollie admin-gedeelte veranderd? Als je me precies kunt zeggen welke versie van de module je gebruikt zal ik er even naar kijken. Je kunt me eventueel ook mailen op marco@janssencox.nl.

Groeten, Marco Cox (maker van de Mollie iDEAL module)

Newbie

Posts

Joined
Tue Sep 15, 2009 2:57 am
Location - The Netherlands

Post by Paradontax » Wed Mar 10, 2010 5:42 pm

Hallo,

Is er al een oplossing voor dit probleem?

Groet,
Leo

Newbie

Posts

Joined
Wed Mar 10, 2010 5:39 pm
Who is online

Users browsing this forum: No registered users and 6 guests