Post by gabrielmartins » Thu Nov 24, 2011 1:05 am

Seguinte, quando você abre a página de um produto na loja do Opencart (tema defaut) aparecem logo abaixo da imagem principal isto: Descrição - Outras imagens (3) - Opniões (3) - Produtos relacionados (4)

Image

Enfim, isso são botões (óbvio), mas a questão é.. quando clico neles não acontece nada, e eu quero que quando clicar neles vá direto para o ítem que é como deveria de ser, eu sei que é um erro no meu template, mas não entendo nada de PHP, se alguém puder ajudar eu agradeceria.

Minha loja: www.webzica.com


Posts

Joined
Wed Nov 23, 2011 10:31 am

Post by nytrous » Thu Nov 24, 2011 1:22 am

boas;
quase de certeza que se fizeres o Update para a versão:
Opencart 1.4.9.6 que isso fica a funcionar ;)

Image


New member

Posts

Joined
Tue Oct 25, 2011 2:24 am

Post by gabrielmartins » Thu Nov 24, 2011 7:23 am

Provavelmente o erro seria resolvido sim, mas eu tenho módulos importante que só existem por enquanto na versão 1.4.9.5, dai eu ia sair perdendo. Alguém tem uma outra solução sem ser atualizar o Opencart ?


Posts

Joined
Wed Nov 23, 2011 10:31 am

Post by nytrous » Thu Nov 24, 2011 5:41 pm

Já utilizei a versão 1.4.9.5 e qdo saiu a 1.4.9.6 actualizei em todas as lojas que tinha para gerir e até hoje não conheço nenhum modulo que não funciona-se, mas são opções....
podes sempre tentar fazer o download da versão 1.4.9.5 outra vez e enviar para o servidor a template default para ver se funciona pois esses erros são provenientes do css!
outra coisa que podes fazer é ires a sistema e ver o LOG de erros para ver quais os ficheiros que estão a dar problemas!

Image


New member

Posts

Joined
Tue Oct 25, 2011 2:24 am

Post by gabrielmartins » Thu Nov 24, 2011 11:32 pm

Se eu atualizar minha versão para 1.4.9.6 eu posso continuar usando o template da versão anterior 1.4.9.5 ?
É que eu fiz algumas modificações no defaut, mudei ícones, textos de alguns módulos enfim.
Mas no Log de erros não aparece nenhum erro referente ao mesmo não.
Mas tudo bem minha loja não vai falir por causa disso hsuahus'

Mas se alguém tiver uma solção já me ajudaria muito :joker:


Posts

Joined
Wed Nov 23, 2011 10:31 am

Post by nytrous » Fri Nov 25, 2011 3:22 am

gabrielmartins wrote: É que eu fiz algumas modificações no defaut, mudei ícones, textos de alguns módulos enfim.
se calhar então é por isto que essas abas não funcionam como deve de ser, pois por exemplo alteração textos deve ser feita nas traduções e não na propria theme;
alteração de icones devem ser feitos no .CSS da theme....!
é verificares o que alteras-te e ver qual o erro de sintax existente e corrigires!

Cumps

Image


New member

Posts

Joined
Tue Oct 25, 2011 2:24 am

Post by gabrielmartins » Fri Nov 25, 2011 7:45 am

Eu não alterei textos na Theme, alterei nas traduções mesmo que é o correto.
Quando eu instalei o Opencart 1.4.9.5 já tava com esse erro, e mesmo reinstalando tudo novamente permaneceu o erro. Baixei a versão 1.4.9.5 completa e alterei só o arquivo referente ao carrinho e nada aconteceu, fiz o mesmo com o arquivo referente aos botões "tab" da página do produto e nada também.

Tentei fazer a mesma coisa que eu fiz só que com o arquivo da versão 1.4.9.6 mas mesmo assim não alterou em nada.
Parece que é um erro no template mesmo. Quanto ao erro do botão remover no carrinho, eu alterei a imagem do "X" vermelho, coloquei outra no lugar para não parecer que é um botão de remoção de produtos do carrinho.

A página do carrinho que tem aquela caixa de assinalar que serve para remover o produto do carrinho quando clica em atualizar carrinho, eu mudei, coloquei um botão com efeito ajax, quando clica nele o produto é removido, ficou muito melhor.

Quem me ajudou nisso foi um amigo que é dono do site: www.surgimento.com.br

Enfim, vou aguardar uma solução a não ser atualizar a versão.

Minha loja: www.webzica.com
Meu site de informática: www.helpaki.com


Posts

Joined
Wed Nov 23, 2011 10:31 am

Post by gabrielmartins » Tue Nov 29, 2011 5:52 am

O erro infeslimente é da versão 1.4.9.5, não é por causa de nenhum tipo de modificação nem nada. É apenas um bug.

Mas consegui o arquivo: catalog/view/javascript/jquery/tab.js
Substitui o arquivo com defeito por um modificado, que foi o Jeann do blog www.surgimento.com.br quem criou.

Caso alguém esteja com o mesmo problema, mande um email para: gabrielmartins2010@bol.com.br que enviarei o arquivo por email.

Obrigado a todos.


Posts

Joined
Wed Nov 23, 2011 10:31 am

Post by telmomoreira » Mon Aug 06, 2012 1:10 am

Pessoal, preciso de ajuda no meu site / opencart.

Instalei e tenho personalizado, mas como percebo pouco não sei onde alterar o texto nos botoes, ex: (comprar) está "button_cart".

Podem ajudar... o site é compronaweb.com . Obrigado

Newbie

Posts

Joined
Sun Aug 05, 2012 4:57 am
Who is online

Users browsing this forum: No registered users and 1 guest