Post by Cody » Tue Aug 03, 2010 5:04 am

Notei que quando fazemos uma compra e estamos utilizando o modulo PAC ele calcula tudo certinho exemplo:

Valor do produto: 50,00
Valor do PAC: 10,00
Valot Total: 60,00

Até ae tudo bem, porem na forma de pagamento vamos dizer que eu esteja usando o UOL PagSeguro!
ele me manda para uma tela e nesta tela ele tem o valor do meu produto + 1,00 real que é o valor do boleto (isso considerando a forma de pagamento como BOLETO) então o valor total que mostra é:

50,00 + 1,00 = 51,00

Agora me digam cadê o valor do PAC? Se na loja consta 60,00 então por logica teria que ser:

Valor Total da Loja: 60,00 + Valor do boleto: 1,00 = 61,00 <= Total de tudo para o cliente pagar.

Meus caros amigos eu tou aqui mechendo no opencart já faz umas duas semanas ou mais explorando ele, é um sistema maravilhoso mas encontro diversas dificuldades quanto a sua forma de gerenciamento e praticidade. Bem voltando ao assunto de origem:

Como posso fazer para que o pagseguro inclua o valor do PAC, SEDEX, e demais outros tipos de forma de envio e calcule o frete e inclua ele perfeitamente na forma de pagamento?

Alguem já notou isso quando add os produtos e faz a compra? ???

desde já obrigadinho...

New member

Posts

Joined
Mon Jul 12, 2010 10:45 pm

Post by rochester » Tue Aug 03, 2010 10:12 pm

Qual modulo do pagseguro você está usando?

Pelo que entendi deve ser um erro na programação dele mesmo, ele só tá pegando o valor do produto, em vez de pegar o valor do carrinho.

Pra fazer mais um teste, tenta ativar um cupom de desconto, e joga ele. Se o modulo tiver pegando só o preço do produto, ele deve ignorar o cupom (que é aplicado sobre o carrinho).

--
Rochester Oliveira


Active Member

Posts

Joined
Thu Jul 01, 2010 2:15 am

Post by Cody » Tue Aug 03, 2010 10:52 pm

Estou usando a versão do PagSeguro 1.4.8b, fiz o teste que falou e realmente ele não puxa o valor :-[

versão do PAC e SEDEX que uso é também 1.4.8b

o que posso fazer para corrigir isto?

New member

Posts

Joined
Mon Jul 12, 2010 10:45 pm

Post by rochester » Tue Aug 03, 2010 10:55 pm

Provavelmente tem q mudar o código deles, ele foi feito errado, pelo que entendi.

Tente achar outro módulo, na lista do poen cart brasil tinha bastante módulos lá, talvez o deles esteja melhor.

--
Rochester Oliveira


Active Member

Posts

Joined
Thu Jul 01, 2010 2:15 am

Post by Mallmann » Tue Aug 03, 2010 11:05 pm

Ae Cody, o Rochester manja muito desse negocio, me ajudou a resolver um problema nesse modulo.

Dá uma olhada lá cody, pois sei que tu ta usando a mesma loja que eu e a mesma versão do mod do PagSeguro e no meu funciona o cupon de desconto, mas tb tem o mesmo erro no calculo do PAC.

T+
;D

Newbie

Posts

Joined
Fri Feb 05, 2010 10:16 pm

Post by Cody » Wed Aug 04, 2010 11:09 am

Estou verificando este arquivo assim que corrigir ou achar uma solução informarei aqui ;)

New member

Posts

Joined
Mon Jul 12, 2010 10:45 pm

Post by rochester » Wed Aug 04, 2010 12:03 pm

Cody, se precisar de uma ajuda, não entender algo do código, ou qualquer coisa assim só me avisar por PM. Não tenho esse módulo instalado, mas já ralei bastante com integração de módulos então dá pra ajudar a achar os erros.

--
Rochester Oliveira


Active Member

Posts

Joined
Thu Jul 01, 2010 2:15 am

Post by denisgomes » Wed Aug 04, 2010 10:59 pm

Verifique também a configuração de cálculo de frete do PagSeguro. Se não me engano existem duas opções: com cálculo feito por eles e sem cálculo. Se você estiver usando o cálculo deles, verifique o módulo do OpenCart, que deve repassar o peso total do pedido ao enviar os dados para o PagSeguro - ou ele irá considerar o pedido como virtual (download de arquivos, p.ex.). Se você estiver usando sem cálculo (ou seja, prefere calcular o frete pela loja), então o módulo deve incluir o frete como um item separado ao enviar para o PagSeguro.

Newbie

Posts

Joined
Wed Aug 04, 2010 3:57 am
Who is online

Users browsing this forum: No registered users and 4 guests