Post by webpie it. » Thu Jun 23, 2011 11:42 pm

The title is a question i asked myself today, just curious really because i won't be changing over my 1.4xs to 1.5 any time soon at the moment.

Everyone seems to call it an upgrade, i guess it is from some peoples perspectives, but for me, it's not really.

I have found 1.4 to be fantastic to "my needs", especially 1.4.9.3, no real reason just like this V.

I see Q is working on 1.4.9.6 which is fantastic news!

What daniel has done on 1.5 is awesome, i just find its in its infantcy at the moment, and i do try to do any bug searching i can, but when its quiet(real busy atm, thanks to oc of ofcourse) i will have a proper look, ive installed it had a go, really love it, but some time i will need to be spend looking over changes! Great to see the mods all comp. With 1,4x and 1.5x coming out!

Anyway, back to my original question is 1.4x support going to continue? I suppose it is hard to say as the community kind of dictate this, depending on how much 1.5 is accepted as an"upgrade".

But just looking for thoughts and an official word on this From Q or one of the moderators.

But thanks for making OC so great to work with!

Many thanks over

Chris

Regards

Chris


Active Member

Posts

Joined
Mon Jan 31, 2011 7:28 pm

Post by i2Paq » Thu Jun 23, 2011 11:53 pm

As the 1.4.x family differs a lot from the 1.5.x family I hope and believe that they both will be supported in the months to come.

1.5.x is missing some feature that where in 1.4.x and 1.5.x has some new features that a lot find un-usable (no AJAX) where working with 1.4.x is a breeze.

If 1.4.x is working for you, it is for me, there is no need to upgrade to 1.5.x.
At some point 1.4.9.x will be stable and there will be no more new development made. If a bug or issue is found there will still be all the help here on these forums. Like you get when using 1.3.x.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by webpie it. » Fri Jun 24, 2011 12:02 am

Awesome response i2paq.

Thanks very much, nice to know from a mod that you feel exactly the same way as i have over the last few weeks, as i have watched 1.5 rolled out.
1.5.x is missing some feature that where in 1.4.x and 1.5.x has some new features that a lot find un-usable (no AJAX) where working with 1.4.x is a breeze.
Hit it on the nail here! I'm sure over time it will sort itself out naturally as 1.5 is used more and more. But i think i just have a real liking to 1.4x, like apple fanboys have to apple! Lol
At some point 1.4.9.x will be stable and there will be no more new development made. If a bug or issue is found there will still be all the help here on these forums. Like you get when using 1.3.x.
Really good to know, thanks i2paq, your assurance and detail on this subject is good enough for me!

Cheers buddy

Chris

Regards

Chris


Active Member

Posts

Joined
Mon Jan 31, 2011 7:28 pm

Post by i2Paq » Fri Jun 24, 2011 12:47 am

Daniel wrote:yes Google checkout will be coming. i'm working on 1.5.1 at the moment. that will have more reports and the order editor back. I'm also trying to hire 2 developers in Hong Kong to start working on extensions like Google checkout and many other things I think needs to be included in future releases.
Just found this in the 1.5.0 release-topic.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by webpie it. » Fri Jun 24, 2011 1:07 am

Excellent idea, ithinkthis has been missing from OC! For sure, i actually prefer this over paypal! And so do many clients when they see it running!

Regards

Chris


Active Member

Posts

Joined
Mon Jan 31, 2011 7:28 pm

Post by Xsecrets » Fri Jun 24, 2011 2:18 am

webpie it. wrote:Excellent idea, ithinkthis has been missing from OC! For sure, i actually prefer this over paypal! And so do many clients when they see it running!
well it may not have been in the core distribution, but there has been a module available for google checkout for quite a long time now.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by Qphoria » Fri Jun 24, 2011 3:20 am

I am planning on releasing 1.4.9.6 soon that just has bug fixes. No new features. That will start rounding off the 1.4.9.7 and 1.4.9.8 and that will pretty much end the 1.4.x series. Hopefully by that time 1.5.x has gained some more all around stability.. or daniel has decided to scrap it all and start fresh :P

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by i2Paq » Fri Jun 24, 2011 4:00 am

Qphoria wrote:or daniel has decided to scrap it all and start fresh
Your, you, you..., Evil man!

;D

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by ckonig » Thu Jul 14, 2011 9:06 pm

I am really looking forward to see the next 1.4 releases.
I worked on a OpenCart systems for 6 months using vQmod to keep it upgradeable. But re-working my 35 vQmods for 1.5 is not really desirable... and thanks to god also not necessary!
So I am going to wait for the next 1.4 releases, and when its done, i will merge all vqcache files to the core, because at this point the vqcache code starts to look messy.... ever seen a single sql query getting modified by 10 vQmods, you know what i mean.

User avatar
Active Member

Posts

Joined
Wed Feb 16, 2011 4:26 pm
Location - Netherlands

Post by Qphoria » Thu Jul 14, 2011 10:09 pm

ckonig wrote:I am really looking forward to see the next 1.4 releases.
I worked on a OpenCart systems for 6 months using vQmod to keep it upgradeable. But re-working my 35 vQmods for 1.5 is not really desirable... and thanks to god also not necessary!
So I am going to wait for the next 1.4 releases, and when its done, i will merge all vqcache files to the core, because at this point the vqcache code starts to look messy.... ever seen a single sql query getting modified by 10 vQmods, you know what i mean.
There is an option in vqmod called "VirtualMode=false" that will actually write the mods to the original source permanently. I recommend using it just the one time and changing it back to true

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 17 guests