Post by carol » Sun Oct 04, 2020 2:47 am

I installed the Journal theme 3,0,3,6 (the last vertion) 3,1,4 ...........
and i only have messages that my php vertion is not the correct one ...

I have 7.4 --- it tells me that I must have 7.3 and less
but here I change the vertion 7.4 to 7.3 or 7.2 ...
nothing works ?

Newbie

Posts

Joined
Sun Oct 04, 2020 2:32 am

Post by OSWorX » Sun Oct 04, 2020 5:53 am

carol wrote:
Sun Oct 04, 2020 2:47 am
I installed the Journal theme 3,0,3,6 (the last vertion) 3,1,4 ...........
and i only have messages that my php vertion is not the correct one ...

I have 7.4 --- it tells me that I must have 7.3 and less
but here I change the vertion 7.4 to 7.3 or 7.2 ...
nothing works ?
Wrong Forum here for this Extension!
Correct place is:
https://docs.journal-theme.com/docs/general
https://support.journal-theme.com/index.php?a=add

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by xxvirusxx » Sun Oct 04, 2020 3:05 pm

Edit catalog/controller/journal3/startup.php and remove:

Code: Select all

			// php version check
			if (version_compare(VERSION, '3.1', '<') && version_compare(phpversion(), '7.4', '>=')) {
				$this->print_error(
					'Unsupported PHP Version',
					'Opencart <b>' . VERSION . '</b> does not fully support PHP <b>' . phpversion() . '</b> version!',
					'Consult with your hosting provider for more information regarding how to downgrade PHP to 7.3 (or lower).'
				);
			}

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by SVN » Tue Feb 16, 2021 6:53 pm

xxvirusxx wrote:
Sun Oct 04, 2020 3:05 pm
Edit catalog/controller/journal3/startup.php and remove:

Code: Select all

			// php version check
			if (version_compare(VERSION, '3.1', '<') && version_compare(phpversion(), '7.4', '>=')) {
				$this->print_error(
					'Unsupported PHP Version',
					'Opencart <b>' . VERSION . '</b> does not fully support PHP <b>' . phpversion() . '</b> version!',
					'Consult with your hosting provider for more information regarding how to downgrade PHP to 7.3 (or lower).'
				);
			}
Did not help for me, now I have another error.

Fatal error: Uncaught Error: Class 'Twig\Loader\ArrayLoader' not found in /system/library/template/twig.php:31 Stack trace: #0 /storage/modification/system/library/template.php(59): Template\Twig->render('journal3/templa...', '<style>\n /*No ...') #1 /storage/modification/system/engine/loader.php(133): Template->render('journal3/templa...', '') #2
/catalog/controller/journal3/settings.php(155): Loader->view('journal3/css', Array) #3
/storage/modification/system/engine/action.php(79): ControllerJournal3Settings->index(Array) #4
/storage/modification/system/engine/loader.php(54): Action->execute(Object(Registry), Array) #5
/catalog/controller/journal3/startup.php(88): in /system/library/template/twig.php on line 31

User avatar
SVN
Active Member

Posts

Joined
Mon Jan 03, 2011 11:59 pm

User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România
Who is online

Users browsing this forum: No registered users and 4 guests