Post by cooldeveloper » Wed Oct 02, 2019 7:25 pm

I have a new project coming up. I am in a dilemma as to whether I should use OpenCart 3.0.3.2 or wait for the next big version (whenever it arrives).

Some people are even recommending me to move down to version 2.3.0.2 which I actually don't want to opt because I want to use PHP 7 and be PCI compliant which is not easily possible with that version.

I know that it's not a new question and has been asked a couple of times earlier also. But after a passage of time, this question needs to be revisited and discussed again. Without any clarity on the future roadmap, developers and other stakeholders will look out for other greener pastures.

Newbie

Posts

Joined
Fri Aug 24, 2012 7:35 pm

Post by Johnathan » Wed Oct 02, 2019 10:42 pm

OpenCart 3.1 has been in development for 2+ years, so there's really no telling when it will be released. If you have a project that has a deadline, you should go with 3.0.3.2, otherwise you could be waiting for another 2 years.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by MarketInSG » Thu Oct 03, 2019 10:35 pm

There's a lot of hiccups over the past couple of months from what I understand. A new version was supposedly ready, but i'm not sure why it isn't released. So I do agree with Jonathan that you should just use the latest available version rather than to wait (even if you have no deadline).


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by xxvirusxx » Fri Oct 04, 2019 1:07 am

Johnathan wrote:
Wed Oct 02, 2019 10:42 pm
you should go with 3.0.3.2, otherwise you could be waiting for another 2 years.
And after that you will fix all bugs for free?

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by Johnathan » Fri Oct 04, 2019 10:27 pm

Sorry, I'm not sure I understand your question. Are you asking if I will fix all bugs in OpenCart 3.0.3.2 for free after 2 years?

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by xxvirusxx » Sun Oct 06, 2019 1:25 am

Your recommendation is to update to 3.0.3.2 but you forget to specify that 3.0.x version has bugs :)

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by Johnathan » Mon Oct 07, 2019 10:39 pm

The only reason I did that is because the original poster specifically said they didn't want to use 2.3:

cooldeveloper wrote:
Wed Oct 02, 2019 7:25 pm
Some people are even recommending me to move down to version 2.3.0.2 which I actually don't want to opt because I want to use PHP 7 and be PCI compliant which is not easily possible with that version.
I agree that OpenCart 3.0 still having bugs after 2+ years is ridiculous, so I recommend OpenCart 2.3.0.2 for new installations as well. It's easier to install and implement at this point. However, if you want to go with 3.0 then you should use 3.0.3.2, and then visit github to review all the bugs that you'd need to fix.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by xxvirusxx » Tue Oct 08, 2019 1:43 pm

Johnathan wrote:
Mon Oct 07, 2019 10:39 pm
I agree that OpenCart 3.0 still having bugs after 2+ years is ridiculous, so I recommend OpenCart 2.3.0.2 for new installations as well.
Yep, and on Release Notes doesn't write if may have or not bugs and when users install...bugs strike again :laugh:

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO
Who is online

Users browsing this forum: No registered users and 26 guests