Post by TheCreatables » Mon Apr 13, 2015 11:41 pm

Hello Guys,

How would I go about removing the red asterisk in the checkout section.

Which file would I go to and what would I remove?

Thanks

Charlotte

New member

Posts

Joined
Fri Feb 13, 2015 8:35 pm

Post by EvolveWebHosting » Tue Apr 14, 2015 1:20 am

Which field(s) are you trying to remove? The red asterisk is there to let a visitor know that it's required to complete the form.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by TheCreatables » Tue Apr 14, 2015 4:36 pm

Hello,

I am trying to remove the red asterisk from address 2 and company. I have made them so they are no longer compulsory to continue, but would now like to take the red asterisk off.

Thanks

Charlotte

New member

Posts

Joined
Fri Feb 13, 2015 8:35 pm

Post by fido-x » Tue Apr 14, 2015 5:45 pm

Which version of OpenCart are you using???

The "Company" field has not been required for quite a few versions now and the "Address 2" field has never been required.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by TheCreatables » Tue Apr 14, 2015 6:45 pm

I am running 2.0.1.1 and yes, but I would still like to remove the red asterisks?

Thanks

Charlotte

New member

Posts

Joined
Fri Feb 13, 2015 8:35 pm

Post by fido-x » Tue Apr 14, 2015 7:09 pm

TheCreatables wrote:Hello,

I am trying to remove the red asterisk from address 2 and company. I have made them so they are no longer compulsory to continue, but would now like to take the red asterisk off.

Thanks

Charlotte
There are NO asterisks next to these fields in a default OpenCart 2.0.1.1 template.

As previously stated, the company and address 2 fields are NOT required fields and there is no validation on these fields in the controller.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by TheCreatables » Tue Apr 14, 2015 8:56 pm

Please see the attachment for the red asterisks that are there and what I want removed.

Cheers guys!

Charlotte

Attachments

Screenshot.jpg

Red asterisks I want removed - Screenshot.jpg (315.69 KiB) Viewed 2145 times


New member

Posts

Joined
Fri Feb 13, 2015 8:35 pm

Post by fido-x » Tue Apr 14, 2015 9:11 pm

fido-x wrote:There are NO asterisks next to these fields in a default OpenCart 2.0.1.1 template.
From the screenshot provided, you're not using the default template!

Perhaps you should have stated this in the first place or, alternatively, asked the template designer how to remove them, since he/she put them there in the first place. Further, with no link to your site, how was anybody supposed to look at what's been done so that they can help. For example: did your template designer use the same classes as in the default template, or did he/she use different classes?

If the classes being used in your custom template are the same as those being used in the default template, you should replace the following:

Code: Select all

<div class="form-group required">
with:

Code: Select all

<div class="form-group">
If the classes are not the same, then nobody can help you except the template designer.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by TheCreatables » Tue Apr 14, 2015 9:15 pm

Lol we can't all be experts. Thanks for your help though. :)

New member

Posts

Joined
Fri Feb 13, 2015 8:35 pm

Post by fido-x » Tue Apr 14, 2015 9:28 pm

No worries. My apologies if you felt insulted by anything I've said. It wasn't my intention. It can be rather frustrating trying to help someone when they haven't provided the relevant information.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by TheCreatables » Tue Apr 14, 2015 9:30 pm

No apologises needed! :)

I have already removed the required term from the files in those locations and the dreaded red asterisks still remain! :O

New member

Posts

Joined
Fri Feb 13, 2015 8:35 pm

Post by fido-x » Tue Apr 14, 2015 10:53 pm

Because the sections of the checkout page are loaded through ajax calls, it is not possible to view the page source for these files.

Having viewed your site (got the url from the screenshot you provided), it looks like you're using one of those "fancy" journal themes.

You could try looking at the "guest.tpl", "payment_address.tpl" and "shipping_address.tpl" files in your theme's "template/checkout" directory and see if there is any "required" class for the company and address 2 fields in those files. If that doesn't work, I can only suggest contacting the developer/designer of the theme to find out how to remove the asterisks.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by samaraki » Mon Aug 12, 2019 4:06 pm

Did you resolve this issue? I have it using Journal 3 / Opencart 3.0.3.2
For me it only happens on the guest checkout.

Active Member

Posts

Joined
Fri Jul 26, 2013 2:36 pm
Who is online

Users browsing this forum: No registered users and 15 guests