Search found 1352 matches

Search found 1352 matches

Data Migration from v1.5.6.4 to v2.1.0.1

I have not yet perfected the total migration from v1.5.x to 2.1.x but I figured what I have done so far can help others. If you find something missing or have something helpful to add, please feel free to let me know and I could possibly add it to the existing migration to make it better. I have att...

Jump to post
  • Wed Dec 23, 2015 2:34 pm
  • Replies 26
  • Views 3814
Re: route=common/home page not found

Found the issue. It was in the config.php file that had an incorrect path. I will attempt to see if I can make this error report the possible reason for this error to help debug this issue in the future.

Jump to post
  • Mon Dec 21, 2015 3:06 pm
  • Replies 1
  • Views 359
route=common/home page not found

Always getting this message after upgrade. I can access the admin panel but not the store. Where do I look to fix this issue?
Does not do this on other store sites on same website different folder. clean install no code changes...

Jump to post
  • Mon Dec 21, 2015 1:00 pm
  • Replies 1
  • Views 359
Re: After upgrade from 1.5.6.4 to 2.0.1.1

Also the admin config.php is like posted above for the root config.php remove

// HTTP
define('HTTP_CATALOG', 'https://***************/****************/');

// HTTPS
define('HTTPS_CATALOG', 'https://************/**********************/');

Jump to post
  • Mon Dec 21, 2015 11:54 am
  • Replies 2
  • Views 346
Re: Upgrading from 1.5.x to 2.1.x Issue

BTW: In migrating your images you will need to download them from the original site from \image\data\ then upload them to \image\catalog\ in the new location of your OpenCart upload location.

Jump to post
  • Sun Dec 20, 2015 8:07 am
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

One more file that needed to change to remove some errors. The file can be found in \upload\admin\language\english\common\header.php. Change notation in attached file.

Jump to post
  • Sun Dec 20, 2015 4:47 am
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

In order to get to the point where I had the original issue, I have attached the upgrade.php that I used. It has two minor changes but will get you to the point where information in some tables needs to be changed (prior posts with attachements in this thread). The original author of this script did...

Jump to post
  • Sun Dec 20, 2015 3:45 am
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

Another issue solved with being denied access to certain areas of OpenCart in the Admin panel. Please use the following SQL to remedy this situation ONLY if you have the default user groups (2). If you have more user groups, just replace the permissions for the Top Administrator for now.

Jump to post
  • Sat Dec 19, 2015 6:37 pm
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

I found the answer to this issue. It was the oc_settings table. The contents of this table has to be truncated and new data inserted into the file. I have included the SQL needed to do this. There are more issue and I will post them as I solve them to get a working migration tool to the latest versi...

Jump to post
  • Sat Dec 19, 2015 5:34 pm
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

If you can't be helpful why annoy? Data portability has nothing to do with program compatibility... There has NEVER been a system that I have worked on that my data could not be ported to the latest version...

Telling someone other than that is just plain inexperience...

Jump to post
  • Sat Dec 19, 2015 9:14 am
  • Replies 56
  • Views 6524
Re: After upgrade from 1.5.6.4 to 2.0.1.1

You will need to add DIR_MODIFICATION to your config.php files in the root and in the admin folders for OpenCart, if the parameter is not there. This is what my config.php file looks like, the asterisks would be where you would place your information: <?php // HTTP define('HTTP_SERVER', 'https://***...

Jump to post
  • Sat Dec 19, 2015 9:08 am
  • Replies 2
  • Views 346
Re: Upgrading from 1.5.x to 2.1.x Issue

The upgrade is indeed busted... I managed to correct some of the minor issues in the upgrade due to it NOT stepping thru the tables properly and attempting to drop and index that it already changed. Now I am getting some JSON errors and implode errors which probably means that the upgrade forgot to ...

Jump to post
  • Sat Dec 19, 2015 8:14 am
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

Thanks, Yes I see that the documentation is not that clear on that extension just what will happen. I will give it a try.

Jump to post
  • Thu Dec 17, 2015 5:19 pm
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

OK, yes this is why we run a test for the upgrade so that we can see what will work and what will not or needs to be changed. I would have thought that the developers would have written a script for the database changes and that would be included in the "Upgrade" portion of the install. Of course we...

Jump to post
  • Thu Dec 17, 2015 5:11 pm
  • Replies 56
  • Views 6524
Re: Upgrading from 1.5.x to 2.1.x Issue

Why would I NOT want to migrate to 2.1.x??? I don't understand the question.
I followed the OpenCart directions to upgrade... Aren't those directions correct?

Jump to post
  • Thu Dec 17, 2015 4:46 pm
  • Replies 56
  • Views 6524
Upgrading from 1.5.x to 2.1.x Issue

I wanted to upgrade from 1.5.x to 2.1.x and I did the following: Created New FTP upload location Exported Production Database into SQL text file Created new test database Imported SQL dump into new test database Uploaded 2.1.0.1 software folder to new FTP upload location Copied config.php from produ...

Jump to post
  • Thu Dec 17, 2015 4:18 pm
  • Replies 56
  • Views 6524
Software Subscription Renewals

I need a way for customers to purchase license renewals. The way I need is for the customer to select the product(s) that they want to purchase renewals for and they enter their current license and the systems checks a table for existing licenses. if the license exists then and only then will the di...

Jump to post
  • Mon Mar 23, 2015 7:04 am
  • Replies 0
  • Views 158
Re: Need Coupons / Discount Extension

Yes, I am aware that coupons are built int OpenCart but it does not fit my needs. I have check some of the other extensions on OC but the descriptions of what they actually do and don't do are so poor...

Jump to post
  • Fri Mar 20, 2015 8:20 pm
  • Replies 2
  • Views 320
Re: Vqmod is not working for a lot of extensions

Your best bet to finding which mod is not working is to install the VQMod Manager. It will show you which installs are not working and where they are not working. It is free and will help solve your headaches. It is located here: http://www.opencart.com/index.php?route=extension/extension/info&exten...

Jump to post
  • Fri Mar 20, 2015 4:57 pm
  • Replies 2
  • Views 421

Search found 1352 matches