Search found 891 matches

Search found 891 matches

Re: Rounding total problem

It could be due to OpenCart using 4 decimal places for the prices. All calculations are done and then converted to the number of decimal places for display.

What are your exact product prices and cart totals?

Jump to post
  • Wed Jan 09, 2019 5:53 am
  • Replies 10
  • Views 582
Re: WYSIWYG Admin Editor Doesn't Show - Firefox 64.0 (64-bit)

Working for me in Firefox 65.0b9 (64-bit), 64.0 (32-bit) and 60.4.0esr (64-bit).

Do you see any error messages in the Firefox developer console?

Jump to post
  • Wed Jan 09, 2019 5:46 am
  • Replies 2
  • Views 215
Re: Why no shipping option for Italy. But OK for Spain

Have you enabled "International Tracked & Signed" in the Royal Mail module? Spain is in "International Tracked" and "International Signed", whereas Italy "International Tracked & Signed". I think they should both show in "International Standard".

Jump to post
  • Wed Jan 09, 2019 5:38 am
  • Replies 3
  • Views 267
Re: SMTP Reply To Email OC 2.3x

That should work. However you could try adding. $mail->setReplyTo($this->request->post['email']); And possibly changing the from to to use your store email if just adding the reply-to doesn't help. $mail->setFrom($this->config->get('config_email')); Other than that is to contact Google support to fi...

Jump to post
  • Wed Jan 09, 2019 3:22 am
  • Replies 6
  • Views 312
Re: mysqli > getaddrinfo failed

I agree that the defaults should be off. Not only for security, but also as you see many posts on the forum where the error, such as with ajax responses, are cause by PHP warnings and messages that don't matter that much. You'll have to convince the OpenCart developers. It's been reported several ti...

Jump to post
  • Wed Jan 09, 2019 12:52 am
  • Replies 9
  • Views 521
Re: mysqli > getaddrinfo failed

While I agree that credentials should be avoided being output in error messages. Just making a change to the database drivers won't stop all the other possible places where critical (security, personal, etc.) data may be leaked in error messages or to error logs. Educating store owners how to config...

Jump to post
  • Tue Jan 08, 2019 10:46 pm
  • Replies 9
  • Views 521
Re: mysqli > getaddrinfo failed

If you configure the error display correctly for a production site, there is no problem. The error display is only meant for debugging use when setting up. Once the site is set up and live, all error displaying should be switch off. To switch off. 1. Switch off Display Errors under the Error Handlin...

Jump to post
  • Tue Jan 08, 2019 10:25 pm
  • Replies 9
  • Views 521
Re: Order Status (history) not updating

Do you see any error messages in your web browser's error console?

Jump to post
  • Tue Jan 08, 2019 12:46 am
  • Replies 3
  • Views 133
Re: 3.0.3.x Issues and Bugs

From the comments on https://github.com/opencart/opencart/issues/7130 It seems that 3.0.3.x will still have most of the bugs that 3.0.2.0 had. Although there are some worthwhile fixes included.

Jump to post
  • Mon Jan 07, 2019 11:04 pm
  • Replies 60
  • Views 5911
Re: Urgent! problem with php code

Try looking or asking in the forum post for that extension. viewtopic.php?f=119&t=104532

At a guess it will be something like.

Code: Select all

if ($this->getSubTotalWithTax() > 291.50)
{
$cost = 0;
}
else
{
$cost = 3;
}

Jump to post
  • Mon Jan 07, 2019 5:07 am
  • Replies 10
  • Views 584
Re: PayPal Payments Standard returns error "Things don't appear to be working at the moment..."

Do you mean a subfolder, not subdomain? If it's a sub folder. You need to change both HTTP_SERVER and HTTPS_SERVER to use https:// and in your admin/config.php. You will also need to change any link from your main site to your store to use https. It would also be best to use the same version of your...

Jump to post
  • Mon Jan 07, 2019 3:25 am
  • Replies 8
  • Views 424
Re: Urgent! problem with php code

If you are modifying a custom extension there is not much anyone can suggest as they will not know how the custom extension works. You could try asking a developer of the author of the extension to make the changes for you.

Jump to post
  • Mon Jan 07, 2019 3:12 am
  • Replies 10
  • Views 584
Re: Urgent! problem with php code

Where are you trying to make this change? It's not clear what exactly you are trying to do?

Jump to post
  • Sun Jan 06, 2019 7:05 am
  • Replies 10
  • Views 584
Re: SMTP Reply To Email OC 2.3x

The issue seems to be with Gmail ignoring the reply-to field. Someone else reported this in the forum not long ago. What are your $mail->setTo, $mail->setFrom and $mail->setReplyTo set to in catalog/controller/information/contact.php? https://github.com/opencart/opencart/blob/2.3.0.2/upload/catalog/...

Jump to post
  • Sun Jan 06, 2019 6:59 am
  • Replies 6
  • Views 312
Re: Opencart 2 not sending shipping address to paypal standard

no_note will not make any difference. no_shipping defaults to 0 anyway. You could try adding it or setting it to 2, but I'm not sure it will help with your issue.

Jump to post
  • Sun Jan 06, 2019 3:40 am
  • Replies 32
  • Views 20820
Re: PayPal Payments Standard returns error "Things don't appear to be working at the moment..."

There seems to be a problem with site not being set correctly to use HTTPS. I would fix that first, as it may be the cause of the PayPal problems.

What are HTTP_SERVER and HTTPS_SERVER set to in your config.php and admin/config.php?

Jump to post
  • Sat Jan 05, 2019 3:59 am
  • Replies 8
  • Views 424
Re: UTF-8 error on Admin login OC2.3.0.2

It's in the php.ini and admin/php.ini files. You need remove the semicolon from the end of each line. So default_charset = UTF-8; To default_charset = UTF-8 Once you have done that you may need to make the change elsewhere in your hosting. You may have a MultiPHP INI Editor in your control panel. Wh...

Jump to post
  • Fri Jan 04, 2019 11:25 pm
  • Replies 3
  • Views 345

Search found 891 matches