Search found 185 matches

Search found 185 matches

Re: What's wrong with my code?

In the catalog/controller/product.php, catalog/language/product.php/english and /french and in catalog/view/theme/mytheme/template/product.tpl I added the code as shown below. controller.php $this->data['text_fill_the_form'] = $this->language->get('text_fill_the_form'); Have you added this in all t...

Jump to post
  • Thu Sep 26, 2013 3:56 pm
  • Replies 8
  • Views 976
Re: Does upgrading override layout and CSS?

The latest release of any web project (especially OpenCart :) ) isn't something you should jump into lightly. It will overwrite the CSS and templates, and once your site is up and running, you should only upgrade for security fixes and *required* new features. Changes you make to the layout in the a...

Jump to post
  • Thu Aug 29, 2013 5:28 pm
  • Replies 2
  • Views 419
Re: Call to a member error only showing on certain browsers

Does it definitely work on the Mac - could you be looking at Firefox's cached page? ...and are you working with a custom template or the default? Seeing a PHP error in one browser but not another usually suggests that some $_GET or $_POST value from the browser isn't being sent correctly - which pro...

Jump to post
  • Thu Aug 29, 2013 4:50 am
  • Replies 2
  • Views 596
Re: enter button on search

ianhaney wrote:...also using the template Azure
This is the most likely suspect. Maybe it's something you can take up with the theme developer. If not, you could try this:

http://stackoverflow.com/questions/6990 ... ith-jquery

Jump to post
  • Thu Aug 29, 2013 3:40 am
  • Replies 4
  • Views 605
Re: Problems Installing - SQL Database Error

Assuming you're looking at the address you uploaded the file to, you're doing the right thing. It may be being affected by a htaccess file (although that seems unlikely given that you've only just started)? Try putting test.php in its own folder at the same level or above the opencart folder. Is the...

Jump to post
  • Thu Aug 29, 2013 12:20 am
  • Replies 8
  • Views 2086
Re: Problems Installing - SQL Database Error

Copy and paste this into notepad: <?php $mysqli_connection = new MySQLi('localhost', 'user', 'pass', 'db'); if ($mysqli_connection->connect_error) { echo "Not connected, error: " . $mysqli_connection->connect_error; } else { echo "Connected."; } Edit it to replace the parameters for the connection w...

Jump to post
  • Wed Aug 28, 2013 11:49 pm
  • Replies 8
  • Views 2086
Re: How do I get my website off Hosting??

Another golden rule would be never to hire a server/server space from a one-man band. Even with the best will in the world, it's not going to compete with a place that has dedicated support staff and plenty of hosting experience. E.g. this shouldn't be the fourth hit on Google for 'Destrove': https:...

Jump to post
  • Wed Aug 28, 2013 11:36 pm
  • Replies 6
  • Views 757
Re: enter button on search

On my virginal test install of 1.5.5.1, pressing enter does submit the search form in the header. The code in common.js is specifically looking for the 13 keyCode. What browser are you using, and have you made any modifications to your store that could have affected the search form? E.g. a template ...

Jump to post
  • Wed Aug 28, 2013 11:02 pm
  • Replies 4
  • Views 605
Re: Update JQuery Not Working

Is it copying and pasting that's removed the 'http:' from the beginning of those links, or is it actually missing? Also, you're probably better off hosting javascript locally - if JQuery introduce a big change (which they're wont to do fairly frequently), you may not even know it's happening until y...

Jump to post
  • Wed Aug 28, 2013 10:43 pm
  • Replies 3
  • Views 2843
Re: Notices after upgrade to v1.5.6

There are a number of issues with 1.5.6.

Is there are a reason for not just restoring your backup and returning to 1.5.5.1, e.g. a specific feature that you need in 1.5.6?

Jump to post
  • Wed Aug 28, 2013 8:00 pm
  • Replies 9
  • Views 1302
Re: Have I been Hacked? Or is it a bug...

Based on a Google search, are you running something called "HubSpot"?

Jump to post
  • Wed Aug 28, 2013 7:11 pm
  • Replies 5
  • Views 956
Re: cache problem after updating css file

You could try this trick: http://forum.opencart.com/viewtopic.php?f=10&t=85807 ..or rename the css file and update the header template whenever you change the css. Another alternative is to use a php file that includes a css file instead of a real css file - but normally that technique is better if ...

Jump to post
  • Wed Aug 28, 2013 6:18 pm
  • Replies 9
  • Views 4833
Re: how and where does the 'latest' module query for the ite

It is a bit confusing at first glance. If you look at around line 23 of "catalog/controller/module/latest.php", it's calling 'getProducts' in "catalog/model/catalog/product.php" with the $data array that it created around line 16 as a parameter. getProducts builds/runs the SQL query and returns the ...

Jump to post
  • Tue Aug 27, 2013 5:56 pm
  • Replies 5
  • Views 1396
Re: With and Without www problem

No reason why it shouldn't, it only affects the main part of the address.

...but you really should read the article instead of copying and pasting something that I copied and pasted from Google - then you can copy and paste from that with confidence :)

Jump to post
  • Wed Aug 21, 2013 4:57 pm
  • Replies 5
  • Views 1615
Re: With and Without www problem

This will explain the issue, and tell you what to put in your htaccess file: http://www.thesitewizard.com/apache/redirect-domain-www-subdomain.shtml You'll need something like one of the following: (These are *completely untested* examples,they are just to give you an idea of what to look for.) Redi...

Jump to post
  • Wed Aug 21, 2013 4:30 pm
  • Replies 5
  • Views 1615
Re: SAGEPAY not notifying system of payment

Stick with Sagepay Form - unless your client needs to process repeat transactions, it should be fine for your needs. I won't be online for a day or two, but I'm sure someone else will help out. It sounds like you should be able to get everything working by double-checking all the options in OpenCart...

Jump to post
  • Wed Aug 21, 2013 12:29 am
  • Replies 5
  • Views 952
Re: SAGEPAY not notifying system of payment

On the options page for Sagepay in your admin panel, choose an order status that is something other than 'Pending', run it through the simulator and see what happens. If the order is successful, the order status should be changed to the one you've chosen. If it isn't then it will remain as the defau...

Jump to post
  • Tue Aug 20, 2013 10:55 pm
  • Replies 5
  • Views 952
Re: SAGEPAY not notifying system of payment

Are you using Sagepay Form? That's the one that's included with OpenCart and works fine on a store I set up for someone (pretty much out of the box, think I just had to add logging). Have you set up a state for orders to be changed to and set its ID as the value for sagepay_order_status_id? Have you...

Jump to post
  • Tue Aug 20, 2013 10:18 pm
  • Replies 5
  • Views 952
Re: FREE responsive theme needing some testing!

Only had a quick go on the demo so far, but it's looking great - nice work! :)

Jump to post
  • Fri Aug 09, 2013 4:30 pm
  • Replies 32
  • Views 25898

Search found 185 matches