Search found 46 matches

Search found 46 matches

bhy

Re: [SOLVED]: How to pull through product attributes for manipulation in category.twig ?

Just FYI, it's probably obvious but I had some trouble with it. If you are doing this for product.twig (and thus don't need to modify the controller, as the attributes are already available to the product page), use just "attribute_groups" instead of "product.attribute_groups" in the first for loop.

Jump to post
  • Wed Oct 09, 2019 8:10 pm
  • Replies 4
  • Views 1250

bhy

Re: Display image on product page if the name of an attribute starts with a string

Eureka! I looked to the part of product.twig that generates the specifications table next to the product description. If it works there, I must be able to reproduce it. So, the error was in the first loop. Instead of "product.attribute_groups" it should be just "attribute_groups". Probably because t...

Jump to post
  • Wed Oct 09, 2019 8:01 pm
  • Replies 6
  • Views 359

bhy

Re: Display image on product page if the name of an attribute starts with a string

paulfeakins wrote:
Tue Oct 08, 2019 10:20 pm
So when you output "attribute.name" what do you get?
Strangely enough, <li>{{ attribute.name }}</li> doesn't output anything (or to be more precise, it outputs <li> </li>) and neither does attribute_name or just attribute.

Jump to post
  • Wed Oct 09, 2019 7:28 pm
  • Replies 6
  • Views 359

bhy

Re: Display image on product page if the name of an attribute starts with a string

paulfeakins wrote:
Tue Oct 08, 2019 5:11 pm
I'm guessing the problem is this character "Č".

Try again using just "C" and that will confirm or deny this theory, then you can see what to do about it.
Thank you. I changed the specification to CZE (and also tried changing the "starts with" to just 'C') and unfortunately the problem persists.

Jump to post
  • Tue Oct 08, 2019 8:09 pm
  • Replies 6
  • Views 359

bhy

[SOLVED] Display image on product page if the name of an attribute starts with a string

Hello, I'm trying to display a flag of a country on product page on the condition that the name of an attribute starts with the name of that country. Based on https://forum.opencart.com/viewtopic.php?t=200460 I added the following to my product.twig to the column which has manufacturer, price etc.: ...

Jump to post
  • Mon Oct 07, 2019 8:27 pm
  • Replies 6
  • Views 359

bhy

Re: Can't see installed extenstions in OC 3.0.2.0

Turns out it was a problem with the extensions after all, and not a problem of OpenCart. One of the extensions has the installer zip which contains folder admin/ etc. directly and not in an upload/ folder. I changed the installer zip so that the folders admin/ etc. are in the upload/ folder and it w...

Jump to post
  • Mon Sep 23, 2019 8:49 pm
  • Replies 5
  • Views 817

bhy

Re: Can't see installed extenstions in OC 3.0.2.0

Changing the permissions of ../storage_biovina/ to 777 didn't help either, I'm out of ideas..

Jump to post
  • Fri Sep 20, 2019 9:22 pm
  • Replies 5
  • Views 817

bhy

Re: Can't see installed extenstions in OC 3.0.2.0

I found out that the ../storage_biovina/ directory which I use for this installation of OC had owner set to root:root (even though all the subdirectories were apache:apache), I changed it to apache:apache but it didn't help. The absence of any error message is very frustrating.

Jump to post
  • Fri Sep 20, 2019 9:14 pm
  • Replies 5
  • Views 817

bhy

Can't see installed extenstions in OC 3.0.2.0

Hello, I have OC 3.0.2.0 with the default theme. I can install ocmod extensions, there is no error message, the extension installer says they are installed successfully and I can see them installed under the extension installer. However, they don't appear in the respective areas of the administratio...

Jump to post
  • Thu Sep 19, 2019 8:06 pm
  • Replies 5
  • Views 817

bhy

Re: 2.3.0.2. - Google Base feed contains only 35 out of 133 products

It was really the reason, or at least one of them. We have some more issues with our products (Violation of Shopping ads policy) which we are now working out with google.

Jump to post
  • Thu Sep 19, 2019 6:48 pm
  • Replies 3
  • Views 1306

bhy

Re: Can OpenCart's caching system affect a WordPress install in a subdirectory?

So, after spending more than a week learning Apache stuff I never knew about before, it turned out that no caching was involved and in fact there was an error in the configuration of one of the WordPress plugins, which was causing the error that everyone suspected to be caused by caching. Weird stuff.

Jump to post
  • Thu Sep 05, 2019 9:13 pm
  • Replies 7
  • Views 456

bhy

Re: Can OpenCart's caching system affect a WordPress install in a subdirectory?

Thank you. The response headers for www.bio-krasa.cz (OpenCart): Pragma: no-cache Cache-Control: no-store, no-cache, must-revalidate Date: Mon, 02 Sep 2019 13:25:19 GMT Expires: Thu, 19 Nov 1981 08:52:00 GMT Set-Cookie: PHPSESSID=nqn75q2bf2kg8o3kb5jneml6hq; path=/; HttpOnly,default=6aevv7vpr77sjqsai...

Jump to post
  • Mon Sep 02, 2019 9:38 pm
  • Replies 7
  • Views 456

bhy

Re: Can OpenCart's caching system affect a WordPress install in a subdirectory?

Are you sure there is no .htaccess which enables caching for the entire domain ? Yes, I just checked it again. WP is a heavily cached system by default. You actually need a plugin to DISABLE or at least to control caching in WP. That's interesting. I tried WP Super Cache, deleted the WP cache with ...

Jump to post
  • Thu Aug 29, 2019 8:23 pm
  • Replies 7
  • Views 456

bhy

Can OpenCart's caching system affect a WordPress install in a subdirectory?

Hello. I have OpenCart 2.3.0.2 installed in /var/www/bio-krasa.cz and WordPress installed in /var/www/bio-krasa.cz/funnel I have some issues in the WordPress installation, i.e. some changes I make in the WP administration don't appear on the front-end. People in the WordPress community told me that ...

Jump to post
  • Wed Aug 28, 2019 9:02 pm
  • Replies 7
  • Views 456

bhy

Re: 2.3.0.2. - Google Base feed generates prices without currency

Since I didn't find a more elegant solution, I just changed both occurrences of '</g:price>' to '.00 CZK </g:price>' in the aforementioned file. The feed is in correct format now. (Of course, the downside is that I can't use any other currencies in my shop, but in my case that's not a problem.)

Jump to post
  • Tue Aug 06, 2019 10:42 pm
  • Replies 1
  • Views 390

bhy

Re: 2.3.0.2. - Google Base feed contains only 35 out of 133 products

products in categories where you have set the google base category Thank you, this is very interesting indeed. I don't think I've seen this mentioned ever before. We have some products that are in "Category > Subcategory" while only "Category" is mapped to a Google category. This is probably the re...

Jump to post
  • Tue Aug 06, 2019 10:02 pm
  • Replies 3
  • Views 1306

bhy

2.3.0.2. - Google Base feed contains only 35 out of 133 products

Hello, we are running an eshop https://www.bio-krasa.cz which currently has 133 products. We are using the default Google Base product feed included with OC 2.3.0.2, the feed is here: https://www.bio-krasa.cz/index.php?route=extension/feed/google_base As you can see, it contains only 35 products. Wh...

Jump to post
  • Mon Jul 29, 2019 9:50 pm
  • Replies 3
  • Views 1306

bhy

2.3.0.2. - Google Base feed generates prices without currency

Hello, I am using the default Google Base product feed included with OC 2.3.0.2. The default currency (and the only one used) is CZK - Czech koruna. The feed only displays the price as a number without decimal places or the currency code (i.e. <g:price>659</g:price>). This is not accepted by Google....

Jump to post
  • Mon Jul 29, 2019 9:12 pm
  • Replies 1
  • Views 390

bhy

Re: OC 2.0.2.0 - change layout to be compatible with default theme after switching from a non-default theme

Ehh.. I just realized one important fact I totally forgot about. When we bought the template from Template Monster three years ago, there were some issues with the front-end. So instead of installing the template itself on vanilla OC 2.0.2.0, we downloaded a modified version of OC 2.0.2.0 from TM wi...

Jump to post
  • Sat Mar 31, 2018 9:29 pm
  • Replies 1
  • Views 164

bhy

OC 2.0.2.0 - change layout to be compatible with default theme after switching from a non-default theme

Hello everyone, I have a shop running OC 2.0.2.0 which was using a custom template from Template Monster. I switched back to the default theme. Of course, the layout of the front end is totally messed up now, because the layouts are optimized for the custom template I no longer use. I tried clearing...

Jump to post
  • Sat Mar 31, 2018 9:09 pm
  • Replies 1
  • Views 164

Search found 46 matches