Search found 30 matches

Search found 30 matches

Re: htaccess not redirecting properly in multistore

Yes, the technical service gave me a list for the credit card payment system to work properly: -It has to be accesible from the Internet -It must not ask for a user or a password -It has to get the parameters for Post -It must not redirect to other urls So the redirection is a problem. I ask them to...

Jump to post
  • Sat Jul 29, 2017 7:11 am
  • Replies 12
  • Views 2540
Re: htaccess not redirecting properly in multistore

New issues :( . The redirections are all ok, however If people pay using credit card the money is charged but I don't get the order in my email, neither does the customer, also the stock is not discounted. The technical support tell me that the confirmation has to go to an http and cannot use a redi...

Jump to post
  • Fri Jul 28, 2017 5:01 am
  • Replies 12
  • Views 2540
Re: htaccess not redirecting properly in multistore

[Update]

Now it works perfectly! I added this line:

RewriteCond %{ENV:HTTP} !on [NC]

However I see that my website is so customized that a lot of modules are not working in the domain2 version, I'll have to consider if the effort is worthwhile.

Thanks a lot!

Jump to post
  • Wed Jul 26, 2017 5:37 pm
  • Replies 12
  • Views 2540
Re: htaccess not redirecting properly in multistore

Both stores are in the same folder, I have 2 different domains pointing to that folder. I have updated the htaccess with this new config: When I use https://www.domain2.com I get a Secure Connection Failed error. But I guess no one will type https in the url bar. When I use http://www.domain2.com I ...

Jump to post
  • Wed Jul 26, 2017 4:20 pm
  • Replies 12
  • Views 2540
Re: htaccess not redirecting properly in multistore

Doesn't seem to work :( . Domain1 is ok, non www redirects to www and http redirects to https which is fine. Domain2 redirects to domain1. I don't have http s in Domain2, I want it to go to plain http. Do you see something wrong in this code? # SEO URL Settings RewriteEngine On # If your opencart in...

Jump to post
  • Wed Jul 26, 2017 6:05 am
  • Replies 12
  • Views 2540
Re: htaccess not redirecting properly in multistore

Thanks for your reply. Almost there!

The current domain, using https, has not suffered any change, which is good. But the new domain, which is http redirects to an https, so the browser shows an Secure Connection Failed error.

I need the new domain to go to the http version to work. Any suggestion?

Jump to post
  • Wed Jul 26, 2017 3:39 am
  • Replies 12
  • Views 2540
htaccess not redirecting properly in multistore

Hi, I have just added a store to my Opencart store but the new domain always redirect to the current store. Newdomain.com redirects always to CurrentDomain.com, unless I disable htaccess. My htaccess is a bit complicated and I have no idea what should I change to solve it, every idea will be welcome...

Jump to post
  • Wed Jul 26, 2017 1:33 am
  • Replies 12
  • Views 2540
How to offer free shipping only when Paypal reaches X amount

Hallo, I have cash on delivery and Paypal payments in my website. I want to offer free shipping when the order is paid by Paypal and reaches 50$, but keeping free shipping for COD at 70$. After searching the extensions list I couldn't find anything like this. Any idea of a workaround or a way to imp...

Jump to post
  • Thu Jun 25, 2015 8:01 pm
  • Replies 2
  • Views 171
Re: remove downloads link from "my orders"

Having the same problem. Any solution for this?

Jump to post
  • Sat Jan 03, 2015 10:25 pm
  • Replies 4
  • Views 1188
Cambiar traducciones en el panel de control del cliente

He buscado por todas partes pero no consigo encontrar dónde cambiar las traducciones del Panel de Control del cliente registrado.

Es el sitio donde aparece "Mi cuenta", "Mis pedidos", etc.

Gracias.

Jump to post
  • Sat Jan 03, 2015 10:22 pm
  • Replies 3
  • Views 375
Re: Auto language detection fix

At the end I bought an extension that autoswitch language and currency based on IP. The bad thing is that my website has Spanish as default language, and I set OC to change to English and USD for United States, and it works fine, the big problem is that Google is only showing results in English, eve...

Jump to post
  • Wed Aug 27, 2014 6:21 pm
  • Replies 6
  • Views 2189
Re: Url in the wrong language shown by google

Thank you Earnie, I really appreciate your answer and your observations. What I have discovered is that when I search my website in Google, the results show English title and Spanish description or Spanish title and English description. See the image attached, I cannot imagine what can be wrong! The...

Jump to post
  • Wed Jun 25, 2014 4:43 am
  • Replies 3
  • Views 609
Re: Url in the wrong language shown by google

One of my dreams is that someday someone will answer one of my questions in this forum. :joker:

Jump to post
  • Wed Jun 18, 2014 7:28 am
  • Replies 3
  • Views 609
Url in the wrong language shown by google

Hi, I have a multilingual site Spanish / English. If I search my own site in google I get the results in English, even if I'm looking in the Spanish Google version "google.es" and the browser is in Spanish. The other 9 results in the first page are a mixture of Spanish and English pages. If I click ...

Jump to post
  • Thu Jun 12, 2014 2:04 am
  • Replies 3
  • Views 609
Re: CluodFlare Code to Opencart

I had to put it into index.php Right after //Version if ($_SERVER["HTTP_CF_CONNECTING_IP"]) { $_SERVER["REMOTE_ADDR"] = $_SERVER["HTTP_CF_CONNECTING_IP"]; } And then it works. You can check it in Reports/Clients/Clients Online If you click on the IP number you can see the procedence of the IP number...

Jump to post
  • Mon Jun 02, 2014 5:53 am
  • Replies 3
  • Views 514
Can't see content of extensions in the backoffice

Hallo, I cannot see the content or settings of the backoffice in the extensions, under Extensions > Modules Everything looks right in the frontend but I cannot change things as I cannot see them in the backoffice. E.g In the picture below I should see a whole list of options. Where should I look for...

Jump to post
  • Sun May 18, 2014 5:02 am
  • Replies 0
  • Views 129
Re: Auto language detection fix

It doesn't seem to be working for me on 1.5.6 I have just added the code but the language stays in Spanish even if the browser is set only in English. I can switch manually to English and it works fine. What could be wrong? // Language Detection $languages = array(); $query = $db->query("SELECT * FR...

Jump to post
  • Wed May 14, 2014 5:06 am
  • Replies 6
  • Views 2189
Re: Módulo de pagos ING multimoneda basado en TPV ZhenIT

Veo que en la carpeta que indicas tengo el módulo redsys.tpl con el siguiente código. Me funcionaría si agrego el código que propones? Tengo la plataforma de ING y veo que da error cuando la gente quiere pagar en otra moneda. <form action="<?php echo $action; ?>" method="post" id="payment"> <input t...

Jump to post
  • Mon May 05, 2014 5:37 pm
  • Replies 5
  • Views 995
Re: programa de afiliados, 3 pregustas mejora y funcionamien

Me respondo a mí mismo por si a alguien más le sirve: - Sí, si un cliente se hace afiliado y genera sus propios links los puede usar para obtener descuentos en sus propias compras. - Sí, el cliente puede entrar por un link generado en el producto A, pero si luego compra el producto B el sistema reco...

Jump to post
  • Mon May 05, 2014 5:21 pm
  • Replies 2
  • Views 823
How to set the languages to show in different countries

I have a multilingual site, Spanish being the main language and English the second one. I want all Latin America, Spain and Portugal to get the site in Spanish. I want the rest of the world to get the website in English. So far I know that people in USA and UK are seeing the site in English, but all...

Jump to post
  • Wed Apr 30, 2014 8:07 am
  • Replies 0
  • Views 186

Search found 30 matches