Search found 42 matches

Search found 42 matches

Re: Coupon code to apply to sub-total before tax is applied

Just for reference, Super Coupons can do this, since it bases its calculation on the sub-total without tax by default. However, I think there's an easy edit to get the built-in coupon system to do this, since you just have to skip it applying discounts to tax. Try this edit and see if it works: IN:...

Jump to post
  • Mon May 20, 2019 7:57 pm
  • Replies 5
  • Views 264
Re: Coupon code to apply to sub-total before tax is applied

Thanks for the reply.
My problem is slightly different. The coupon amount is correct but the VAT is calculated on the total before the coupon, so the total is incorrect - see attachment.

Jump to post
  • Mon May 20, 2019 5:58 pm
  • Replies 5
  • Views 264
Coupon code to apply to sub-total before tax is applied

Version 1.5.6.1 Currently our store shows (for example) a 10% coupon code which is deducted correctly from the goods total; but subsequently after that the VAT is valued from the goods total also, not from the goods total minus the coupon discount, which is what we want. I have changed 'sort order' ...

Jump to post
  • Fri May 17, 2019 11:08 pm
  • Replies 5
  • Views 264
Re: [RELEASED] CSRF Protection Form

Opencart 3.0.2.0.
I have uploaded the files but cannot install as the extension as it is not showing under extensions. I have tried everything I can think of but no success. Can you shed any light as to why this might be?

Jump to post
  • Tue May 14, 2019 4:20 pm
  • Replies 198
  • Views 28228
Re: Registration Spam

Apologies.

Its the 'CSRF Protection Form (VQMod)'
https://www.opencart.com/index.php?rout ... on_id=4773

Jump to post
  • Mon May 13, 2019 8:32 pm
  • Replies 24
  • Views 5108
Re: Registration Spam

Installed extension on 3.0.2.0.
I cannot see the extension in the admin - I am clearly doing something basic wrong but cannot see what it is! Any ideas?
thanks!

Jump to post
  • Mon May 13, 2019 6:04 pm
  • Replies 24
  • Views 5108
Re: Registration Spam

Just to double check please. For v 3.0.2.0 is it just a case of uploading these extension files or are there additional settings that need taken care of?

Jump to post
  • Fri May 10, 2019 4:46 pm
  • Replies 24
  • Views 5108
Re: Show attribute on product page

Does anyone know specific code that would work to bring attributes into Category page though? They do not show by default and there custom code needed.

Jump to post
  • Thu Jan 24, 2019 9:34 pm
  • Replies 3
  • Views 278
Show attribute on category page

Hi
Is there a way to bring in a single attribute to show on a category page?
e.g. to show under the product name for example?
Thanks

Jump to post
  • Fri Jan 18, 2019 10:55 pm
  • Replies 3
  • Views 278
Single Product Redirect for Category and Search

version 3.0.2.0.

For previous versions of Opencart we found extensions or a code snippet to redirect a category or search to a single product result, should a category or search result only contain one product.
Does anyone know of a way to do this in Opencart 3.0.2.0. ?

Thanks

Jump to post
  • Tue Jun 05, 2018 6:59 pm
  • Replies 2
  • Views 162
Re: Modification warning message

v 3.0.2.0. I am receiving errors like the following with several Export/Import extensions: Warning: htmlentities(): charset `UTF-8;' not supported, assuming utf-8 in /home/*********/public_html/admin/controller/marketplace/modification.php on line 756 I have read other threads in the forum but do no...

Jump to post
  • Thu Apr 26, 2018 12:55 am
  • Replies 2
  • Views 791
Re: Customer Custom Fields not available in admin & not saving

OK thanks for your help.
Should I try again or do I need to try and get to bottom of why this has happened?

Jump to post
  • Mon Apr 16, 2018 11:42 pm
  • Replies 40
  • Views 1798
Re: Customer Custom Fields not available in admin & not saving

No its not showing on there. I assume it should be?

I did a search for 'vat' (as this was part of the field name) in the database - it shows in custom_field_description but not in custom_field
http://test.bigdecision.co.uk/v1.jpg
Is this expected behaviour?

Jump to post
  • Mon Apr 16, 2018 9:16 pm
  • Replies 40
  • Views 1798
Re: Customer Custom Fields not available in admin & not saving

Sure.
Where would I get more details about the error?

line 445
if ($custom_field_customer_group['required']) {

Jump to post
  • Mon Apr 16, 2018 7:33 pm
  • Replies 40
  • Views 1798
Re: Customer Custom Fields not available in admin & not saving

Not sure if this helps but when I added regex I got error:
Notice: Undefined index: required in /home/********/public_html/admin/controller/customer/custom_field.php on line 445

(value still not saving)

Jump to post
  • Mon Apr 16, 2018 7:20 pm
  • Replies 40
  • Views 1798
Re: Customer Custom Fields not available in admin & not saving

Yes - am testing as a registered customer.
No regex was added to the new field.

Jump to post
  • Mon Apr 16, 2018 6:52 pm
  • Replies 40
  • Views 1798
Re: Customer Custom Fields not available in admin & not saving

Thanks.
No unfortunately still not working.
I get directed to the "Success: Your account has been successfully updated." However value is not retained when I go back into 'Edit Account' and the field does not show at all in the admin.

Jump to post
  • Mon Apr 16, 2018 5:56 pm
  • Replies 40
  • Views 1798

Search found 42 matches