Search found 6 matches

Page 1 of 1

Search found 6 matches

Re: Opencart 2.3.0.2 random api error in admin panel

you will find it in the link you referred to.

Jump to post
  • Tue Feb 18, 2020 6:54 pm
  • Replies 20
  • Views 2323
Re: Opencart 2.3.0.2 random api error in admin panel

It says "There are a few errors in the code posted. " ... and I am a novice so I don´t know how to writ the code.

Jump to post
  • Mon Feb 17, 2020 5:44 pm
  • Replies 20
  • Views 2323
Re: Opencart 2.3.0.2 random api error in admin panel

Updated the "encryption.php" file with the code from "xxvirusxx ", but no effect. Still can´t use Chrome only IExplorer (with random API messages).

Jump to post
  • Tue Feb 11, 2020 8:38 pm
  • Replies 20
  • Views 2323
Re: Opencart 2.3.0.2 random api error in admin panel

Followed advice: Replaced this line: Code: Select all return strtr(base64_encode(mcrypt_encrypt(MCRYPT_RIJNDAEL_256, hash('sha256', $this->key, true), $value, MCRYPT_MODE_ECB)), '+/=', '-_,'); With this line: Code: Select all return base64_encode(openssl_encrypt($value, 'AES-256-CBC', hash('sha256',...

Jump to post
  • Fri Jan 24, 2020 4:16 pm
  • Replies 20
  • Views 2323
Re: Opencart 2.3.0.2 random api error in admin panel

Have the same problem - it has worked fine until appr. 1 month ago when the server host upgraded from php 7.1 to 7.2 (maybe they have done something else as well...). I have to refresh the module changer several times to get it to work (update the order and API message gone) . This will only work wi...

Jump to post
  • Mon Jan 20, 2020 6:10 pm
  • Replies 20
  • Views 2323

Page 1 of 1

Search found 6 matches