Search found 34 matches

Search found 34 matches

Re: Frequent OCMOD Changes

OSWorX wrote:Events are currently not useable?
Well isn't that wonderful! Events aren't working and OCmod only works to a limited extent! Sounds like v2 isn't really ready for production use yet.

Jump to post
  • Tue Jan 12, 2016 4:39 am
  • Replies 9
  • Views 1135
Re: Frequent OCMOD Changes

About the Opencart events: The big changes for these are actually about to be introduced in 2.1.0.2_rc or later. Does this mean the events are not working now? I am trying to code an event for Version 2.1.0.1. Trigger = admin/controller/catalog/product/getForm/before. Action = module/mymod/my_metho...

Jump to post
  • Sun Jan 10, 2016 8:49 am
  • Replies 9
  • Views 1135
Re: vQmod To OCMod Conversion Thread

They're only in the database. Nothing with ocMod can be easy. WTF? Is this still true? I'm just now getting around to updating my mods to v2 and was doing a little research on the new structure. I came across this thread and now I'm wondering if I should even bother! I can't tell you how many times...

Jump to post
  • Sat Jan 09, 2016 12:20 pm
  • Replies 58
  • Views 31445
Re: Calling a Second Controller With Functions

Thank you for the clarification on the two versions. That is very helpful. Currently I am working on 1.6 so I would think $this->children = array('dir/file/method'); is probably my best bet, but since its a private function I'm running into errors. Do I have to make this a public function in order t...

Jump to post
  • Fri Apr 24, 2015 1:51 am
  • Replies 3
  • Views 4440
Calling a Second Controller With Functions

I need to add several private functions to the a few admin controller files. Rather than add a bunch of duplicate code with VQmod I was hoping to a link to "module/common_functions.php" vqmod and the access the functions that way, but I'm not sure how to do that. I tried: $this->getChild('controller...

Jump to post
  • Thu Apr 23, 2015 10:29 pm
  • Replies 3
  • Views 4440
Re: Admin VQmod Not Working after migration

install the Swedish language to fix these error... I have never had these installed before. However Since the XML of that mod is actually set to skip on those errors I do not think this would be the issue. This isn't a language issue. And vQmod is working. Unless you have an extension affecting the...

Jump to post
  • Tue Jan 27, 2015 8:56 pm
  • Replies 13
  • Views 1818
Re: Admin VQmod Not Working after migration

Thank you for taking the time to help me with this. The error from the VQmod log folder is below. ---------- Date: 2015-01-26 09:45:27 ~ IP : 184.166.217.217 ---------- REQUEST URI : /admin/index.php?route=sale/order&token=eaa4bf7525d0a696cebcabc29bc2979c MOD DETAILS: modFile : /mnt/stor14-wc1-ord1/...

Jump to post
  • Tue Jan 27, 2015 1:21 am
  • Replies 13
  • Views 1818
Re: Admin VQmod Not Working after migration

-clean vqmod cache - Done. Only Catalog files come back. -clean oc cache - Not sure how to do this. -chmod on vqmod folder - 755 -try to install it again - Tried says already installed -check error log for errors... -This is the strange part. I have one error and it has the requesting URI as admin/i...

Jump to post
  • Tue Jan 27, 2015 1:08 am
  • Replies 13
  • Views 1818
Admin VQmod Not Working after migration

I have recently moved my site from a VPS to rackspaces cloudsites. Everything seems to be working fine except the admin VQmod is no longer functioning. I understand this could be an issue with the mods.cache file however it appears to have the proper path to my admin folder in there so I am kind of ...

Jump to post
  • Tue Jan 27, 2015 12:45 am
  • Replies 13
  • Views 1818
Create Tables & Settings Issue with Similar Named Mods

I have a mod that I am completely redesigning. Since the database structure will also change in this version I have decided to build it as a completely separate mod. However I am running into some very strange errors. I'm hoping someone can shed some light onto why this would be happening. Original ...

Jump to post
  • Sat Sep 13, 2014 11:29 pm
  • Replies 0
  • Views 202
Re: Storing extension settings/config

How does "$this->config->get('my_extension_key')" avoid getting a setting from another extension that has the same key name?

Jump to post
  • Thu Aug 21, 2014 10:24 am
  • Replies 7
  • Views 7110
Re: Multiple Item Discount

I also need an answer to this question. For me different options = 2 different products and volume discount should not be applied. Why did this change? Is there a way to change it back that anyone has found?

Jump to post
  • Fri Jul 11, 2014 2:09 am
  • Replies 13
  • Views 7791
Re: [solved]I need a developer to fix an issue with edit ord

Not sure if it can still help you, but I have built an order edit VQmod that you can see here: http://goo.gl/r7IQwD.

Jump to post
  • Thu Mar 27, 2014 12:15 am
  • Replies 3
  • Views 702
Admin Order Edit Works With Qphoria's Option Boost

I just finished a new vqmod that will allow admin's to edit order product options and change qty, it will also allow you to change the shipping charge/method add custom shipping charges as well as order fees or discounts. Works with Qphoria's Option Boost and all currencies. A must for sore owners t...

Jump to post
  • Sun Mar 23, 2014 1:52 am
  • Replies 1
  • Views 432
Re: New order edit system in 1.5.2

This mod will allow you to edit orders, products, product options, shipping charges, custom shipping methods, add extra order fees and/or discounts you can buy it pretty cheap here http://goo.gl/r7IQwD

Jump to post
  • Sun Mar 23, 2014 1:44 am
  • Replies 27
  • Views 7494
Re: Cannot edit order in admin panel OC 1.5.5.1

Need a way for administrators to edit orders, products, product options, shipping charges, custom shipping methods, add extra order fees and/or discounts. Please check it out here: http://goo.gl/r7IQwD ... Works Great with Qphoria's Options Boost.

Jump to post
  • Sun Mar 23, 2014 1:39 am
  • Replies 42
  • Views 23551
Re: Edit Order

Just finished my new mod. Allows admin to edit orders, products, product options, shipping charges, custom shipping methods, add extra order fees and/or discounts. Please check it out here: http://goo.gl/r7IQwD

Jump to post
  • Sun Mar 23, 2014 1:37 am
  • Replies 11
  • Views 6012
Re: Orders not showing up

This is actually a very easy fix. All you need to do is goto your settings of your OpenCart Authorize.net mod and enter a MD5 Hash. Copy that go to authorize.net account click on settings next to where you find get API transaction key there is a link to update MD5 Hash. Click on that; paste the MD5 ...

Jump to post
  • Sat Mar 22, 2014 12:50 am
  • Replies 64
  • Views 22886

Search found 34 matches