Search found 9 matches

Page 1 of 1

Search found 9 matches

Re: Settings not persistent?

Thanks all, that solved it. I found a site that explains the procedure properly (albeit for modules, not reports) and took it from there. It appeared that my controller was missing the install-function (?!). And thus when activating, uninstalling and not installing. Weird because it's a copy of an e...

Jump to post
  • Thu Jun 18, 2020 4:46 am
  • Replies 3
  • Views 223
[SOLVED] - Settings not persistent?

Lectori Salutem, I've created a custom report (a copy of the product_purchased) and everything is working fine. It's showing up in the report drop down list, I can give access to it to other users and the report is reporting like it's supposed to... until..... I change something in the settings (und...

Jump to post
  • Mon Jun 15, 2020 3:18 am
  • Replies 3
  • Views 223
Re: Custom report not showing in drop down list

How stupid of me. Indeed it's there. And now it works! Found it in the docs eventually (installing a mod) just didn't realize it had to be 'installed' since it also shows up automatically in the permissions folder. The docs refer a lot to version 2 (with .tpl's etc) and the links to the DIY mod buil...

Jump to post
  • Sun Jun 14, 2020 6:41 pm
  • Replies 5
  • Views 232
Re: Custom report not showing in drop down list

Eeehhhh...... I guess not :-\
How do I do that? I just copied files. I've tried to find documentation on how to create custom reports but it's very scarce.

Jump to post
  • Sun Jun 14, 2020 5:31 pm
  • Replies 5
  • Views 232
[SOLVED] Custom report not showing in drop down list

Lectori Salutem, I've made a custom report, a modified copy of Products Purchased, (controller) and changed the query (model), gave it a new title header (language) and layout (view). All looks well and the report shows up in the permissions under System/Users/User Groups so I've enabled it under Ac...

Jump to post
  • Sun Jun 14, 2020 10:05 am
  • Replies 5
  • Views 232
[SOLVED] Reports not visible for usergroup

Lectori Salutem, I'm trying to create access to a (1) products purchased report for a (1) new user. So I've created a new user group (system/users/user group) and ticked the report/report access permissions. Modify permissions are all de-selected. Then I added a new user (system/users/users) and gav...

Jump to post
  • Sat Jun 13, 2020 2:38 am
  • Replies 2
  • Views 146
Re: [RELEASED] Multilingual Export/Import for OpenCart 2.x / 3.x

You're right, installation now works ok. Not sure what happened. As for the php://output." error, I changed $pFilename = @tempnam(PHPExcel_Shared_File::sys_get_temp_dir(), 'phpxltmp'); to $pFilename = 'c:\tmp\phpxltmp'; in /system/library/export_import/Classes/PHPExcel/Writer/Excel2007.php and now a...

Jump to post
  • Fri Nov 03, 2017 3:56 am
  • Replies 1040
  • Views 268482
Re: [RELEASED] Multilingual Export/Import for OpenCart 2.x / 3.x

I just did an install of the 3.19 version of Export/Import on a fresh installation of OC 3.0.2.0. The standard installation through Extensions/Marketplace/Install gives me a "Signature hash does not match!" and does not install. Downloading the zip and uploading it with Extensions/Installer/Upload d...

Jump to post
  • Thu Nov 02, 2017 3:47 am
  • Replies 1040
  • Views 268482

Page 1 of 1

Search found 9 matches