Search found 84 matches

Search found 84 matches

Re: imagecreatetruecolor(): Invalid image dimensions

The function has three default parameters, however if you try to use them, the function fails. You really trying to say that is an intended result? If the function requires three parameters to work -- and fails without all three parameters -- Why are the parameters optional? Can you explain that to ...

Jump to post
  • Sun Aug 25, 2019 9:31 pm
  • Replies 5
  • Views 503
Re: imagecreatetruecolor(): Invalid image dimensions

Thanks for your helpful thoughts. I'm not making things up, this fails. Walk through it for this method call: $image->resize(300); what does $height equal when imagecreatetruecolor($width, $height) runs? It will evaluate to 0 and imagecreatetruecolor will fail because you cannot create an image that...

Jump to post
  • Sat Aug 24, 2019 11:46 pm
  • Replies 5
  • Views 503
Re: imagecreatetruecolor(): Invalid image dimensions

There's actually several problems with this code... here are my revisions that are currently working properly.

https://pastebin.com/2fx4vxA3

Jump to post
  • Sat Aug 24, 2019 11:30 pm
  • Replies 5
  • Views 503
imagecreatetruecolor(): Invalid image dimensions

3.0.2 system/library/image public function resize ($width = 0, $height = 0, $default = '') { [...] $this->image = imagecreatetruecolor($width, $height) } This line should be $this->image = imagecreatetruecolor($new_width, $new_height) I believe the same error occurs here: imagefilledrectangle($this-...

Jump to post
  • Sat Aug 24, 2019 11:06 pm
  • Replies 5
  • Views 503
Devs: How would YOU do this?

Client wants the ability to save a shopping cart for later. That is, take all the products in the cart, store their info somewhere, and then empty the cart. Then the user would be able to retrieve that cart and add its products to the current cart. Should I just store the product info in JSON in the...

Jump to post
  • Tue Feb 26, 2019 8:38 am
  • Replies 2
  • Views 367
Re: Taking payment admin-side

Sure but once theyre in admin side how do they process the order and get payment

Jump to post
  • Sun Feb 17, 2019 9:45 am
  • Replies 3
  • Views 298
Re: Taking payment admin-side

Do I need to build a CC form modal and trigger the payment providers api manually?

Jump to post
  • Sat Feb 16, 2019 11:24 am
  • Replies 3
  • Views 298
Taking payment admin-side

Client wants to have a payment method called "Pay by Phone" -- basically the same as "free checkout" and then from admin side we will call the customer and take Cedit Card payment over the phone and enter the information in on the admin-side of the application. Where in admin side is that done? I ha...

Jump to post
  • Sat Feb 16, 2019 10:57 am
  • Replies 3
  • Views 298
Re: 500 Internal Error on Checkout - Register Account

Most likely a modification you've added that doesn't work. Start by deleting any mods.

If you havent installed any, permissions error is still the #1 most likely thing.

Jump to post
  • Thu Feb 14, 2019 9:37 am
  • Replies 4
  • Views 441
Re: Admin Page on 3.0.2.0 Very slow

Bumping for new information -- My admin section was taking ~25 second for page load on local development. Found solution here -- https://github.com/opencart/opencart/issues/5559 Issue is due to SASS recompiling at every page load. in system/config/admin, comment out line 26 'startup/sass' Page load ...

Jump to post
  • Thu Feb 14, 2019 9:29 am
  • Replies 8
  • Views 1656
[2.3.0.2] Admin-Side emails not firing [SOLVED]

Hi guys, Having a strange issue where the catalog-side emails are getting sent properly (eg new user registration) but any emails that originate from the admin side of the application (eg user has been approved) are not being delivered. OC doesn't shoot any errors. It seems like everything is going ...

Jump to post
  • Wed Nov 14, 2018 11:12 pm
  • Replies 0
  • Views 369
Re: Staying with OpenCart

The shopping cart framework isn't where your issue is. Your issue is your business has now grown to the point where what you need done simply cant be done by mass-produced extensions that you buy for $25. This will be true in opencart or in shopify or any other framework. Its hard to be a serious pl...

Jump to post
  • Mon Sep 24, 2018 3:28 am
  • Replies 18
  • Views 1170
Re: Notice: Undefined index: in_stock_status_id 2.3.0.2

This is an error by the developer. The part thats incorrect is ....

$query->row['in_stock_status_id']

Your best bet is contact him and show him this thread.

Jump to post
  • Wed Jun 20, 2018 1:46 am
  • Replies 2
  • Views 587
Want to watch a beginners opencart course?

(Free!) The biggest obstacle to opencart gaining popularity is that its just really hard to get started with. There's not much documentation, and there's a lot of "little" stuff you have to know first. Most of what IS on the web is outdated. I'm working on writing a course for people looking to get ...

Jump to post
  • Wed Jun 20, 2018 12:30 am
  • Replies 1
  • Views 507
Re: Opencart multi store second store redirects to default store

Its been forever since I dealt with this, but check your config.php files and see if you can force it to https that way.

Jump to post
  • Wed Jun 20, 2018 12:27 am
  • Replies 2
  • Views 557
Fatal installation bug found

https://github.com/opencart/opencart/bl ... tartup.php

Line 98, reference.php does not exist.

Since this is a required file, installation halts.

Removing line 98 will solve the problem.

Jump to post
  • Sat Jun 02, 2018 5:40 am
  • Replies 1
  • Views 394
Re: Opencart 2.0.1.1 Hacked - Please Help

I did some digging through the site -- Its being dumped in after the opencart footer, so my guess is it is a standalone php file that someone snuck into your server. It is a <form> element and its not calling any external site, so when you fill it out, the form is being submitted to a script that is...

Jump to post
  • Sat Mar 10, 2018 3:57 am
  • Replies 5
  • Views 1042
Re: Customer details are pre-filled

Thats not his browser auto-filling the forms from memory guys. For whatever reason his php file is echoing out the details... probably just echoing out user_id 1. First thing is disable all your extensions and see if the problem goes away. If you can't track it down from there, you'll probably need ...

Jump to post
  • Fri Mar 09, 2018 10:33 pm
  • Replies 4
  • Views 654
Re: Featured Module Not Working - Updated in Detail ......

I like money. Go ahead and shoot me an email, I can take care of this for you.

RGBrewer@gmail.com :)

Jump to post
  • Fri Mar 09, 2018 10:29 pm
  • Replies 10
  • Views 792

Search found 84 matches