Post by webfeetdesign » Thu Jun 10, 2010 6:22 pm

My client who is a big company is getting the message - Internal Error when they have added there card details and click checkout button. I'm really lost on what to do here. It works fine for me but they have had at least 10 customers phone up saying the same thing. There sales have dropped dramatically too.

I would be forever in your debt if you could help me.

Alex :o
Last edited by i2Paq on Thu Jun 10, 2010 6:26 pm, edited 1 time in total.
Reason: Title adjusted

Active Member

Posts

Joined
Fri Feb 05, 2010 1:28 am
Location - Dubai

Post by i2Paq » Thu Jun 10, 2010 6:26 pm

Which version of OC, what payment method, did you make any changes to the code.

We need more info!

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by webfeetdesign » Thu Jun 10, 2010 6:38 pm

Im using PayPal Website Payment Pro. The version i'm using is 1.4 and was installed late feb. The payments work fine with Lloyds but there was a problem with Halifax yesterday but for some reason that now works. HSBC doesn't seem to be working now though.

I've made no changes to the code.

Active Member

Posts

Joined
Fri Feb 05, 2010 1:28 am
Location - Dubai

Post by i2Paq » Thu Jun 10, 2010 6:39 pm

webfeetdesign wrote:Im using PayPal Website Payment Pro. The version i'm using is 1.4 and was installed late feb. The payments work fine with Lloyds but there was a problem with Halifax yesterday but for some reason that now works. HSBC doesn't seem to be working now though.

I've made no changes to the code.
So it works with one bank but not with the other.

have you contacted HSBC about this?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by webfeetdesign » Thu Jun 10, 2010 6:46 pm

No not yet, been trying to find out what the problem is. Its been working like a dream for a couple of months no probs. I don't understand. Could it be a bank issue?

Active Member

Posts

Joined
Fri Feb 05, 2010 1:28 am
Location - Dubai

Post by i2Paq » Thu Jun 10, 2010 6:53 pm

webfeetdesign wrote:Could it be a bank issue?
Looks to me it is.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by JNeuhoff » Sat Jun 12, 2010 9:32 pm

One of my customers (using OpenCart 1.3.4) had similar issues with the PayPal Pro for the past few days. The problem appears to be the PayPal server which sometimes sends back to OpenCart something like the following variables:

TIMESTAMP = '2010-06-10T18:09:41Z'
CORRELATIONID = 'xxxxxxxxxxxxx'
ACK = 'Failure'
VERSION = '51.0'
BUILD = '1338445'
L_ERRORCODE0 = '10001'
L_SHORTMESSAGE0 = 'Internal Error'
L_LONGMESSAGE0 = 'Internal Error'
L_SEVERITYCODE0 = 'Error'
AMT = 'xx.xx'
CURRENCYCODE = 'GBP'

I think this is a timeout issue on the PayPal server. The problem is NOT with OpenCart nor its PayPal PRO payment module.

Maybe Qphoria can shed some light on this?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 13 guests