Post by graze » Tue Aug 07, 2018 10:52 pm

I've recently installed 3.0.2.0 and I can get any emails to send, the contact us form works but thats it, I've spoken to my host (siteground) and ran through my settings and they can't see a problem, I've changed my email password numorus times, I've got all my alert mail boxes ticked, I'm getting no errors in my hosts log or opencarts error log, I've put up other versions of opencart and not really had any issues.

I've run out of ideas anyone got any pointers?

Thanks.

New member

Posts

Joined
Wed Jun 24, 2015 5:28 pm

Post by straightlight » Wed Aug 08, 2018 1:10 am

How many events are listed in your admin - > extensions - > events page?

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by graze » Wed Aug 08, 2018 3:42 am

4 Events -

openbay
openbay
openbaypro_amazon
openbaypro_ebay


All of which are Disabled.

New member

Posts

Joined
Wed Jun 24, 2015 5:28 pm

Post by straightlight » Wed Aug 08, 2018 7:04 am


The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by graze » Wed Aug 08, 2018 5:41 pm

Thanks for the help, I've added the events and now have 33 active events, I'm recieving emails on sign up etc, but when I add history to an order add note and tick notify customer no email is being recieved any ideas?

Thanks.

New member

Posts

Joined
Wed Jun 24, 2015 5:28 pm

Post by graze » Wed Aug 08, 2018 5:58 pm

All now seems to be working!

Thanks very much for your help, this issue was driving me mad.

New member

Posts

Joined
Wed Jun 24, 2015 5:28 pm

Post by bronts » Tue Aug 21, 2018 11:44 am

Dear Straightlight,
It seems I am now having this same issue and as a newbie, I am hesitant to go playing around with files I not confident with.
The shop is OC 3.0.2.0 and the contact form is not sending to the admin email and the order alert email is not being sent also.
Customers can place an order and the invoice is being sent to the customer.
I have checked the settings in the stores mail tab and they are correct.
I tried a quick fix of adding in the admin email (enquiries@redraglynsgems.com) into the Additional Alert Mail to see if that would work (I saw that as a fix on another forum post) and nope :-(
I have rung my hosting provider and everything checks out there too.
I have looked in my events and there are over 33 and all are enabled.

Do you or anyone else have a suggestion to help fix this issue please?

Thank you
Brontè

User avatar
Active Member

Posts

Joined
Sat Jul 14, 2012 12:56 pm
Location - QLD Australia

Post by straightlight » Tue Aug 21, 2018 5:54 pm

I tried a quick fix of adding in the admin email (enquiries@redraglynsgems.com) into the Additional Alert Mail to see if that would work (I saw that as a fix on another forum post) and nope :-(
Source instruction unprovided. More information is needed.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bronts » Tue Aug 21, 2018 7:41 pm

oops sorry,
viewtopic.php?f=202&t=201380&p=729898&h ... er#p729898
The change that seems to have made it work is removing my admin email from the 'Mail Parameters" field in the Systems>Stores>Settings>Mail Tab. I put an alternate email in there which is also hosted from my godaddy (another ...@e-lectronics dot net) address. Nothing seems to be sending to this other email but I put my primary store email in the "Additional Alert Mail" field at the bottom of the page. I had tried using the Additional Alert before but also had my primary email in the Mail Parameters field.

User avatar
Active Member

Posts

Joined
Sat Jul 14, 2012 12:56 pm
Location - QLD Australia

Post by straightlight » Wed Aug 22, 2018 7:27 am

Since, you are using GoDaddy webhosting service, see if this provided solution is working: viewtopic.php?f=181&t=153330&p=719678#p719678

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bronts » Wed Aug 22, 2018 7:31 am

Oooooh Thank you Straightlight, I'll give it a try.
I didn't see that post in my hunt through the forum.
*fingers crossed*

User avatar
Active Member

Posts

Joined
Sat Jul 14, 2012 12:56 pm
Location - QLD Australia

Post by bronts » Thu Aug 23, 2018 3:58 pm

Dear Straightlight,
I followed the instructions, step by step and that fix unfortunately did not work and when I go to make a fake order...
When I click on the confirm button at the checkout, i get an error popup (it says internal server error).
When I look in admin at the error log, I have this listed...

Code: Select all

2018-08-23 7:43:02 - PHP Warning:  fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/***/public_html/system/library/mail/smtp.php on line 87
2018-08-23 7:43:02 - PHP Warning:  fsockopen(): unable to connect to relay-hosting..secureserver.net:25 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/***/public_html/system/library/mail/smtp.php on line 87
I presume I will also need to change the mx records back as I am not able to receive any emails at all now (I can send though, but not from/via the shop).
The shop owner only uses godaddy's workspace webmail.

Do you have any other ideas?
Would this fix you mentioned on another post re: a similar issue work?
viewtopic.php?f=202&t=202500&p=715912#p715912

User avatar
Active Member

Posts

Joined
Sat Jul 14, 2012 12:56 pm
Location - QLD Australia

Post by straightlight » Thu Aug 23, 2018 5:50 pm

Then it would be incorrect to state that you encounter the same issue as the OP reported originally on this topic.
relay-hosting..secureserver.net:25
I do notice two dots in the address. According to the error message you posted above, the issue is related to the mail configuration form in the OC admin you have filled. As for the events, it would be the correct location to follow the instructions on how to resolved the events list. The default quantity is 33 events - still in OC v3.0x releases.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by bronts » Thu Aug 23, 2018 6:55 pm

I got rid of the extra . hoping that would be it, but no, I still get the popup internal server error when i try to place an order and the error long says...

Code: Select all

2018-08-23 10:50:47 - PHP Warning:  fsockopen(): unable to connect to relay-hosting.secureserver.net:25 (Connection refused) in /home/mcoskkwvkbwx/public_html/system/library/mail/smtp.php on line 87
And i have over have over 33 events listed.

User avatar
Active Member

Posts

Joined
Sat Jul 14, 2012 12:56 pm
Location - QLD Australia

Post by bronts » Thu Aug 23, 2018 7:41 pm

Update:
Just got off the phone with GoDaddy and they changed one of the MX records and now I can place orders AND get the order alert email *happy dance*
Still not getting any emails from the contact form though :-( But I am happy to be a step closer.

Further Update:
It's working now. I presume the MX records needed a little more time *shrugs shoulders*

User avatar
Active Member

Posts

Joined
Sat Jul 14, 2012 12:56 pm
Location - QLD Australia
Who is online

Users browsing this forum: dani888 and 16 guests