Post by Cloudeze » Sat Jun 23, 2018 6:09 pm

Hello guys,

i have a serious problem here! I'm using this extension to change seo url https://www.opencart.com/index.php?rout ... n_id=24613 and for about 6 month only 6-10 page was indexed and I don't know if the seo url extension prevent google from accessing urls. Because sometimes google says that some of my page are not found.

Do you know the reason for this? Can someone take a look on the code and tell me if something wrong with it? Do you suggest to me to remove the extension or what? 28 page was submitted in google webmasters and only 4 page was indexed in google webmasters while the google search display 6-10 page are indexed. Is this logical?

my opencart version is 1.5.6.4

Please let me know your suggestions. Thank you!

New member

Posts

Joined
Sun Jul 16, 2017 12:23 am

Post by straightlight » Sat Jun 23, 2018 7:55 pm

- .htaccess issues
- using old OC version

Suggesting to upgrade your OC version. Use a website analyzer for detailed report about your website's flexibilities.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Cloudeze » Sun Jun 24, 2018 7:24 am

straightlight wrote:
Sat Jun 23, 2018 7:55 pm
- .htaccess issues
- using old OC version

Suggesting to upgrade your OC version. Use a website analyzer for detailed report about your website's flexibilities.
I don't think the version is problem because there is some site using oc 1.5.6.4 and indexed very well in google. Any other suggestions please?

New member

Posts

Joined
Sun Jul 16, 2017 12:23 am

Post by IP_CAM » Sun Jun 24, 2018 8:44 am

I don't think the version is problem ...
Sure not :D
it's likely more an 'ideological' issue around here, to frequently talk 1.5.6.x Versions down.
But Business cannot continue, as soon as just about everything on Mod's and Infos exists,
wich is the case for v.1.5.6.x. Wich could make it understandable, from that point of view ... ;)
---
But since you did not share a single link, there is absolutely no way, to get a minimum
impression on what you have been doing so far, header-wise, to get indexed well. :-\
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Cloudeze » Sun Jun 24, 2018 5:34 pm

IP_CAM wrote:
Sun Jun 24, 2018 8:44 am
I don't think the version is problem ...
Sure not :D
it's likely more an 'ideological' issue around here, to frequently talk 1.5.6.x Versions down.
But Business cannot continue, as soon as just about everything on Mod's and Infos exists,
wich is the case for v.1.5.6.x. Wich could make it understandable, from that point of view ... ;)
---
But since you did not share a single link, there is absolutely no way, to get a minimum
impression on what you have been doing so far, header-wise, to get indexed well. :-\
Ernie
IP_CAM, I didn't understand the first part, can you please explain more?

My robots.txt has something like that:

Code: Select all

user-agent: *
Disallow: /*&limit
Disallow: /*?limit
Disallow: /*&sort
Disallow: /*?sort
Disallow: /*?route=checkout/
Disallow: /*?route=account/
Disallow: /*?route=product/search
Disallow: /*?route=affiliate/
Allow: /
Htaccess

Code: Select all

RewriteEngine On

#RewriteCond %{QUERY_STRING} (^|&)sort= [NC,OR]
#RewriteCond %{QUERY_STRING} (^|&)limit= [NC]
#RewriteRule (.*) /$1? [R=404,L]

# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /

#RewriteCond %{HTTP_HOST} ^www\.domain\.com [NC]
#RewriteRule ^(.*)$ https://domain.com/$1 [L,R=301]

#Force (http host) non www to www
#RewriteCond %{HTTP_HOST} !^www\.
#RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

#Rewrite to HTTPS:
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

# Allow robots.txt and block all files .txt
#RewriteCond %{REQUEST_URI} !/robots\.txt$ [nocase]
#RewriteRule \.txt$  -  [forbidden,last]

RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteRule ^system/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
Does something wrong with my htaccess or robots.txt?

I want to make my robots.txt just like this way:

Code: Select all

User-agent: *
Allow: /
But the problem if i did, google will index all pages will index.php?route=
Any suggestions how to prevent google indexing this or if you have a good method to rewrite all urls to a custom seo urls?

Thank you so much guys.

New member

Posts

Joined
Sun Jul 16, 2017 12:23 am

Post by straightlight » Sun Jun 24, 2018 8:48 pm

As mentioned on the above, the issue could be related to .htaccess codes.
I don't think the version is problem because there is some site using oc 1.5.6.4 and indexed very well in google. Any other suggestions please?
Since no website analysis has been done and no official report has been provided, this quote is only based on assumption. Take note that PHP requirements with OC has increased over the past few weeks and it is important to consider to due compatibility, accessibility and flexibility of the platform.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Sun Jun 24, 2018 8:50 pm

As mentioned on the above, the issue might be with the .htaccess codes.
I don't think the version is problem because there is some site using oc 1.5.6.4 and indexed very well in google. Any other suggestions please?
Since no website analysis has been done and posted with official reports about it, the above quote is only based on assumption. Take note that PHP requirements with OC has increased since the past few weeks as it is important to consider due to accessibility, compatibility and the flexibility of the platform.

The most generated errors being found on Opencart forum originates from contributed programming. The increased counters are caused by posted redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Mon Jun 25, 2018 5:43 am

, I didn't understand the first part, can you please explain more?
Well, just compare OC with Windows, if MS still would have to care about XP's,
for free and for those, unwilling to move up, they would be broke for a long time
already. Despite of the Fact, that they still do it, just not for free ! :laugh:
And Ideology is, then trying to convince Users, that the are in great danger, if
they further use that unworthy, messy old piece of crab any longer, without
delievering even one single proven Fact, not also valid for later Versions too ...
And because of all this, I still use my XP's, and they work best! :D
---
Still, you should make sure, to also use a late PHP Version too, but also better
make sure, NEVER to use ANY latest Version, they are always still full of Bugs, like
Windows, OC, PHP, or whatever it might be. ;) Or there would be no more Upgrades
and Fixes, required, to keep those things alive and well.
viewtopic.php?f=20&t=205294#p727393
But that's only my very personal point of view, from looking around, on what's going on.
So, don't take it for granted, since I'm not a Pro! :D
Good Luck!
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by Cloudeze » Mon Jun 25, 2018 7:52 am

IP_CAM wrote:
Mon Jun 25, 2018 5:43 am
, I didn't understand the first part, can you please explain more?
Well, just compare OC with Windows, if MS still would have to care about XP's,
for free and for those, unwilling to move up, they would be broke for a long time
already. Despite of the Fact, that they still do it, just not for free ! :laugh:
And Ideology is, then trying to convince Users, that the are in great danger, if
they further use that unworthy, messy old piece of crab any longer, without
delievering even one single proven Fact, not also valid for later Versions too ...
And because of all this, I still use my XP's, and they work best! :D
---
Still, you should make sure, to also use a late PHP Version too, but also better
make sure, NEVER to use ANY latest Version, they are always still full of Bugs, like
Windows, OC, PHP, or whatever it might be. ;) Or there would be no more Upgrades
and Fixes, required, to keep those things alive and well.
viewtopic.php?f=20&t=205294#p727393
But that's only my very personal point of view, from looking around, on what's going on.
So, don't take it for granted, since I'm not a Pro! :D
Good Luck!
Ernie
Yes, you are right and fine of win XP BTW :)

I don't know why i don't want to upgrade to latest opencart version, because I really like the v1.5.6.4. Do you think this version still safe to use? I think you still use it form some of your websites. Did you found any bugs or improvements to make it even safe? can you share with me the best way to change contact/register/login page to custom seo urls?

thank you very much for help.

New member

Posts

Joined
Sun Jul 16, 2017 12:23 am

Post by IP_CAM » Mon Jun 25, 2018 8:49 am

Well, the (latest 1.5.x!) v.1.5.6.5_Release-Candidate is better, because it already had a
few still existing misses fixed, compared with the last 'official' v.1.5.6.4 Release.
So, one could only download the about 25 fixed Files, and replace existing one's,
to so have the latest 1.5.6.5 code and wisdom installed in a v.1.5.6.4 ;)
https://github.com/opencart/opencart/bl ... angelog.md

But due to the earlier Debut of the first OC v.2.0 Generation, another 'official Version 1.5.6.5'
could have lead to a lot of Rumors and Questions among Users, and, worst of all, hinder
Sellers from creating cash, once again, so, it got dropped, or at least hidden, from the
officially published Line of OC-Releases, for good. :choke:
https://github.com/opencart/opencart/tr ... 306fb75707

Still, it's used as part of some complete Packages, consisting out of either a Custom responsive
Admin Theme, or then, as Bases for some responsive Themes. And since it's debut, no matters
or questions have been raised, about problems or misses, related to 1.5.6.5_rc, anywhere. ::)
And if only a couple of hundred active Sites would exist, some questions would have been raised,
that's enough for me, to know, what to still use, and this, without a single drop of ideology.

But I use it in an enhanced Form, by use of OC-2 Themes, to make the Front Side responsive
by regular OC v.2.+ Bootstrap Design. You might find more infos on this, by checking about
Opencart-1.5.6.5-Edge in my Github OC Code Archive, if you ever plan, to make your
Version front-side look and work like, what's 'OC-Style' today ! :D
https://github.com/IP-CAM
---
can you share with me the best way to change contact/register/login page to custom seo urls?
Well, I momentarely test a somewhere 'found' solution for SEO, as shown here:
http://www.velomech.ch/cart/
And it's only consisting of some code-section, to be placed in a regular OC File, to then
create Pages with, in my case, an HTML extension ending. It stores all URL's in it's own Cache
Section, and uses links+titles, consisting out of category and product name as well as some numbers.
It looks great, but that cache setup also kept one of my other ~120 extensions from doing it's
Job, just to mention this! :laugh:
But I would have to find out first, where it eventually fails, and where I got it ... 8)
---
Did you found any bugs or improvements
Well, bunches of them, and sure not many Bugs, but xx improvements! :D
Especially in the admin zone, and based on genious MaxD's OpenShop
Idea. But it always depends on, how much time someone is willing to invest,
to peak something to it's best, and I invested ~15k houres, so far, to only
find out, what exists, and possibly matches best. Too much, to sometimes
even remember, what I already have done before... 8)
---
But this, on the other hand, also hinders me so far, to simply create a shareware
Version out of it, since such Code could eventually have a negative effect, when it
comes to add existing VqMod Extensions to such a custom-modified Source.
This, just to make it clear, that the V-2-themed OC 1.5.6.5 will require VqMods, to
match it's own Theme-related way of doing things, it cannot be expected, that
everything just works, as it did before ... just to have this mentioned too! :'(
---
My present Test Shops all use about 100 VqMod's, in Action, besides of some
hard-coded stuff.

Just Nuts, probably... , or I would be gone for a long time already, I guess :crazy:
Ernie

For Sale: Top URL's, including OpenCart V-Pro installed, like seen here:
http://www.bigmax.ch - http://www.ipcam.li - http://www.opencart.li
For Information + URL's offered, please contact me at: jti@jacob.ch
I am NOT available for Custom Support in existing OC Installations!
My Github Repositories: https://github.com/IP-CAM
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: Google [Bot] and 18 guests