Post by tsloc » Sat Jan 13, 2018 10:52 pm

Dear all,

I have a problem with my OC 2.3.0.2. store. When a customer have placed an order, they sometimes write or misspelling their email address, phone number or some other customer info. When I trying to edit the info in the placed order in admin, I got a error and it´s impossible to change.

For example I want to change the email address. I edit the details and klicking next until the past page with the button "Save". When I click the button I have the error message "Shipping options are required!" and I can´t proceed. I have this roll down list with only one option and Im using X-Shipping Pro module for the shipping options. The admin just keep fightning with the red marked shipping options row.

Any one else who have dealed with this issue?


Best regards Thomas

New member

Posts

Joined
Thu Feb 09, 2017 7:15 am

Post by straightlight » Sat Jan 13, 2018 10:53 pm

Im using X-Shipping Pro module for the shipping options
Caused by this installed extension with a shipping error message. Contact the extension developer to resolve this issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by tsloc » Sun Jan 14, 2018 5:39 pm

Thanks straightlight for your reply!

Unfortunately I have been in contact with the developer of the shipping method, and he told me that it´s not the module itself that cause this problem. Also the "Payment method" is impossible to change and the admin shows the error when I trying to change the payment method.

I tried to activate flat shipping method and did a test order. It was the same result here with red marks around both "shipping method" and "payment method".

My store setup is:
OpenCart 2.3.0.2
Pavilion theme from BurnEngine
Quick Checkout from MarketInSG
+ other other additional modules

My question is what can cause this problem in backend in Admin area? Everything else in frontend work correctly.


Best regards Thomas

New member

Posts

Joined
Thu Feb 09, 2017 7:15 am

Post by straightlight » Sun Jan 14, 2018 7:50 pm

OpenCart 2.3.0.2
Pavilion theme from BurnEngine
Quick Checkout from MarketInSG
+ other other additional modules
It is kind of obvious at this point that one of these extensions might be causing an issue. Test Opencart on a virtual server or on a separate folder and install one extension at a time until finding the cause of the issue.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Guru Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 24 guests