Post by flpcarv » Mon Aug 21, 2017 10:47 am

I made an extension to 2.3 and it was working normaly now I am trying to upgrade to 3.0 using Twig language but I am getting a blank page without any errors, not even on the logs file. Where should I look at to know what I am doing wrong? Thanks.

Newbie

Posts

Joined
Mon Aug 21, 2017 10:43 am

Post by linetrace » Mon Aug 21, 2017 10:33 pm

You're probably getting PHP errors and may not have error logging enabled in your PHP.ini. I'd suggest researching how to verify and/or enable that on your platform/host.

Also, I've added some notes on what needs to be changed in an extension to upgrade it from 2.3.x to 3.0.x, beyond just the conversion of views from .tpl to .twig. See the second half of my How to successfully upgrade from OC 2.3.0.2 to 3.0.2.0 thread.

Newbie

Posts

Joined
Sat Aug 05, 2017 4:42 am
Location - Winooski, VT, US

Post by flpcarv » Tue Aug 22, 2017 12:12 am

linetrace wrote:
Mon Aug 21, 2017 10:33 pm
You're probably getting PHP errors and may not have error logging enabled in your PHP.ini. I'd suggest researching how to verify and/or enable that on your platform/host.

Also, I've added some notes on what needs to be changed in an extension to upgrade it from 2.3.x to 3.0.x, beyond just the conversion of views from .tpl to .twig. See the second half of my How to successfully upgrade from OC 2.3.0.2 to 3.0.2.0 thread.
My apache is configured to show any errors, so its probably something else, I should look for the twig engine error logs.

-----------------

Yeah I could't find what is wrong, it just show a blank page without showing any errors, I will stay with 2.3.x for now, I hope I can make it work at the end of the year.

Newbie

Posts

Joined
Mon Aug 21, 2017 10:43 am

Post by pm-netti » Tue Aug 22, 2017 2:27 pm

linetrace wrote:
Mon Aug 21, 2017 10:33 pm
You're probably getting PHP errors and may not have error logging enabled in your PHP.ini. I'd suggest researching how to verify and/or enable that on your platform/host.

Also, I've added some notes on what needs to be changed in an extension to upgrade it from 2.3.x to 3.0.x, beyond just the conversion of views from .tpl to .twig. See the second half of my How to successfully upgrade from OC 2.3.0.2 to 3.0.2.0 thread.
Hi.
Can you try, add this script to index.php top:

Code: Select all

ini_set('display_errors', 1);
ini_set('display_startup_errors', 1);
error_reporting(E_ALL);

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland
Who is online

Users browsing this forum: No registered users and 6 guests