Post by nudylady » Mon May 02, 2016 4:58 pm

I looking for an extension to remove API.

New member

Posts

Joined
Sun Feb 19, 2012 12:14 am

Post by nudylady » Mon May 02, 2016 5:02 pm

kul1010 wrote:Post by webtiger is working fine. Thanks to him. But some changes in IP address give your subscriber ip not server or client ip.

like Below you can create a list of IP's allowed to access the API. Your current IP is 122.162.60.67


Its very simple first go into System > User > API
1 Give Name To Your API Example : " Main IP "
2 Click on Generate API
3 Make it Enable

Click on API Addressees
Click on ADD IP
Copy paste your IP

Click on Save

Then Go to System > Setting > Edit Your main Store > Click on Option
See here : API User
Select Your API USER Which was created in last Stage
For Example Select " main IP "
This method has been posted 100 time all over the internet. does not help me. I am stucked

New member

Posts

Joined
Sun Feb 19, 2012 12:14 am

Post by cristianmiu » Thu Jul 28, 2016 3:03 am

Is there any solution to disable this API? I cannot add the ip everytime... i check my orders from different ip addresses ( mobile, tablet, hotel room )... In the past i was using opencart 1.5.x without any problems.

Thank you !

Newbie

Posts

Joined
Mon Jul 16, 2012 10:22 pm

Post by straightlight » Thu Jul 28, 2016 3:41 am

cristianmiu wrote:Is there any solution to disable this API? I cannot add the ip everytime... i check my orders from different ip addresses ( mobile, tablet, hotel room )... In the past i was using opencart 1.5.x without any problems.

Thank you !
Opencart v2.3 Beta fixes all passed issues encountered with the API: http://forum.opencart.com/viewtopic.php ... 30#p627403

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by kalogero » Wed Aug 03, 2016 4:52 am

//////////////////THIS IS THE REAL SOLUTIONS FOR THIS CASE ///////////////////////////

Its very simple first go into System > User > API
1 Give Name To Your API Example : " Main IP "
2 Click on Generate API
3 Make it Enable

Click on API Addressees
Click on ADD IP
Copy paste your IP

Click on Save

Then Go to System > Setting > Edit Your main Store > Click on Option
See here : API User
Select Your API USER Which was created in last Stage
For Example Select " main IP "

When another administrator login the system prompts you to add your new IP automatically and that's all

Newbie

Posts

Joined
Wed Aug 03, 2016 4:49 am

Post by cobrapromotions » Fri Aug 12, 2016 8:59 am

I have 2 sites, both running 2.0.3.1. The first site is not multi store, and it works fine. The second site is multi store and I cannot edit any orders - the dreaded you do not have permission error. When I go to settings -> users -> api, I had never changed anything on either site since I installed them a year ago. Nowhere do I have an option to add or change IP addresses, it simply is not there.

At this point, my main site is useless, I cannot edit any orders. Short of doing a nuke and reinstall, is there going to be any fix for this at the 2.0.3.1 level? This is ludicrous! Telling people to add IP addresses on a panel that does not exist on their system is no help at all.


Posts

Joined
Mon Sep 14, 2015 6:13 am

Post by hos » Fri Nov 18, 2016 10:57 pm

i have the same problem, Version 2.3.0.2, i can not complete the "pending" orders! to be complete or shipped .etc.
i get "Warning: You do not have permission to access the API! "

i did above solutions and no way ???

hos
Newbie

Posts

Joined
Wed Nov 16, 2016 5:34 pm

Post by infaas » Sun Dec 04, 2016 3:48 pm

hos wrote:i have the same problem, Version 2.3.0.2, i can not complete the "pending" orders! to be complete or shipped .etc.
i get "Warning: You do not have permission to access the API! "

i did above solutions and no way ???
Hello
Compatibility2.3.0.0, 2.3.0.1, 2.3.0.2
here last solution create code or download https://www.opencart.com/index.php?rout ... n_id=28323
api.ocmod.xml
<?xml version="1.0" encoding="utf-8"?>
<modification>
<code>ifaass_auto_add_api_ip</code>
<name>Auto ADD api IP</name>
<version>1.0</version>
<author>Nzymic</author>
<link>http://www.opencart.com/</link>
<file path="admin/view/template/sale/order_form.tpl">
<operation>
<search trim="true"><![CDATA[
$('#content > .container-fluid').prepend('<div class="alert alert-danger"><i class="fa fa-exclamation-circle"></i> ' + json['error']['ip'] + ' <button type="button" id="button-ip-add" data-loading-text="<?php echo $text_loading; ?>" class="btn btn-danger btn-xs pull-right"><i class="fa fa-plus"></i> <?php echo $button_ip_add; ?></button></div>');
]]></search>
<add position="after"><![CDATA[
$('#button-ip-add').click();
]]></add>
</operation>
</file>
</modification>

Newbie

Posts

Joined
Sun Dec 04, 2016 3:42 pm

Post by denise92 » Mon Dec 05, 2016 5:34 am

I'm using 2.3.0.2 and 2.2.0.0, and only 2.3 have this issue...

Hope my extension can help you.....
https://www.opencart.com/index.php?rout ... n_id=28614

Image


Newbie

Posts

Joined
Wed Jun 15, 2016 3:20 am
Location - Taiwan

Post by QuinnD » Tue Dec 20, 2016 8:55 pm

I was just testing a new install of OC v 2.3.0.2 and had this problem..

fix was easy

the first time i got this message when entering Orders, a button to add ip also appears with the message, added IP and got this message again when i tried to edit the order.

found this thread so checked permissions as the first reply suggested, found all to be ticked already and all permissions set..

I decided to go through the save process anyway and test the order editing again.

This time it worked,

i would suggest if your having this problem resave your user permissions for administrator

Newbie

Posts

Joined
Tue Dec 20, 2016 8:46 pm

Post by RandyRocket » Mon Jan 30, 2017 11:25 pm

This is in fact a bit of a stupid logic...

Since admin ips often are not static and will change... There should be a way to remove this blocking and also disable API.

Is there already a way without hacking the code?

Newbie

Posts

Joined
Fri Jan 06, 2017 5:44 am

Post by 8pmshop » Fri Feb 03, 2017 11:04 pm

Check your base url

if your base url is :
<base href="http://culedshoes.com/admin/" />

when you login , you should not use www.culedshoes.com/admin to login, once you did, not matter what you do, the error pop up.


all depends on your base url :

with or without www
with or without https

User avatar
New member

Posts

Joined
Sat Oct 08, 2016 11:27 pm
Location - new york

Post by al404 » Wed Feb 15, 2017 2:46 am

since most connection has dynamic IP each time i connect to order i need to add my IP to API?
what's the point of this?
is it possible to disable IP restriction?

New member

Posts

Joined
Fri May 04, 2012 4:29 pm

Post by Quish » Thu May 11, 2017 8:11 pm

I might have a solution for those of you who have everything enabled and your IP is on list.
If you are using OCmod extensions you need to navigate to Extensions > Modifications > And hit reload button.

Once I did this, recently added IP address is working without any problem.

Hope this helps atleast some of you :)

New member

Posts

Joined
Sun Jan 27, 2013 8:39 pm

Post by asrofi_indo » Mon Jul 03, 2017 6:00 pm

Simple.

Just install extension "Disable API checks", or with this link "https://www.opencart.com/index.php?rout ... _license=0"

It is free.

Thanks for app developer.

Newbie

Posts

Joined
Mon Jul 03, 2017 5:56 pm

Post by globalscope » Sat Aug 19, 2017 4:28 am

Great

Newbie

Posts

Joined
Fri Aug 18, 2017 2:51 pm

Post by Leoden » Sat Apr 21, 2018 12:28 am

go to system -> users -> API and make sure the default is enabled and save it.
go to system -> settings -> options and scroll down to Checkout and make sure that the API User is set to Default from the dropdown list and save it.
when you get the warning click on add IP.
that's it enjoy...

_______________________
LEODEN OpenCart Support
https://leoden.com


User avatar
Newbie

Posts

Joined
Wed Apr 04, 2018 2:41 am

Who is online

Users browsing this forum: No registered users and 11 guests