Post by Daniel » Fri Mar 02, 2012 12:49 am

redownload. it was a problem with jquery and i upgrade to the latest version.

OpenCart®
Project Owner & Developer.
OpenCart commercial support now available!


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by markman-b » Fri Mar 02, 2012 1:38 am

I confirm it has been solved.

OC version 1.5.4.1


Newbie

Posts

Joined
Wed Aug 24, 2011 7:13 pm

Post by bingo » Fri Mar 02, 2012 1:45 am

In shopping cart,if leave the quantity blank,then click the refresh image,then will delete the product.
I'm not sure if you think it a bug.

bingo

One Page Checkout Professional - More flexible and powerful one page checkout solution.
One Page Checkout Standard - Best one page checkout solution,separate module,no core files replace.
Product Import Export - Bulk insert update download product excel format.
Order Manager - help you manage orders more effectively.


User avatar
Newbie

Posts

Joined
Sun Sep 04, 2011 6:57 am


Post by Qphoria » Fri Mar 02, 2012 3:36 am

bingo wrote:In shopping cart,if leave the quantity blank,then click the refresh image,then will delete the product.
I'm not sure if you think it a bug.

bingo
The same will happen if you enter a letter instead of a number.. If you leave it empty.. its considered a "0"
If you enter a non-numeric, it's considered a 0.
Always been that way.. not likely to bother changing

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by wroughtec » Fri Mar 02, 2012 9:55 am

Been having a few issue with the create order in admin:

1st on the shipping address when I selected UK as country the county/state did not populate as per the payment tab address

2nd when I try to add a product tells me I do not have permission I double check in the group permissions and clicked select all but this did not resolve the issue

3rd when i clicked save order I got booted out of admin and nothing was saved :( (actually there have a been a few times I have been booted back to the login screen so this may be my issue)

Newbie

Posts

Joined
Sat Feb 18, 2012 7:45 am

Post by Ulf » Fri Mar 02, 2012 5:32 pm

Daniel, now after you have changed files in rev 880
it be error
Undefined variable: basket in C:\xampp\htdocs\test880\catalog\view\theme\default\template\common\header.tpl on line 54

Ulf
Newbie

Posts

Joined
Sat Oct 16, 2010 4:41 pm

Post by markman-b » Fri Mar 02, 2012 5:56 pm

Find catalog\language\english\common\header.php
Change

Code: Select all

$_['text_cart']     = 'Shopping Cart';
into

Code: Select all

$_['text_shopping_cart']     = 'Shopping Cart';
Find
\catalog\view\theme\default\template\common\header.tpl

Change

Code: Select all

<?php echo $basket; ?>
into

Code: Select all

<?php echo $cart; ?>

OC version 1.5.4.1


Newbie

Posts

Joined
Wed Aug 24, 2011 7:13 pm

Post by markman-b » Fri Mar 02, 2012 6:23 pm

The product prices in the order edit section are not being presented in a consistent way. The number of decimals differ.(and the currency symbol is missing....)

According to my store settings, OC should show 2 decimals.

No decimals
Image

4 decimals
Image
Last edited by markman-b on Fri Mar 02, 2012 10:26 pm, edited 2 times in total.

OC version 1.5.4.1


Newbie

Posts

Joined
Wed Aug 24, 2011 7:13 pm

Post by markman-b » Fri Mar 02, 2012 10:24 pm

I'm not sure if this is a bug, but this is what happening, when a customer creates an account during checking out and there is only 1 shipping method active (Free Shipping).

Warning: No Shipping options are available. Please contact us for assistance!'
It is possible to finish the order, but the error message should not appear.

Image

OC version 1.5.4.1


Newbie

Posts

Joined
Wed Aug 24, 2011 7:13 pm

Post by Qphoria » Fri Mar 02, 2012 11:45 pm

markman-b wrote:I'm not sure if this is a bug, but this is what happening, when a customer creates an account during checking out and there is only 1 shipping method active (Free Shipping).

Warning: No Shipping options are available. Please contact us for assistance!'
It is possible to finish the order, but the error message should not appear.

Image
Well its not bug if free shipping isn't appearing if the minimum total field hasn't been met
However, if you see that error, you should not be able to finish the order which would be a bug.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by markman-b » Sat Mar 03, 2012 12:41 am

I've found out what caused the problem. A wrong product setting. (shipping not required)

OC version 1.5.4.1


Newbie

Posts

Joined
Wed Aug 24, 2011 7:13 pm

Post by Qphoria » Sat Mar 03, 2012 1:46 am

markman-b wrote:I've found out what caused the problem. A wrong product setting. (shipping not required)
You should still never see that message if shipping not required.

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by markman-b » Sat Mar 03, 2012 2:06 am

Qphoria wrote:
markman-b wrote:I've found out what caused the problem. A wrong product setting. (shipping not required)
You should still never see that message if shipping not required.
The error message doesn't appear anymore now. I always thought that I had to use the "Free Shipping" method for downloads and set the treshold for free shipping to 0,00.

Changing the product setting to "Shipping not required" did the trick. I've completely overlooked this setting for 6 months :choke:

OC version 1.5.4.1


Newbie

Posts

Joined
Wed Aug 24, 2011 7:13 pm

User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Sat Mar 03, 2012 4:01 am

Current SVN has $basket error at the top of the page and items can't be added to cart. But I assume daniel is working on it

OpenCart 2.0.x Mod Update Info

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by bigboss » Sat Mar 03, 2012 1:12 pm

upgrade from 865 to 880 still has the sql error in the upgrade script.

page header error, can't display the shopping cart icon.
Notice: Undefined variable: basket in /var/server/catalog/view/theme/default/template/common/header.tpl on line 54

====================
language and currency display problem, I would like OC to display them in combo box, see what's happened if there are many language and currency options.

Attachments

pic01.jpg

pic01.jpg (10.32 KiB) Viewed 2637 times


Newbie

Posts

Joined
Sun Jul 25, 2010 10:35 am

Post by bigboss » Sat Mar 03, 2012 1:33 pm

language file is missing this variable : text_shopping_cart (1.5.2 880)

Newbie

Posts

Joined
Sun Jul 25, 2010 10:35 am

Post by i2Paq » Sat Mar 03, 2012 6:27 pm

With the release of 1.5.2 there is an official 1.5.2 BUG Topic.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

UPGRADE to 2.x: Contemplate before thou begins!

Our FREE search: Find your answer FAST!.

BUGs?: Known BUGS for All OC Versions.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands
Who is online

Users browsing this forum: No registered users and 9 guests