Community Forums

Won't go after step 2 in checkout

Bug reports here

Re: Won't go after step 2 in checkout

Postby SoulV » Mon Jan 02, 2012 2:13 pm

Thanks for that... i tried changing the ups code from Daniel, but unfortuantly that has not fixed it.
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby straightlight » Mon Jan 02, 2012 2:15 pm

The addressed URL was modified by Qphoria ... not from Daniel ... is this the solution you pointed out as not working ?
Regards,
Straightlight
straightlight
 
Posts: 2239
Joined: Mon Nov 14, 2011 10:38 am
Location: Canada, ON

Re: Won't go after step 2 in checkout

Postby SoulV » Mon Jan 02, 2012 2:22 pm

Yes by Q then just under by Dan.

Re: OpenCart 1.5.1.3 Bug Thread

Postby Qphoria » Sat Oct 08, 2011 8:17 pm
BUG: UPS and USPS won't work at the same time....

This is because of the new price sorting function that I put into both shipping options. Didn't realize it would leave them loaded. So it actually errors out because it is being redeclared if they are both enabled. This is in 1.5.1.3 only.

The quick fix:
1. EDIT: catalog/model/shipping/ups.php

2. FIND:

function comparecost ($a, $b) {
return $a['cost'] > $b['cost'];
}
uasort($quote_data, 'comparecost');



3. REPLACE WITH:
2. FIND:

function upscomparecost ($a, $b) {
return $a['cost'] > $b['cost'];
}
uasort($quote_data, 'upscomparecost');


Then Daniel says:
declaring functions in side of classes is not the way to do things!

try this:

uasort($quote_data, array($this, 'comparecost'));


Tried both ways and still no joy at making the checkout page work
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby straightlight » Mon Jan 02, 2012 2:53 pm

Have you cleared your cache and temp files then close browser then retried the checkout process to see if there were different results before stating there's no joy ? ;)

The stored session will stick into checkout until either the checkout is completed or until the user clears its settings even though the stored session may be stored for a temporary time on the customer end.
Regards,
Straightlight
straightlight
 
Posts: 2239
Joined: Mon Nov 14, 2011 10:38 am
Location: Canada, ON

Re: Won't go after step 2 in checkout

Postby SoulV » Mon Jan 02, 2012 3:07 pm

Ahh I thought youd cracked it! ... but no still no joy!
I tried deleting all cookies, cache and made a new user
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby straightlight » Mon Jan 02, 2012 3:12 pm

Unfortunately, many has reported issues on that end and hope to have a fix from the dev team soon enough. :/
Regards,
Straightlight
straightlight
 
Posts: 2239
Joined: Mon Nov 14, 2011 10:38 am
Location: Canada, ON

Re: Won't go after step 2 in checkout

Postby SoulV » Mon Jan 02, 2012 3:14 pm

Fingers crossed! Thanks for your help!
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby Hamatojoshi » Tue Jan 17, 2012 8:39 pm

I think I figured it out.
I had this situation of not going on after 2 step or 3rd step when there was some encode problem with the language files. When it contained some accent letter, like éá, and the code of one or two pages containing the translation was not in Unicode (UTF8) but was in Western-European. Cart did not go on.

When I fixed the coding of those pages, the problem solved 100%.

Jozsef
Hamatojoshi
 
Posts: 3
Joined: Mon Feb 22, 2010 2:19 pm

Re: Won't go after step 2 in checkout

Postby SoulV » Wed Jan 18, 2012 2:22 am

If you have fixed it you have made my dreams come true! (Geeki dreams) How exactly would I correct this error please?
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby Rainforest » Wed Jan 25, 2012 8:53 am

Any fix? Is this just an isolated issue with 1.5.1.3? Bummer as without a fix it's pretty much an unusable cart for most...
Rainforest
 
Posts: 217
Joined: Thu Jan 27, 2011 2:50 pm

Re: Won't go after step 2 in checkout

Postby SoulV » Wed Jan 25, 2012 9:06 am

im with you Rainforest... My cart is usless aswell.
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby Rainforest » Wed Jan 25, 2012 11:18 am

It is "fixed" (not in the currentfiles that you download from the opencart website, maybe david can get on that?) I think it's a really essential module at least for the massive US user base who relay on UPS.

I was kindly directed to a thread which is a little confusing because Qphoria and David get into discussing the fix.

I replaced the code as per instructed.

The quick fix:
1. EDIT: catalog/model/shipping/ups.php

2. FIND:

function comparecost ($a, $b) {
return $a['cost'] > $b['cost'];
}
uasort($quote_data, 'comparecost');



3. REPLACE WITH:
2. FIND:

function upscomparecost ($a, $b) {
return $a['cost'] > $b['cost'];
}
uasort($quote_data, 'upscomparecost');


I ignored the next line and further back and forth between David and Q because it got confusing and I had no clue what they were talking about. I'm not a programmer.
SO, bottom line, just replace the text. I've also added my changed UPS php file. Try it, maybe it'll work for you.
Attachments
ups.php
my changed ups module
(12.03 KiB) Downloaded 85 times
Rainforest
 
Posts: 217
Joined: Thu Jan 27, 2011 2:50 pm

Re: Won't go after step 2 in checkout

Postby SoulV » Wed Jan 25, 2012 3:30 pm

Thanks for the try... I uploaded the file you provided and it still does not work for me. Shame!!!
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby Rainforest » Thu Jan 26, 2012 8:06 am

Then it's maybe your settings. I mean it works for me. Are you using a UPS account? try disabling the USPS module?
Rainforest
 
Posts: 217
Joined: Thu Jan 27, 2011 2:50 pm

Re: Won't go after step 2 in checkout

Postby SoulV » Thu Jan 26, 2012 8:23 am

Im not using ups. Just weight based shipping. All are disabled.

its like the Ajax clogs up. too much demand?????
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby Qphoria » Thu Jan 26, 2012 9:23 am

SoulV wrote:Im not using ups. Just weight based shipping. All are disabled.

its like the Ajax clogs up. too much demand?????


No. there is no issue with using UPS on its own or USPS on its own or any other shipping. It was only the combo of UPS and USPS which rainforest has found to resolve the issue. If you are having issues with just one then it is likely something else. You should be using the checkout patch here to get a better error message:
viewtopic.php?f=133&t=45863

Also you can use firebug to track errors using this guide:
viewtopic.php?f=144&t=43803
User avatar
Qphoria
Administrator
 
Posts: 19202
Joined: Mon Jul 21, 2008 2:02 pm
Donate to Qphoria

Re: Won't go after step 2 in checkout

Postby SoulV » Thu Jan 26, 2012 9:52 am

I think your on to it Q! This is the 1st glimmer of hope since Nov 25th!

The video you linked to is my error, apart from the error notice does not show.

Is it worth me adding your vQmod to combat these errors?

I used firebug and threw me this: (attached a screen shot here http://www.bleujenflorist.com/flowersho ... terror.JPG )

jquery.min.js (line 4)
GET http://www.bleujenflorist.com/flowersho ... s/shipping

403 Forbidden 93ms

jquery.min.js (line 4)
POST http://www.bleujenflorist.com/flowersho ... s/shipping

403 Forbidden 68ms
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby Qphoria » Thu Jan 26, 2012 11:07 am

SoulV wrote:I think your on to it Q! This is the 1st glimmer of hope since Nov 25th!

The video you linked to is my error, apart from the error notice does not show.

Is it worth me adding your vQmod to combat these errors?

I used firebug and threw me this: (attached a screen shot here http://www.bleujenflorist.com/flowersho ... terror.JPG )

jquery.min.js (line 4)
GET http://www.bleujenflorist.com/flowersho ... s/shipping

403 Forbidden 93ms

jquery.min.js (line 4)
POST http://www.bleujenflorist.com/flowersho ... s/shipping

403 Forbidden 68ms


I'm not getting 403 on those links.. Maybe something you have setup in htaccess?
User avatar
Qphoria
Administrator
 
Posts: 19202
Joined: Mon Jul 21, 2008 2:02 pm
Donate to Qphoria

Re: Won't go after step 2 in checkout

Postby SoulV » Thu Jan 26, 2012 11:15 am

I know, me too. Strange eh? My .htaccess is pretty standard (shown below).

The continue button works sometimes... but other times it throws those errors???

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^bleujenflorist.com [nc]
rewriterule ^(.*)$ http://www.bleujenflorist.com/$1 [r=301,nc]

RewriteCond %{THE_REQUEST} ^.*/index.html
RewriteRule ^(.*)index.html$ http://www.bleujenflorist.com/$1 [R=301,L]

redirect 301 /bude-florist-news.html http://florist-bude.blogspot.com/
User avatar
SoulV
 
Posts: 85
Joined: Tue May 04, 2010 9:57 am
Location: UK

Re: Won't go after step 2 in checkout

Postby DragonJ » Sun Jan 29, 2012 11:21 pm

I didn't thoroughly read what other people have done here, but I found this thread because I too was getting stuck at step 2 and step 3.

The fix was to disable the "Free Shipping" shipping option.

Extensions > Shipping > Free Shipping = disable.

I re-enabled this module and it gets stuck again during the checkout process. Only when it's disabled will the checkout process advance. Hopefully that helps some people.
My store is awesomely powered by OpenCart 1.5.5.1.
User avatar
DragonJ
 
Posts: 169
Joined: Sun Jan 29, 2012 3:49 am

PreviousNext

Return to Bug Reports

Who is online

Users browsing this forum: 1975bloom and 35 guests

Hosted by Arvixe Web Hosting