Post by Topsecret » Sat Jul 29, 2017 1:36 pm

Beste medegebruikers.

Sinds een tijdje is OpenCart begonnen met de OC3 versie.
Nu had ik voor de oude OC2 versies een leuke favicon in de admin, eentje die je via de ocmod extensies kon uploaden en installeren.
Deze had ik ook gratis ter beschikking gesteld voor alle andere OC gebruikers.

<modification>
<name>Favicon in Admin</name>
<version>1.0.2</version>
<author>Fred for www.paibkk.com</author>
<code>Favicon in Admin</code>

<file path="admin/view/template/common/header.tpl">
<operation>
<search>
<![CDATA[
<base href="<?php echo $base; ?>" />
]]>
</search>
<add position="after">
<![CDATA[
<link href="view/image/adm.png" rel="icon">
]]>
</add>
</operation>
</file>
</modification>

Nu is het zo dat de .tpl file vervangen is door een .twig file. Beiden gebruiken wel html maar het lukt me niet om de .twig file van admin/view/template/common/header.twig zo aan te passen dat de favicon verschijnt.

De verwijzing zou eigenlijk na regel 6 van de header.twig moeten komen:
<base href="{{ base }}" />
Momenteel aan het testen op http://oc3x.paibkk.com/admin
Login: demo
Password: demo

Na wederom een slapeloze nacht met te veel denkwerk dacht ik dat ik maar eens wat hulp in moest roepen.
Heeft er iemand suggesties of een oplossing?

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am


Post by Frens » Sat Jul 29, 2017 6:52 pm

Moet je dan niet verwijzen naar > admin/view/template/common/header.twig
header.tpl bestaat niet meer zoals je al aangeeft.

Ik kan het niet testen in oc3.0.1.2 , dat is bij mij een zootje wat mods installeren betreft.

Active Member

Posts

Joined
Sat Apr 20, 2013 10:48 pm

Post by Topsecret » Sat Jul 29, 2017 7:02 pm

Beste Frans,

Ik heb het niet over de OC mod maar gewoon over de aanpassing in de header.twig file.
Als de header.twig en evtuele ander files klaar zijn, schrijf ik pas een OC mod.

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am


Post by Topsecret » Mon Aug 28, 2017 8:24 pm

Probleem reeds opgelost...

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am

Who is online

Users browsing this forum: No registered users and 16 guests