Post by Flet » Wed Feb 01, 2017 7:54 pm

Beste allen,
Ik wil mijn installatie OC 1.5.4.6 "verhuizen" van een .nl extensie naar een .com extensie bij dezelfde provider maar nu "ziet" de software de database niet. Er komt geen connectie.
Ik heb de provider (One.com) al om een oplossing gevraagd maar zij schrijven dat alles goed moet werken en laten het daarbij.

Wat ik heb gedaan: Een nieuwe gedownloade installatie van OC 1.5.6.4 geuploaded naar de webruimte met de bedoeling om later, na het installeren, alle gegevens van de webwinkel in .nl te verhuizen naar de nieuwe installatie van .com.
Is er iemand die al eerder met dit bijltje gehakt heeft en hoe heb je het toen opgelost? Ik bedoel dus het connectieprobleem met de database?

Het gaat dus over een webwinkel die nu draait als postcrosscollectief.nl en over moet gaan naar postcrosscollectief.com.

Ik ben hier al twee maanden mee bezig. Heb ook al een andere provider geprobeerd (Neostrada) maar die lieten me ook in de steek. Ik ben op zoek naar een betere provider maar die mag niet te duur zijn omdat we een non-profit "winkel" hebben. En providers uitproberen kost ook heel veel geld.
Last edited by Flet on Sun Feb 05, 2017 12:10 am, edited 1 time in total.

https://postcrosscollectief.com


Active Member

Posts

Joined
Fri Nov 29, 2013 8:36 pm


Post by Dennis K » Thu Feb 02, 2017 9:16 pm

Misschien dat het lukt met de stappenplan op deze pagina; viewtopic.php?f=105&t=92496&hilit=verhuizen

Succes

Newbie

Posts

Joined
Tue Aug 20, 2013 1:01 am

Post by Flet » Fri Feb 03, 2017 4:40 am

Denni K, Bedankt voor je reactie.
Het is een goed stappenplan maar ik strand al in het prille begin.
OC ziet de database niet en dus kan ik zelfs de basisinstallatie niet in orde krijgen.
Ik heb een nieuwe OC gedownloaded en bij step 2 gaat het al fout.
(image invoegen lukt niet)
Dus ik kom al niet verder.
Last edited by Flet on Fri Feb 03, 2017 7:26 pm, edited 4 times in total.

https://postcrosscollectief.com


Active Member

Posts

Joined
Fri Nov 29, 2013 8:36 pm


Post by pprmkr » Fri Feb 03, 2017 3:39 pm

Log in op het Configuratiescherm en vervolgens klikken op 'PHP & Database - MariaDB '.
Daar zie je de database gegevens die je kunt invullen tijdens het installeren van OC.

User avatar
Active Member
Online

Posts

Joined
Sat Jan 08, 2011 11:05 pm
Location - Netherlands

Post by Flet » Fri Feb 03, 2017 7:23 pm

Bedankt voor je reactie pprmkr,

Ik zie dat mijn schermafbeelding niet meer zichtbaar is maar daarop kon je zien wat ik bedoel.
Het invullen van de databasegegevens bij OC is in step 3 van het installatieproces.
Voordat ik daar ben gaat OC eerst controleren of alles waar het programma gebruik van gaat maken "beschrijfbaar / benaderbaar" is. Daar gaat het al mis omdat er een rood streepje (in plaats van groen vinkje) bij de php komt te staan.
Dus ik kom nog niet eens bij step 3. Was het maar waar want dan kon ik een fout gemaakt hebben maar daar heb ik nu de kans nog niet voor gehad. Ook de database bij de provider bestaat wel maar blijft leeg.
Ik kan niet anders concluderen dan dat er iets fout zit bij de provider maar One.com blijft volhouden dat het allemaal goed moet werken.
Op dit moment heb ik een werkende installatie die draait onder de extensie .nl. Mijn vrouw deed het voorstel om dat te veranderen in .com.
Ik weet nog niet goed hoe ik dat moet doen en wat ik allemaal moet aanpassen maar het lijkt vooralsnog de enige oplossing. Dan moet de winkel wel even gesloten worden.

https://postcrosscollectief.com


Active Member

Posts

Joined
Fri Nov 29, 2013 8:36 pm


Post by pprmkr » Sat Feb 04, 2017 6:19 pm

Bedoel je niet versie 1.5.6.4 ?
En de 'rode streep' staat dan achter Extension: MySQL ?

Dat zal kloppen ! One.com serveert standaard PHP 7. Daar bestaat mysql niet meer.
Je dient over te schakelen naar mysqli.

Helaas kun je die niet selecteren in OC 1.5.6.4 voor installatie, alleen als je stap2 voorbij bent.

Ik heb bijgevoegd een aangepaste install, waar mysql vervangen is door mysqli.
Uitpakken en map install kopiëren naar de server.

User avatar
Active Member
Online

Posts

Joined
Sat Jan 08, 2011 11:05 pm
Location - Netherlands

Post by Flet » Sat Feb 04, 2017 10:42 pm

Hoi pprmkr, Ja ik bedoel inderdaad versie 1.5.6.4.
Maar, heel hartelijk bedankt voor deze hulp! Het werkt nu! Het is inderdaad de sqli versie die nu met je install bestandje wel herkent wordt. Intussen heb ik OC weer geïnstalleerd en kan nu met het overzetten beginnen van alle gegevens van .nl naar .com. Ik weet niet wanneer dit veranderd is bij One.com maar het is de eerste keer dat het mij niet lukt om een nieuwe website te installeren.

Het is wel heel treurig dat One.com niet met deze tip / oplossing komt. Zelfs hun eigen "5-minuten-one-click installatie van Wordpress" werkt ook niet meer.
Het minste wat ze hadden kunnen doen is even een attentie naar mij van, let daar eens op. Misschien weten ze het zelf nog niet.

Gelukkig zitten op dit forum wel mensen die je willen en kunnen helpen.
Heel erg fijn dat ik nu verder kan.

https://postcrosscollectief.com


Active Member

Posts

Joined
Fri Nov 29, 2013 8:36 pm

Who is online

Users browsing this forum: No registered users and 7 guests