Post by e-slap » Tue Jan 02, 2018 5:16 pm

Buen Año para Todos!

Alguien sabe decirme si existe información sobre la alteración de las BD. desde OC 1564 para 3020

Alteración como: Cambio de nombre, eliminadas, movidas para otra tabla, etc.....

Saludos!

¡OpenCart es la llave de ignición para su tienda online!

Escoge tu Traducción - Instalación GRATIS!
----------------------------------------------------------------------------------------------------------
Español/Castellano v1.5.6.4 - Español/Castellano v1.5.6.4 (+Extras) - Español/Castellano v2.x
Português/Portugal v1.5.6.4


User avatar
Active Member

Posts

Joined
Fri Jul 22, 2011 12:22 am
Location - Portugal - Argentina

Post by arcovirtual » Wed Jan 10, 2018 9:46 am

yo pregunto lo mismo. estoy con problemas con 2 tiendas instaladas en un mismo hosting. un error 500 se donde se produce el error, solo es en acceso a la base de datos en register y en edit user del back end.- register del front end.
al parecer me restringieron la memoria en el host ya que es un host re-barato muy económico menos de 6 USD xD tengo instalada la misma tienda en varios host y solo en el mas economico sucede el error 500 asi que creo que es cosa de memoria tratare de probar en un multidominio con mas recursos haaber si se sigue produciendo el error. también pense en el puerto de DBbase

New member

Posts

Joined
Thu Jul 07, 2016 9:49 am

Post by ^-^ » Sun Jan 14, 2018 7:23 pm

ummm, no se si lo tendrán documentado que entiendo que es posible ir mirando versión x versión y ver que van haciendo en la base de datos.

La solución que te propongo yo,

Cojes la versión que quieras, imagina la 1.5 .
bajas los ficheros de la base de datos , SOLO la estructura, NO necesitas los datos, por lo que con desde phpmyadmin bajes la estructura de las tablas te vale.
https://prnt.sc/i08b2n

dos clikcs y exportas.

ahora instalas o actualizas a la versión que quieras. y cuando lo tengas vuelves a bajar la estructura.

haces un diff, o cualquier comando similar. y ves las diferencias.

-----

de todas maneras yo he actualizado unas 10-20 webs de clientes, y puedo decir que desde 1.x.x a 2.x.x o 3.x.x todas suelen dar problemas de actualización, y todas hay que tocarlas. yo he tenido que corregir casi todas, por no decir que debéis de quitar las extensiones antiguas , añadir las rutas ... etc etc.. vamos que no actualizan muy bien, aunque al final todas las he puesto a andar.

Hay servicios que te la actualizan por 50 euros creo que es, ya que da bastante problemillas.

^-^
New member

Posts

Joined
Wed Jul 26, 2017 11:42 pm
Who is online

Users browsing this forum: No registered users and 6 guests