Post by widowmaker » Thu Jul 19, 2018 7:27 am

Estimados; a ver si me pueden ayudar. He seguido todos los pasos copiando todos los archivos desde www de wamp a mi servidor. Modifique Config.php par el usuario y para el admin. La pagina funciono correctamente, hasta que algo cambie y me da continuamente error (no aparecen los estilos correctos, no se cargan las imagenes, etc.). Aparentemente tiene que ver con alguna ruta de acceso, pero no logro descubrirlo. Si me pueden ayudar estaria muy agradecido. la url http://www.dianaortizcarteras.com.
Los primeros errores que me aparecen en la consola de chrome (x ejemplo) Son:

GET http://dianaortizcarteras.com/catalog/v ... camera.css 404 (not found)
(index):16 GET http://dianaortizcarteras.com/catalog/v ... zed.min.js 404 (not found)
(index):17 GET http://dianaortizcarteras.com/catalog/v ... /camera.js 404 (not found)
(index):34 Uncaught SyntaxError: missing ) after argument list
(index):78 Uncaught TypeError: jQuery(...).camera is not a function
at HTMLDocument.<anonymous> ((index):78)
at n (jquery-1.7.1.min.js:2)
at Object.fireWith (jquery-1.7.1.min.js:2)
at Function.ready (jquery-1.7.1.min.js:2)
at HTMLDocument.B (jquery-1.7.1.min.js:2)

Attachments

error sitio.jpg

error sitio.jpg (121.87 KiB) Viewed 1101 times


Newbie

Posts

Joined
Tue Jul 18, 2017 3:32 am

Post by widowmaker » Fri Jul 20, 2018 2:14 am

Agrego el contenido de mi archivo CONFIG.PHP y .HTACCESS

// HTTP
define('HTTP_SERVER', 'http://dianaortizcarteras.com/');

// HTTPS
define('HTTPS_SERVER', 'http://dianaortizcarteras.com/admin');

// DIR
define('DIR_APPLICATION', '/home7/dor/public_html/catalog/');
define('DIR_SYSTEM', '/home7/dor/public_html/system/');
define('DIR_DATABASE', '/home7/dor/public_html/system/database/');
define('DIR_LANGUAGE', '/home7/dor/public_html/catalog/language/');
define('DIR_TEMPLATE', '/home7/dor/public_html/catalog/view/theme/');
define('DIR_CONFIG', '/home7/dor/public_html/system/config/');
define('DIR_IMAGE', '/home7/dor/public_html/image/');
define('DIR_CACHE', '/home7/dor/public_html/system/cache/');
define('DIR_DOWNLOAD', '/home7/dor/public_html/download/');
define('DIR_LOGS', '/home7/dor/public_html/system/logs/');



HTACCESS

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

Newbie

Posts

Joined
Tue Jul 18, 2017 3:32 am

Post by SdeSergi » Fri Jul 20, 2018 6:45 pm

Hola,

Soy un novato en Opencart pero la ruta para el https la veo mal "// HTTPS
define('HTTPS_SERVER', 'http://dianaortizcarteras.com/admin');"

Tampoco me cuadran mucho las rutas de acceso definidas "/home7/dor/public_html/...".

A ver si alguien puede echarte un cable. Ánimos :)

Newbie

Posts

Joined
Wed Jul 18, 2018 5:49 pm

Post by widowmaker » Fri Jul 20, 2018 11:03 pm

Muchisimas gracias por contestar!!!! Me fijo y te dejo saber como me fue. Yo tambien soy novato, y la verdad es que revise una docena de veces todo pero no he tenido suerte. En fin. Te aviso como me fue.
Saludos

Newbie

Posts

Joined
Tue Jul 18, 2017 3:32 am

Post by widowmaker » Thu Jul 26, 2018 4:39 am

Gracias a todos los que me ayudaron con este problema!!!! La verdad una maravilla Necesitamos mas foros como este donde la ayuda llega a raudales. Una vez mas un millo de Gracias ???

Newbie

Posts

Joined
Tue Jul 18, 2017 3:32 am

Post by SdeSergi » Thu Jul 26, 2018 5:24 pm

Buenas,

Veo que conseguiste solucionar el problema, ¿no? Bueno no desesperes, la ayuda voluntaria no siempre depende de la voluntad, también de las capacidades... Una forma muy útil de colaborar es la de compartir la solución que cada uno encuentra a sus problemas, así que te animo a que la compartas. ¿Puede ser que hayas desconfigurado el SSL para que la web esté operativa?

Newbie

Posts

Joined
Wed Jul 18, 2018 5:49 pm
Who is online

Users browsing this forum: No registered users and 6 guests