Moderator: madimar

Post by virussino » Tue Feb 21, 2017 12:43 am

Ciao :)
Ho testato questo comando in htaccess, ma se lo provo mi dice "impossibile visualizzare la pagina" (il sito non funziona)

RewriteEngine on
RewriteRule (.*) https://www.vestilanatura.it.it/$1 [R=301,L]

Installato un certificato SSL, vorrei un redirect da HTTP a HTTPS per tutte le pagine, in quanto allo stato attuale effettuando delle ricerche su google capita di aprire il sito indicizzato in HTTP. Una volta aperto il sito in HTTP si vede male, poi basta cliccare su uno qualsiasi dei link (cambiare pagina) per passare in modalità HTTPS

Ho già provveduto a modificare config.php e admin/config.php, ho settato SSL nelle opzioni di OC, ed ho inserito il sito in Google Webmaster (dove adesso vedo sia quello in HTTP che quello in HTTPS

In realtà ho provato anche altri codici trovati online per un redirect, ma nessuno funziona. Quindi è sbagliato il mio htaccess?

RewriteBase /
RewriteCond %{HTTP_HOST} ^(www.)?vestilanatura.it [NC]
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{HTTP_HOST} ^(www.)?vestilanatura.it [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) /buy/index.php?_route_=$1 [L,QSA]
RewriteRule ^([^?]*) /index.php?_route_=$1 [L,QSA]



->
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE image/jpg
AddOutputFilterByType DEFLATE image/jpeg
AddOutputFilterByType DEFLATE image/gif
AddOutputFilterByType DEFLATE image/png
AddType image/svg+xml .svg
AddOutputFilterByType DEFLATE image/svg+xml
->






## EXPIRES CACHING ##

<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access plus 2 days"
ExpiresByType image/jpeg "access plus 2 days"
ExpiresByType image/gif "access plus 1 month"
ExpiresByType image/png "access plus 2 days"
ExpiresByType text/css "access plus 1 month"
ExpiresByType application/pdf "access plus 1 month"
ExpiresByType application/javascript "access plus 1 month"
ExpiresByType text/x-javascript "access plus 1 month"
ExpiresByType application/x-shockwave-flash "access plus 1 month"
ExpiresByType image/x-icon "access plus 1 month"
ExpiresDefault "access plus 3 days"
</IfModule>
## EXPIRES CACHING ##

Eco-friendly Clothing Store for Man and Woman, with a wide selection of Vegan and Made in Italy clothing, bags, underwear. http://www.vestilanatura.it for join the sustainable lifestyle!


User avatar
New member

Posts

Joined
Wed Jul 08, 2015 12:13 am


Post by raikage » Tue Feb 21, 2017 4:24 pm

prova ad inserire questi comandi nel file .htaccess

Code: Select all

RewriteRule (.*) https://www.tuosito.com/$1 [R=301,L]
RewriteCond %{HTTP_HOST} !^www.tuosito.com$ [NC]
RewriteRule ^(.*)$ https://www.tuosito.com/$1 [L,R=301]
poi nei 2 file config come hai settato l'ssl?
perchè sia il define http che https devono essere settato in https, altrimenti non funziona x tutti e 2 i file config.

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by virussino » Tue Feb 21, 2017 9:47 pm

raikage wrote:
Tue Feb 21, 2017 4:24 pm
prova ad inserire questi comandi nel file .htaccess

Code: Select all

RewriteRule (.*) https://www.tuosito.com/$1 [R=301,L]
RewriteCond %{HTTP_HOST} !^www.tuosito.com$ [NC]
RewriteRule ^(.*)$ https://www.tuosito.com/$1 [L,R=301]
poi nei 2 file config come hai settato l'ssl?
perchè sia il define http che https devono essere settato in https, altrimenti non funziona x tutti e 2 i file config.
RewriteRule (.*) https://www.vestilanatura.it/$1 [R=301,L]
RewriteCond %{HTTP_HOST} !^www.vestilanatura.it$ [NC]
RewriteRule ^(.*)$ https://www.vestilanatura.it/$1 [L,R=301]

Con questo sistema mi dice questo:
Questa pagina non reindirizza in modo corretto
Firefox ha rilevato che il server sta reindirizzando la richiesta per questa pagina in modo che non possa mai essere completata.
Questo problema spesso è causato dal blocco o dal rifiuto dei cookie.


I file sono settati così:

config.php

// HTTP
define('HTTP_SERVER', 'https://www.vestilanatura.it/');
define('HTTP_IMAGE', 'https://www.vestilanatura.it/image/');
define('HTTP_ADMIN', 'https://www.vestilanatura.it/admin/');

// HTTPS
define('HTTPS_SERVER', 'https://www.vestilanatura.it/');
define('HTTPS_IMAGE', 'https://www.vestilanatura.it/image/');
define('HTTPS_ADMIN', 'https://www.vestilanatura.it/admin/');



admin\config.php

<?php
// HTTP
define('HTTP_SERVER', 'https://www.vestilanatura.it/admin/');
define('HTTP_CATALOG', 'https://www.vestilanatura.it/');

// HTTPS
define('HTTPS_SERVER', 'https://www.vestilanatura.it/admin/');
define('HTTPS_CATALOG', 'https://www.vestilanatura.it/');

Eco-friendly Clothing Store for Man and Woman, with a wide selection of Vegan and Made in Italy clothing, bags, underwear. http://www.vestilanatura.it for join the sustainable lifestyle!


User avatar
New member

Posts

Joined
Wed Jul 08, 2015 12:13 am


Post by raikage » Wed Feb 22, 2017 2:24 pm

nel file config.php quello nella root principale deve essere settato in questo modo :

Code: Select all

// HTTP
define('HTTP_SERVER', 'https://www.vestilanatura.it/');


// HTTPS
define('HTTPS_SERVER', 'https://www.vestilanatura.it/');
prova in questo modo e controlla che il certificato ssl sia installato correttamente sul server apache su http://www.vestilanatura.it e non su http://vestilanatura.it

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by virussino » Wed Feb 22, 2017 8:33 pm

raikage wrote:
Wed Feb 22, 2017 2:24 pm
nel file config.php quello nella root principale deve essere settato in questo modo :

Code: Select all

// HTTP
define('HTTP_SERVER', 'https://www.vestilanatura.it/');


// HTTPS
define('HTTPS_SERVER', 'https://www.vestilanatura.it/');
prova in questo modo e controlla che il certificato ssl sia installato correttamente sul server apache su http://www.vestilanatura.it e non su http://vestilanatura.it

Niente da fare, sarà un problema del certificato?!
Comunque è stato installato automaticamente da Aruba.


https://www.vestilanatura.it
Il certificato SSL DV è stato correttamente installato sul tuo sito. Clicca sul link sottostante per verificare.
Il tuo sito ora è raggiungibile con protocollo sicuro https. Qualora ne avessi l’esigenza potrai comunque revocare o disinstallare il certificato. Con la Revoca il certificato viene invalidato dalla Certification Authority, mentre con la Disinstallazione viene disinstallato dal sito ma può essere installato nuovamente.

Il certificato SSL DV ha una validità annuale. Alla scadenza verrà rinnovato automaticamente.

Eco-friendly Clothing Store for Man and Woman, with a wide selection of Vegan and Made in Italy clothing, bags, underwear. http://www.vestilanatura.it for join the sustainable lifestyle!


User avatar
New member

Posts

Joined
Wed Jul 08, 2015 12:13 am


Post by virussino » Tue Feb 28, 2017 3:56 pm

risolto da pannello di controllo aruba, senza modificare htaccess

grazie

Eco-friendly Clothing Store for Man and Woman, with a wide selection of Vegan and Made in Italy clothing, bags, underwear. http://www.vestilanatura.it for join the sustainable lifestyle!


User avatar
New member

Posts

Joined
Wed Jul 08, 2015 12:13 am


Post by Hall-1.0 » Thu Jul 27, 2017 10:33 pm

virussino wrote:
Tue Feb 28, 2017 3:56 pm
risolto da pannello di controllo aruba, senza modificare htaccess
Anche per me simile problema OC 2.2.0: il certificato SSL non viene gestito in modo corretto. Anche io ho l'hosting su aruba e dopo innumerevoli tentativi non funziona bene: tutte le icone sompaiono, o ssl funziona solo in home ma come clicchi sul link torna http......
Dici che hai risolto e son contento, da pannello di controllo, ho guardato ma non trovo indicazioni su come fare modifiche, se sei così gentile da pubblicarlo anche per altri che cercano una soluzione al problema !! Grazie.

User avatar
Newbie

Posts

Joined
Thu Jul 27, 2017 10:10 pm

Post by virussino » Tue Sep 12, 2017 3:53 am

Si hai ragione, io ho effettuato l'accesso sul pannello aruba -> Hosting Linux -> Servizi Hosting -> Redirect SSL e impostato su SI



Hall-1.0 wrote:
Thu Jul 27, 2017 10:33 pm
virussino wrote:
Tue Feb 28, 2017 3:56 pm
risolto da pannello di controllo aruba, senza modificare htaccess
Anche per me simile problema OC 2.2.0: il certificato SSL non viene gestito in modo corretto. Anche io ho l'hosting su aruba e dopo innumerevoli tentativi non funziona bene: tutte le icone sompaiono, o ssl funziona solo in home ma come clicchi sul link torna http......
Dici che hai risolto e son contento, da pannello di controllo, ho guardato ma non trovo indicazioni su come fare modifiche, se sei così gentile da pubblicarlo anche per altri che cercano una soluzione al problema !! Grazie.

Eco-friendly Clothing Store for Man and Woman, with a wide selection of Vegan and Made in Italy clothing, bags, underwear. http://www.vestilanatura.it for join the sustainable lifestyle!


User avatar
New member

Posts

Joined
Wed Jul 08, 2015 12:13 am


Post by Margaretha » Mon Sep 18, 2017 1:31 am

Ciao a tutti, grazie ai vostri post sono riuscita parzialmente a trasportare tutto il sito su Https. Anche il mio sito è su Aruba, ma non essendo una nuova installazione non ho il pulsante che dicevate. Ho perciò fatto a mano tutti i cambiamenti su admin/config.php e /config.php oltre ad avere settato SSL su Opencart. E, miracolo, sembra che Journal2 non abbia fatto storie. Il sito quindi adesso è tutto su https e nella barra degli indirizzi, appare il lucchettino verde (su Chrome) e la scritta Sicuro. In tutte le pagine tranne che nella home! Opencart è installato in una sottocartella del dominio, ed è ancora un 1.5.6. Cosa avrò dimenticato di modificare? Vi copio le configurazioni nella speranza che mi possiate illuminare e far apparire il lucchettino Sicuro anche nella home.
in admin/config:
// HTTP
define('HTTP_SERVER', 'https://www.miosito.it/shop/admin/');
define('HTTP_CATALOG', 'https://www.miosito.it/shop/');

// HTTPS
define('HTTPS_SERVER', 'https://www.miosito.it/shop/admin/');
define('HTTPS_CATALOG', 'https://www.miosito.it/shop/');

in /config.php:
// HTTP
define('HTTP_SERVER', 'https://www.miosito.it/shop/');
// HTTPS
define('HTTPS_SERVER', 'https://www.miosito.it/shop/');

in shop/.htaccess:
#Options +FollowSymlinks
RewriteEngine On
RewriteBase /shop
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteRule ^(.*)$ ./index.php/$1 [L]
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]

in miosito/.htaccess
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
#RewriteRule ^(.*)$ ./index.php/$1 [L]
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]

# Turn on Expires and set default to 0
ExpiresActive On
ExpiresDefault A0

# Set up caching on media files for 5 weeks
<FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up caching on media files for 5 weeks
<FilesMatch "\.(gif|jpg|jpeg|png|swf)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up 1 day caching on commonly updated files
<FilesMatch "\.(xml|txt|html|js|css)$">
ExpiresDefault A86400
Header append Cache-Control "proxy-revalidate"
</FilesMatch>

# Force no caching for dynamic files
<FilesMatch "\.(php|cgi|pl|htm)$">
ExpiresActive Off
Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
Header set Pragma "no-cache"
</FilesMatch>

<IfModule mod_deflate.c>
<FilesMatch "\.(js|css)$">
SetOutputFilter DEFLATE
</FilesMatch>
</IfModule>

Grazie !!!
Marg

New member

Posts

Joined
Sat Mar 26, 2011 6:23 pm
Who is online

Users browsing this forum: No registered users and 5 guests