Post by lainlain19 » Sun Apr 30, 2017 9:11 pm

Bonjour.
Je suis nouveau sur le forum et sur opencart.
J'ai un souci avec mes catégories.
Lorsque j'édite un produit, les catégories ne sont pas toutes dans la liste déroulante dans la section liens (il y en a même très peu). Pourtant, elles sont toutes configurée pareil.
Je n'y comprends rien.
Merci par avance de votre aide.
Last edited by lainlain19 on Tue May 02, 2017 7:23 pm, edited 1 time in total.

Newbie

Posts

Joined
Sun Apr 30, 2017 9:05 pm

Post by villagedefrance » Sun Apr 30, 2017 10:12 pm

Bonjour et bienvenue.

La premiere chose a savoir c'est quelle version d'Opencart vous utilisez !?

La seconde c'est de bien verifier que les categories sont bien attribuées à une boutique (store). En général c'est la boutique par défaut, mais il faut bien sur quand meme cocher la case "défaut" dans chaque fiche catégorie.

La troisieme c'est de savoir si vous avez activé le "seo_url_rewrite" dans vos parametres. Si oui, il est vivement conseillé de remplir le champs "seo url keyword" dans vos fiches catégories. Cela dit, les seo_urls ne devraient pas affecter l'administration mais c'est quand meme plus prudent.

.. et finalement il faut bien sur activer chaque catégorie.

Image
Extensions for Opencart @ https://www.villagedefrance.net


User avatar

Posts

Joined
Wed Oct 13, 2010 10:35 pm
Location - UK

Post by lainlain19 » Mon May 01, 2017 1:48 am

Bonjour.
je suis référencé chez LWS qui utilise la dernière version.
j'ai omis de préciser que les catégories apparaissent bien dans la boutique.
C'est juste quand je crée un produit, dans l'onglet lien, qu'elles n'y sont pas toutes dans la liste déroulante.
Mais comme je suis novice, peut-être que je fait une connerie quelque part !

Newbie

Posts

Joined
Sun Apr 30, 2017 9:05 pm

Post by lainlain19 » Mon May 01, 2017 2:16 am

Et je vient de voir que c'est pareil pour créer une catégorie parente, elles n'y sont pas toutes.

Newbie

Posts

Joined
Sun Apr 30, 2017 9:05 pm

Post by lainlain19 » Tue May 02, 2017 7:19 pm

Bonjour.
J'ai trouvé le problème ! Si quelqu'un a le même, voici la solution: Editer le fichier suivant: admin / controller / catalog / category.php. Trouvez "limit" => 5 (en principe tout en bas) et changez-le. Pour ma part j'ai mis 100.

Newbie

Posts

Joined
Sun Apr 30, 2017 9:05 pm
Who is online

Users browsing this forum: No registered users and 5 guests