Post by crawford » Sat Jun 09, 2018 11:12 pm

Hallo zusammen,

nach sehr langer Zeit möchte ich mich mal wieder um den Shop meiner Frau kümmern., dieser basiert auf OC 1.6.0
Ich habe wie immer eine VM eingerichtet , diesmal mit opensuse (fragt nicht warum), Apache 2.4.23, PHP 5.5.14 und MariaDB 10.0.34.

In der error.log bekomme ich folgende Meldung:

Code: Select all

[Sat Jun 09 16:44:42.452174 2018] [php5:error] [pid 30555] [client 192.168.178.43:19263] PHP Warning:  mysqli_connect(): (HY000/1045): Access denied for user 'micha'@'ha-dev' (using password: YES) in /mnt/hgfs/herzensart_live/ha_shop/db-test.php on line 8
oder, ausführlicher bei etwas anderer Konfiguration:

Code: Select all

[Sat Jun 09 16:52:45.340442 2018] [php5:error] [pid 30572] [client 192.168.178.43:19498] PHP Fatal error:  Uncaught exception 'ErrorException' with message 'Error: Could not make a database link (1045) Access denied for user 'micha'@'ha-dev' (using password: YES)' in /srv/www/htdocs/ha_shop/system/database/mysqli.php:9\nStack trace:\n#0 /srv/www/htdocs/ha_shop/system/library/db.php(13): DBMySQLi->__construct('192.168.178.68', 'micha', 'mypass', 'db539344119')\n#1 /srv/www/htdocs/ha_shop/index.php(44): DB->__construct('mysqli', '192.168.178.68', 'micha', 'mypass', 'db539344119')\n#2 {main}\n  thrown in /srv/www/htdocs/ha_shop/system/database/mysqli.php on line 9
Mit phpMyAdmin komme ich von einem remote System auf die DB mit den obigen Logindaten, von der Shell mit

Code: Select all

mysql --user=micha --password=mypass db539344119
klappts auch. Der hostname "ha-dev" wird aufgelöst, eine Firewall ist nicht aktiv. Was übersehe ich?

Danke für einen Tipp,
Gruß,
Micha

New member

Posts

Joined
Mon Dec 28, 2009 8:10 pm

Post by IP_CAM » Sun Jun 10, 2018 12:56 am

Du könntest es vielleicht einmal mit einer etwas neueren mysqli.php Datei
versuchen, entweder aus einer späteren v.1.5.6.x Version, oder dann von hier:
https://www.opencart.com/index.php?rout ... rch=mysqli
Aber das ist nur eine vage Annahme, denn mit v.1.5.6.0 spielte ich nie rum. Ich
würde aber sowieso auf die letzte v.1.5.6.5_rc aufrüsten, um die vielen Fehler
zu beseitigen, die seit 1.5.6.0 noch in dieser Versionsreihe gefunden wurden.
Viel Glück
Ernst
---
https://github.com/IP-CAM/Opencart-1.5.6.5_rc
---

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by OSWorX » Sun Jun 10, 2018 3:24 pm

Hallo,

zum einen 1.6.x gibt es nicht, soweit ich mich erinnern kann habe ich damals 1.4.8 aufgesetzt.
Kann mich nicht mehr erinnern, aber glaube dass wir dann noch auf 1.5.6.5_rc aktualisiert haben.

Generell ist es eine schlechte Idee heutztage noch mit 1.5.x herum zu spielen - egal was andere sagen.

Wenn schon, dann 2.3.0.2 oder -wenn man sich das antun möchte und Twig lernen, 3.0.2.0 (letzte offizielle Version, besser aber die von Github).

Wobei man sagen muss, 3.0.2.0 gibt es mittlerweile bereits seit knapp 1 Jahr, an der Nachfolgeversion wird seitdem herum gebastelt .. und kein Ende in Sicht!
Womit wir dann wieder bei 2.3.0.2 sind, das meiner Meinung nach - noch (und leider) - die beste Wahl ist.

Dann, eine VM mit dem System aufzusetzen zeugt von Mut und viel Zeit - siehe Fehlermeldung.
Dazu ich dir nicht weiterhelfen kann, denn solche Umgebungen interessieren mich nicht wirklich.

Warum?
Alleine die php-Version ist ein Grund das nicht zu verwenden.
Wenn, dann php 7.2.x - macht als einzige Sinn.
Dann gibt es - meiner Meinung nach - bessere Alternativen als ein selbstgestricktes System, denn der Shop soll ja dann letztendlich Live auf einem realen Server laufen, da wäre es somit angebracht, diese Umgebung so ähnlich dem Server auch Lokal zu haben.
Heisst auch alle php-Erweiterungen dazu installiert zu haben.

Sorry, aber ich glaube nicht dass dir hier jemand bei der Konstellation weiterhelfen kann.

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by crawford » Sun Jun 10, 2018 11:02 pm

IP_CAM wrote:
Sun Jun 10, 2018 12:56 am
Du könntest es vielleicht einmal mit einer etwas neueren mysqli.php Datei
versuchen, entweder aus einer späteren v.1.5.6.x Version, oder dann von hier:
https://www.opencart.com/index.php?rout ... rch=mysqli
...
Hallo Ernst,

warum nicht, einen Versuch ist's wert.

Danke & Gruß,
Michael

New member

Posts

Joined
Mon Dec 28, 2009 8:10 pm

Post by crawford » Sun Jun 10, 2018 11:15 pm

Hallo Michael,
OSWorX wrote:
Sun Jun 10, 2018 3:24 pm
zum einen 1.6.x gibt es nicht, soweit ich mich erinnern kann habe ich damals 1.4.8 aufgesetzt.
Kann mich nicht mehr erinnern, aber glaube dass wir dann noch auf 1.5.6.5_rc aktualisiert haben.
Es ist das was im Footer angezeigt wird:
OpenCart / Dt. Übersetzung von OSWorX
© 2009-2018 Alle Rechte vorbehalten.
Version 1.6.0
OSWorX wrote:
Sun Jun 10, 2018 3:24 pm
Generell ist es eine schlechte Idee heutztage noch mit 1.5.x herum zu spielen - egal was andere sagen.
...
Womit wir dann wieder bei 2.3.0.2 sind, das meiner Meinung nach - noch (und leider) - die beste Wahl ist.
Der Shop ist in vielen Teilen angepasst und schon das letzte Update auf die aktuelle Version war eine Menge Arbeit, ich weiß nicht ob du dich daran erinnerst (oder erinnern magst :-)
Zudem ist in den vergangenen 3 Jahren sehr wenig darüber gelaufen, da meine Frau andere Prioritäten hatte. Jetzt geht es wieder weiter.
OSWorX wrote:
Sun Jun 10, 2018 3:24 pm
Dann, eine VM mit dem System aufzusetzen zeugt von Mut und viel Zeit - siehe Fehlermeldung.
Wir haben keinen ssh Zugang zum System auf dem der Shop läuft. Also mache ich es wie von Anfang an mit einer VM, es ist das erste Mal dass ich damit Probleme habe.
OSWorX wrote:
Sun Jun 10, 2018 3:24 pm
Alleine die php-Version ist ein Grund das nicht zu verwenden.
...
Wenn, dann php 7.2.x - macht als einzige Sinn.
Auf dem Server läuft 5.6, also macht php 7.2x in der VM wenig Sinn...

OSWorX wrote:
Sun Jun 10, 2018 3:24 pm
Dann gibt es - meiner Meinung nach - bessere Alternativen als ein selbstgestricktes System, denn der Shop soll ja dann letztendlich Live auf einem realen Server laufen, da wäre es somit angebracht, diese Umgebung so ähnlich dem Server auch Lokal zu haben.
Heisst auch alle php-Erweiterungen dazu installiert zu haben.
Ich sehe für mich keine bessere Alternative, zumal ich wier gesagt bisher nie Probleme damit hatte. Die php-Erweiterungen sind weitgehend identisch.
OSWorX wrote:
Sun Jun 10, 2018 3:24 pm
Sorry, aber ich glaube nicht dass dir hier jemand bei der Konstellation weiterhelfen kann.
Sieht so aus, hätte ja sein könne dass jemand eine Idee hat und fragen kostet schließlich nix :-)

Danke & Gruß,
Michael

New member

Posts

Joined
Mon Dec 28, 2009 8:10 pm

Post by crawford » Mon Jun 11, 2018 12:29 am

Oh Mann wie peinlich und wieder mal typisch:

Es fehlten die Rechte an der DB für das Clientsystem dem ich mit dem Browser zugriff.......

Irgendwie sollte ich die einfachsten Fehlermeldungen mal wörtlich nehmen.......

Code: Select all

...Access denied for user 'micha'@'ha-dev' ...
Schönen Sonntag noch,
Gruß,
Michael

New member

Posts

Joined
Mon Dec 28, 2009 8:10 pm

Post by IP_CAM » Mon Jun 11, 2018 3:04 am

.. und kein Ende in Sicht!
Ich fühle mich Euch, habe aber deswegen trotzdem kein Erbarmen, :P
denn eigentlich sollte man ja wissen, dass die Letzten noch nie die
Ersten waren, sondern doch immer am Besten erstmal nur zum Testen.

Daher ist es mit Sicherheit nicht Ideologie, sondern ganz einfach nur
reine Vernunft, mit den Gegebenheiten umzugehen, und dem, was man
schon kann und kennt, und nicht auch noch für die fernere Zukunft zu planen.
Zumindest solange, bis sich irgendwann der Nebel wieder verzogen hat, und
man hoffentlich wieder weiss, ob, und wohin, die Reise geht.
Ernie
---
Change library/encryption.php compatible to PHP 7.x free, OC v.1.5.6 - 1.5.6.5_rc:
Was aber nicht bedeutet, dass deswegen auch alle Mod's immer noch auch funktionieren!
Aber bis v.7.1.x reicht es in den meisten Fällen, und die gibts noch ein paar Jahre ...
https://www.opencart.com/index.php?rout ... n_id=34060
---

Ernie's OpenCart v.1.5.6.5 LIGHT + V-Pro + OpenShop Admin v.1.75 Test Sites
http://www.bigmax.ch - http://www.opencart.li/shop/ - http://www.velomech.ch/cart/
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by OSWorX » Mon Jun 11, 2018 4:52 am

crawford wrote:
Sun Jun 10, 2018 11:15 pm
Der Shop ist in vielen Teilen angepasst und schon das letzte Update auf die aktuelle Version war eine Menge Arbeit, ich weiß nicht ob du dich daran erinnerst (oder erinnern magst :-)
Ich habe ein sehr gutes Gedächtnis bei dem Wichtigsten ;)
Daher kann ich mich sehr gut erinnern, aber so viel war es auch wieder nicht - nur ein paar spezielle Anpassungen.

Aber wie gesagt, an der aktuellen Version würde ich keine Zeit mehr investieren.

1. Apache 2.4
2. php 7.2
3. OC 2.3.0.2

Der Server sollte 1. & 2. können, ansonsten wäre es besser den Anbieter zu wechseln.

Ist aktuell die beste Kombination.
Und was damals angepasst wurde und wieder benötigt wird, einfach per OCMod ändern - kannst mich ja anschreiben.

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 7 guests