Post by n.kuebler » Sat Feb 24, 2018 8:24 am

Guten Tag,
Ich arbeite mit OpenCart 3.0.2.0 (am 23.02.2018 Update) und PHP 7.2.1 zuvor mit OC 2.x und PHP 7.0.27
Seit mein Hoster PHP 5.4 abgeschaltet hat erhalten meine Kunden Bestellbestätigungen mit zusätzlichen Produkten drauf.
Der Rechnungsbetrag entspricht den bestellten Artikeln inkl. MwSt. und Versand (Egal ob Gewichtsabhängig oder Versandpauschale)
Ich habe gehofft, dass ein Update auf die neuere Version dem abhelfen würde, ist aber leider nicht der Fall.
Auch bei den Produkten, ist kein Muster zu erkennen.
Ich bin um jeden Lösungsvorschlag dankbar.

Newbie

Posts

Joined
Tue Feb 23, 2016 6:34 pm

Post by OSWorX » Sat Feb 24, 2018 4:19 pm

Zum einen ist es schon extrem mutig mit 3.x einen Liveshop zu betreiben da diese Versionen alles andere als Feherlfrei sind!
Zum anderen wüsste ich nicht was die php-Version mit zusätzlichen Artikeln in den Bestellemails zu tun hat ..

Sind noch zusätzliche Erweiterungen in Verwendung?
Welche Vorlage wird verwendet?

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by n.kuebler » Sat Feb 24, 2018 4:37 pm

Guten Tag,
Ich war mit der Version 1.5.x eigentlich sehr zufrieden, diese wurde jedoch von meinem Hoster (Cyon.ch) nach einer Serverumstellung nicht mehr unterstützt, resp. lief nicht unter PHP 5.4 (Weisser Bildschirm)
Auch mit der Version 2.0.2 von Opencart war ich bis vor 2 Wochen zufrieden, da diese einwandfrei funktionierte.
Grundsätzlich arbeite ich mit dem Standard (default) Layout ohne zusätzliche installationen. Einzige Ausnahme: die deutsche übersetzung.
Der Umstieg auf 3.0.2.0 erfolgte ausschliesslich deshalb, da ich den Fehler in der PHP version vermutete, was sich ja leider nicht bewahrheitet hat.
Ein Downgrading auf 1.5.x ist jedoch leider nicht möglich, da ich auf keine PHP Version zugreifen kann, mit der der Shop noch laufen würde.

Newbie

Posts

Joined
Tue Feb 23, 2016 6:34 pm

Post by OSWorX » Sat Feb 24, 2018 5:16 pm

Wenn schon dann 2.3.0.2
Ist aktuell noch immer die stabilste Version.
Und funktioniert einwandfrei mit php 7.1. und 7.2 - die meisten unserer Kunden auf unseren Servern verwenden eine dieser beiden.
Falls dennoch 1.5. verwendet werden soll - was ich nicht empfehlen würde, kann ich dir dazu etwas anbieten.

Image


User avatar
Expert Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 2 guests