Post by eventec » Mon Oct 02, 2017 2:08 am

Hallo zusammen,

wir suchen einen Open Cart Designer für unseren Shop.
Es wäre schöne wenn sich ein professioneller Designer/in bei uns melden würde.

info@light-sound.at

Danke
schöne Grüsse
Andi

Newbie

Posts

Joined
Mon Oct 02, 2017 2:05 am

Post by IP_CAM » Tue Oct 03, 2017 5:25 am

Uhhh, das könnte dann aber etwas teurer werden, umsomehr, weil man Euch dann
wohl auch grad eine neue OC-Version aufschwatzen wird, und Euch für die Anpassung
der bestehenden Datenbank und Funktionen dafür allein wahrscheinlich schon
einen schönen Batzen Geld aus der Tasche ziehen möchte. Und wenn Ihr auch noch
irgendwelche VqMods oder Anderes eingebaut habt, wird's noch teurer, weil ja gar
nichts mehr passt. Absolut nichts, mit Ausnahme des Datenbestandes, der in teils
neue oder umbenannte 'Sektionen' der neuen Datenbank am richtigen Ort wieder
einzufügen ist, damit die bestehenden Kunden, Artikel, und deren Inhalt, wieder
online zur Verfügung stehen.

Aber was bei der aktuellsten Version von einem FAN zurzeit als Fixes zu Papier
gebracht wird, kann man momentan auf der Beitragsseite 'Unbeantwortete' erkennen,
seitenweise Fixes, für Etwas, was das Beste sein soll, zumindest von Dem, was nach
OC v. 1.5.6.5_rc so alles schon als vermeintlich wirklich besseres erschienen und
angepriesen worden ist.
Und in wenigen Wochen kommt dann die Nächste, und das Spiel beginnt von vorn, und
was vorher war, interessiert eigentlich nur noch die, die es benutzen. Aber bei einem
Projekt, welches sogar nach Aussen nie mit Versionsnummern hausierte, wie andere
das tun, sollte es auch Allen klar sein, dass es sich um ein 'ongoing Project' handelt,
und nicht um jeweils fixfertige und updatebare Vollversionen. :'(

Und dazu ist es kostenlos. Und ohne jede Garantie. ;)
---
Aber so, wie es aussieht, fehlt Euch eigentlich nur ein passendes Thema, responsiv
natürlich, um den heutigen Gegebenheiten zu entsprechen. Und sonst nix, im Prinzip,
wobei natürlich bei Umbauten auch immer noch gern Wünsche anfallen, nur, für Eure
Version weiss man ja bereits bestens, was taugt, und was nicht.

Zu den Themen selbst:
Es existieren grundsätzlich zwei Arten davon:
---
Eine moderne mit aktueller Bootstrap-3 Technologie, die aber verändert so ziemlich
alles, so dass VqMod-Verlinkung und visuelle Darstellung von v.1.5.6.x Mods mit
solchen Themen meist nicht weiterhin anpassungsfrei funzt.
---
Und eine einfache, welche in visuellen Bereichen meist kompatibel bleibt, wenn
es um Erweiterungen geht, die im visuellen Bereich irgendwo mit bestehender
Source 'interagieren' sollen. Und das hat zur Folge, dass in willkürlich gewählten
Browser-Auflösungen teils unschöne Darstellungen entstehen.

So sorgt modernes Bootstrap-3 über die ganze Bandbreite des Screen Resolutions
Spektrums für eine perfekte Darstellung, währenddem die einfache Themen-Technik
vielfach relativ 'breite' Bereiche für eine Darstellungsform 'definiert', und so 'sichtbar'
lässt, was gegebenenfalls noch nicht, oder nicht mehr, sichtbar sein sollte.
EIne relativ sehr gute Lösung, um solches zu vermeiden, wären Sektionen wie:
340 - 480 / 481 - 645 / 646 - 801 / 802 - 1025 / 1026 - 1281 / 1282+ Pixel
---
Eine Anzahl kostenloser einfachere responsive Themen findet man hier:
https://www.opencart.com/index.php?rout ... _license=0
und ein angepasstes Beispiel dieser Themen, das mir am Besten gefallende
YOOHAN Model, ist hier zu sehen, ich habe allerdings bereits Einiges schon
ziemlich stark verändert:
http://www.ebikes.li
---
Moderne Varianten mit Bootstrap-3 responsive Technology:
---
Bootstrap-3, Merkent Theme, helles oder dunkles Stylesheet inkl.,
nahezu perfekt aufgebaut, mit 'globalen' Routinen, wo gleiche Darstellungsformen
gebraucht werden, wie z.B. Grid / View Listings. Ist so nicht mehr ganz OC DEFAULT,
man kann dafür andere Erweiterungen ganz leicht an diese Technik anpassen, oder
bestehende Files in 'resposive format' umschreiben, wo solches ggfls. erforderlich wäre.
Kostenpflichtig:
http://www.ocshop.li/
Hersteller:
https://www.opencart.com/index.php?rout ... n_id=16822
---
Original Opencart v.2.0.3.1 responsive Bootstrap Thema, angepasst auf OC v.1.5.6.5
Peku's kostenlose Version, funktioniert identisch wie ein OC-2 Thema. Hat sogar OcMod
dabei, wobei das eigentlich nutzlos ist, weil man die VqMods ja alle dafür leicht umschreiben
müsste!
Wobei, es existiert ein Online Tool, wo man ganz einfach VqMods zu OcMods machen
kann! Also, für Edelbaster, go ahead, einen gratis v.1.5.6.5 OcMod Editor hätt ich auch
noch irgendwo!
http://openshop.li/downloads/ocmod_editor_156.jpg
VqMod könnte man so, in den meisen Fällen zumindest, einfach vergessen.
http://dyisol.com/vqmod-to-ocmod-conversion-tool.php
Oder dann sollte man besser die OcMod Installation von Anfang an unterbinden, um OcMod
so nicht ganz automatisch immer aktiv zu haben. Ich habe ein Bild gemacht, um zu zeigen, welche
Werte dafür geändert werden sollten, BEVOR man die Software installiert:
download/file.php?id=29562
http://www.opencart.li/
Hersteller:
https://www.opencart.com/index.php?rout ... n_id=23641
Oder das OC-2 Thema im vollen Paket, mit dem letzten OC v.1.5.6.5_rc Release ausgestattet.
https://www.opencart.com/index.php?rout ... n_id=23641
Der einzige Nachteil dieses Contributors ist, dass es sehr schlecht englisch
versteht und schreibt, und's noch ein paar meist ganz kleine Fehlerchen gibt .... ::)

Zudem ist das OC-2 Thema ja dann Default, und mit ihm einige Dinge, die so nicht mehr
ganz dem 1.5.6.x Standard entsprechen. Andere Themen könnten so zum Beispiel
die 'Pagination' - Darstellung fehlerhaft wiedergeben. Ich würde daher eher die Themen-
Erweiterung als Zusatzthema in ein 1.5.6.5 System installieren, dann lässt sich
auch alles wieder ausschalten, falls erforderlich. Einfach, um das auch noch anzumerken.
---
Bootstrap-3 Theme, kostenlos, gut und ohne grosse Systemänderungen, und läuft wirklich
einwandfrei. Etwas grob geschnitzt, in einigen Bereichen, lässt sich aber alles nachfixen:
http://www.ipc.li/
Hersteller:
https://www.opencart.com/index.php?rout ... n_id=14631
---
Und als Abschluss noch die letzte OC v.1.5.6.5_rc Version, denn die solltet Ihr sowieso einsetzen,
da gegenüber der v.1.5.6.4 noch einige nicht unwichtige Fehler gefixt worden sind.
https://github.com/myopencart/opencart/tree/v1.5.6.x
Die 1.5.6.5 wurde, zugunsten ihres v.2.0-Nachfolgers, den es zu diesem Zeitpunkt bereits
schon gab, nicht mehr offiziell als 'final' deklariert und gelistet, denn/und/aber so zweigleisig
weiterzufahren war nicht vorgesehen.

Zwar nicht sehr qualitäts-orientiert, gegenüber Usern, aber imerhin liess man den Link zum
Download am Leben, auch wenn auf der offiziellen Liste und im _RC Forum darüber nichts zu
finden ist. So mach ich halt gelegentlich auf 'Linki', solange man mich lässt ... :D
---
Einfach, um eine der Möglichkeiten aufzuzählen, einen Shop weitgehend übergangslos
auf etwas Neues anzupassen, ohne deshalb nochmal von vorn beginnen zu müssen, denn
auch die Administration funktioniert völlig anders als, was man sich vielleicht gewohnt ist.
Und administrativ ändert sich durch 'NUR'- Themen faktisch nichts, ganz im Gegensatz
zu anderen und teils technisch massiven Erweiterungen, wie Journal, Pavo, und so weiter.

Und Ihr könnt dann immer noch einen guten CSS-Insider anstellen, um ein Thema so zu 'tunen',
dass es überall genau so passt, wie Ihr das möchtet.
---
Einfach als Gratis-Tip, und meine Meinung, ich hab ja nix davon ... :D
Aber wenn schon schreiben, dann doch so, dass man sich später nie wiederholen muss ... :laugh:
Viel Glück !
Ernst

Ernie's OpenCart v.1.5.6.5 LIGHT + OpenShop Admin v.1.75 Test Sites
http://www.ebikes.li - http://www.evelo.li - http://www.openshop.li
Image


User avatar
Guru Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 8 guests