Post by JNeuhoff » Mon Jul 29, 2013 1:36 am

I was trying in vain to upload updated versions of the Override Engine to the Opencart extensions, and keep getting a 'Incorrect file type!' error. Can someone please fix this?

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by mobilewill » Tue Oct 01, 2013 11:39 am

I ended up using rar. I am not sure why zip doesn't work when others are able to use it. I was using Chrome, I don't know if that has anything to do with it.

Current VQMods: http://www.opencart.com/index.php?route ... mobilewill
Blog: http://www.mobilewill.us
Shop: http://friedcircuits.us


Newbie

Posts

Joined
Tue Oct 01, 2013 10:15 am

Post by MrTech » Wed Oct 09, 2013 10:19 am

I've tried to upload a zip file in Chrome and Firefox with the same incorrect file type error.

Adding my vote 'to please fix it'.

~
Install Extensions OR OpenCart Fast Service! PayPal Accepted
I will professionally install and configure any free or purchased theme, module or extension.

Visit http://www.mrtech.ca if you need an OpenCart webmaster
~


User avatar
Active Member

Posts

Joined
Mon Jan 09, 2012 2:39 pm
Location - Canada, Eh!

Post by mobilewill » Wed Oct 09, 2013 10:24 am

Did rar work for you?

Current VQMods: http://www.opencart.com/index.php?route ... mobilewill
Blog: http://www.mobilewill.us
Shop: http://friedcircuits.us


Newbie

Posts

Joined
Tue Oct 01, 2013 10:15 am

User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by mobilewill » Wed Oct 09, 2013 11:54 pm

MarketInSG wrote:well, it doesn't seem to be an issue on my side :) try using IE

I am pretty sure I did, but I can't remember if tried compatibility mode. I am on IE10.

Current VQMods: http://www.opencart.com/index.php?route ... mobilewill
Blog: http://www.mobilewill.us
Shop: http://friedcircuits.us


Newbie

Posts

Joined
Tue Oct 01, 2013 10:15 am

Post by MrTech » Thu Oct 10, 2013 12:15 am

Thanks MarketInSG - Internet Explorer did the trick.

To recap: ZIP files only seem to upload in IE

Did not test RAR, sorry.

~
Install Extensions OR OpenCart Fast Service! PayPal Accepted
I will professionally install and configure any free or purchased theme, module or extension.

Visit http://www.mrtech.ca if you need an OpenCart webmaster
~


User avatar
Active Member

Posts

Joined
Mon Jan 09, 2012 2:39 pm
Location - Canada, Eh!

Post by MarketInSG » Thu Oct 10, 2013 11:44 am

I don't have any issues with any of the browsers. Try testing on a separate system and maybe we can find something out.


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by hirdhird » Sun Oct 20, 2013 7:24 am

I confirm the same error - I get "file type error" when trying to upload ZIP extension in Firefox (v.24) on Windows 7.
In IE 10 the same file uploads without problems

Newbie

Posts

Joined
Sun Oct 20, 2013 6:53 am

Post by rph » Mon Oct 21, 2013 1:52 am

Chrome will work too. Not sure why it only happens to Firefox.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by billynoah » Mon Oct 28, 2013 9:40 am

i had this problem as well.. using IE as a "fix" would be a first.

Let's get this straightened out please.

Image


User avatar
Active Member

Posts

Joined
Tue Jan 15, 2013 12:46 pm

Post by isveta78 » Fri Apr 25, 2014 9:55 pm

I have a same problem. I've tried to upload zip, rar files in Chrome, IE 11 and Firefox, and keep getting a 'Incorrect file type!' error.

Newbie

Posts

Joined
Fri Apr 25, 2014 9:52 pm

Post by trueliar » Tue Apr 29, 2014 6:51 pm

Same problem for me with rar zip (7z never worked also before).
The header of the binary files and the file extensions are correct.
I've also tried to send the file with different mime types (tamper data) but I received the same error.
Could it be a check on the mime-type?

New member

Posts

Joined
Sat Jan 11, 2014 12:09 am

Post by paradoxx » Fri Jul 11, 2014 3:44 am

I had this issue fixed with an older version of Firefox (v.27) but when I updated to the 30 I cannot get it to work again. It is like firefox put a mask on the zip files.

Sadly, I have to use IE to upload files :/

New member

Posts

Joined
Sun Jun 30, 2013 5:56 am

Post by bachelor » Sat Sep 27, 2014 6:10 pm

Uploading module zip file name xxxx.ocmod.zip uploading ok but need xml to folder index

Newbie

Posts

Joined
Wed Apr 16, 2014 2:19 am

Post by JNeuhoff » Sun Sep 28, 2014 2:21 am

bachelor wrote:Uploading module zip file name xxxx.ocmod.zip uploading ok but need xml to folder index
Can you please post it as an issue on github, with an example on how to reproduce it. Or post it on the atlassian bugtracker.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by budgetneon » Wed Oct 15, 2014 11:05 pm

Related to this...

Since the new ocmod system allows end users to upload extension.ocmod.xml files, shouldn't the extension store allow developers to upload theirextension.ocmod.xml, without having to put that in a zip file? ( And of course, making sure that it's downloaded as a file when the user downloads, versus displaying the xml in the browser)

That would allow for a very straightforward download from the store, and then upload/install for the end user, without the end user of the module having to unzip anything.

New member

Posts

Joined
Sat Sep 20, 2014 11:32 pm


Post by opencartdeveloper » Thu Feb 26, 2015 1:38 am

I'm not able to upload zip and it is giving me:

Warning: file could not be uploaded for a unknown reason!

Any help?

Active Member

Posts

Joined
Sat Jul 23, 2011 1:48 am

Post by vcabreu.py » Thu Jan 14, 2016 12:37 am

Ello mate, i`ve fixed this error in my store by adding the MIME types on the configuration

check if u got application/x-rar-compressed, application/octet-stream and application/zip on your MIMEs ($this->System->configuration.... server tab)

:joker:

User avatar
Newbie

Posts

Joined
Thu Jan 14, 2016 12:30 am
Location - Americana | São Paulo | Brazil

Post by trueliar » Mon Mar 14, 2016 3:43 am

vcabreu.py wrote:Ello mate, i`ve fixed this error in my store by adding the MIME types on the configuration

check if u got application/x-rar-compressed, application/octet-stream and application/zip on your MIMEs ($this->System->configuration.... server tab)

:joker:
We are talking about the Website www.opencart.com (extensions upload).

New member

Posts

Joined
Sat Jan 11, 2014 12:09 am
Who is online

Users browsing this forum: No registered users and 2 guests