Post by JIMSLITA » Thu Mar 06, 2014 12:43 am

HI Ryan

I have been trying, unsuccessfully, to write a little VQMod to have the Error Log Heading on my Dashboard/AdminMenu so that it would show Red if there's an error. Sometimes you install a new VQMod and it seems to work fine, only to discover later that has clashed with something along the way - it's just that you don't look at the VQMM interface every 5 minutes but often are on the dashboard or browsing Admin.

Would you be kind enough to give me a couple of pointers as to what I should be trying to pull out to insert this in one or other locations please? I would have thought this would be a useful addition to this indispensable resource too ;) I have created a new Menu Item 'VQMod Error' after between Dashboard and Catalog (as it was the easiest place to start) but I can only make it a shortcut to VQMM but I can't get it mimic the error-tab behaviour.

Thanks

Jim

OC v 1.5.4 with alot of tweaks,exts & mods.


User avatar
New member

Posts

Joined
Fri Feb 08, 2013 3:49 pm

Post by rph » Thu Mar 06, 2014 11:30 am


-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by IP_CAM » Wed Mar 19, 2014 10:16 am

I have sucessfully installed the 'VQMod Manager' in my OpenShop 1.6 (OC 1.5.6.1) Setup, everything seems to work well, I can deactivate as well as delete VQMOD files. I will use it besides ofthe built-in VQMod-Manager, supplied in the OS1.6 Software. It's even multilanguage, great stuff!!

If you add other Mod's to the Admin Section, the only thing missing will be a little pic in the selection Field, as shown in Image below to look nice...

Image

I have made a little Fastdraw-Mod to add the 2 missing pics:

Image

Below Image displays the [MOD] VQMod Manager as installed on my Server.

Image

Here is the ZIP:

http://www.ipc.li/os/iconmod01.zip

Ernie from Switzerland
ipc.li/cart
Last edited by IP_CAM on Thu Apr 03, 2014 12:38 pm, edited 4 times in total.

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Wed Mar 19, 2014 10:28 am

JIMSLITA wrote:HI Ryan
Sometimes you install a new VQMod and it seems to work fine, only to discover later that has clashed with something along the way -Jim
Jim, I have this VQMOD Troubleshooter in my OpenShop 1.6 (OC 1.5.6.1), it's a very efficient tool to find out if you have possible errors within your xml-file section. Figured to inform you on this. Please check my comments above.

Ernie

For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by djbosanac » Sat Aug 02, 2014 2:41 am

Hello

have a problem installing it:
When i go to vqmod/install i get a error: Administrator index.php not writeable
What to do? because all the maps are on 777 using a paid webhosting.

Can somebody help me out...

....Only God Can Judge Me....


Active Member

Posts

Joined
Thu Sep 01, 2011 10:12 pm
Location - Saarland, Germany

Post by jazibshaikh » Thu Aug 14, 2014 12:25 pm

Hi... I am very new at this... I have installed vQmod but recently its showing me error:
VQMod does not appear to be properly generating vqcache files!
I tried to re-install it with update vQmod version and re-installed new vQmod Manager but does seem to be helping.

Any assistance in this regard will be greatly appreciated.

regards

Newbie

Posts

Joined
Fri Nov 29, 2013 6:45 am

Post by TLEwebdevs » Sat Mar 14, 2015 12:06 am

rph wrote:
vapestore wrote:
JAY6390 wrote:Yes it needs to be uploaded to your new admin folder
Hello JAY6390, need little extra help if you don't mind: as said before my admin folder has been renamed. I'm getting this error in my log and I'm assuming because the admin folder has a different name. Can I fix this and how?

thanks
If you have vQmod 2.3.2 edit /vqmod/pathReplaces.php with the custom path. The file will have examples how to do it.
Is there also a file something like /ocmod/pathReplaces.php with options to edit the custom path?

I ask because with a renamed /admin/ folder in 2.0.1.1 I cannot upload any extensions - just keep getting a server 500 error no matter what I try.

hoping you can/will help on this query.

User avatar
Newbie

Posts

Joined
Fri Mar 13, 2015 6:25 pm

Post by JAY6390 » Sat Mar 14, 2015 12:09 am

OCMod has nothing to do with VQMod and I'm pretty sure it doesn't exist

ImageImageImage

SEO MEGA KIT PLUS - Get your site ranking higher in the search engines
Better Product SEO URL's - Perfectly structured product links
SEO URL's Route Editor PRO - Make ANY url on your site have clean keywords - even third party extensions (remove index.php)


Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by TLEwebdevs » Mon Mar 16, 2015 9:48 pm

JAY6390 wrote:OCMod has nothing to do with VQMod and I'm pretty sure it doesn't exist
OK, I've solved the fcgid error - it required adjusting the maximum file length setting in the fcgid.conf file server-side and updating the same for the domain settings in Plesk. If anyone needs instructions for what to do, Google brings up lots of pages telling you that.

However, I now get another error midway through uploading an ocmod file that is linked to vqmod ....
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

OK

<b>Warning</b>: ftp_login(): Login incorrect. in <b>/var/www/vhosts/mydomain.com/httpdocs/opencart/vqmod/vqcache/vq2-admin_controller_extension_installer.php</b> on line <b>295</b>{"error":"Could not login as ftp-user-id"}
The ftp user settings are correct in store - ftp ... I even tried using the VPS root admin credentials and they had no success.

This is on an OC 2.0.1.1 clean install with vqmod as the only installed extension. The vqmod routes file has been updated with the new name for admin folder etc.

Anything I might have missed?

User avatar
Newbie

Posts

Joined
Fri Mar 13, 2015 6:25 pm

Post by Farzana » Tue Mar 24, 2015 11:49 pm

Hi we are using vqmode 2.5.0 and opencart version 2.0.0. I wanted to install a file managing or pdf upload module. But I cannot find any extension installer in admin or any other options in admin. We found vqmod is not working on this website. Any idea how to get file upload module and vqmod working.

Thanks!

New member

Posts

Joined
Tue Mar 17, 2015 11:19 pm

Post by djbosanac » Sun May 24, 2015 4:33 pm

Hello,

we have vqmod installed, but now we want vqmod manager for easy installation in the back-end for our customer.
But where can i find vqmod manager for OC2.0.1.1?? thanks in advance!!1

....Only God Can Judge Me....


Active Member

Posts

Joined
Thu Sep 01, 2011 10:12 pm
Location - Saarland, Germany

Post by IP_CAM » Mon May 25, 2015 1:02 am


For Sale: Top URL's, including an OpenCart V-Pro Shop!
A wide range of matching Designs can be seen here: http://www.opencart.li
For Information on URL's offered, please contact me at: jti@jacob.ch
Hundreds of Mods in 380+ Repositories for OC v.1.5.x - v.2.3.x
to be found on my Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by rph » Wed May 27, 2015 1:02 am

I really wish the extension store would stop people from using the same/similar name of other extensions. I'm sick and tired of creating something popular than having some other dev jumping on it.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by soundzgood-nz » Fri Nov 20, 2015 2:08 am

This is occuring in VQMod Manager (v2.3.0 ?) in 1564 cart admin - changes every time you reload the screen between the two:

Not looking ok (all showing as invalid syntax):
Image

Looking ok:
Image

Checked permissions, folders are writable, disabled all vqmod xmls except opencart xml and Manager's shortcut xml (still does it) ... should point out vqmod extensions are still working regardless so think it's an issue with Manager ?

Thanks
Simon

User avatar
Active Member

Posts

Joined
Sat Oct 25, 2014 5:15 pm
Location - New Zealand
Who is online

Users browsing this forum: No registered users and 10 guests